View Issue Details

IDProjectCategoryView StatusLast Update
0003180Ham Radio DeluxeBugpublic2019-02-24 15:13
ReporterK7ZCZAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version6.4.0.907 
Target VersionFixed in Version6.5.0.196 
Summary0003180: Progress bar in ADIF import doesn't work correctly
DescriptionThe progress bar on the ADIF import dialog shows progress of different operations: reading the file line by line, chopping the lines into records, analysing the records, loading the records into the database.

The allowable range of a Windows progress bar is 0 to 65,536. The code doesn't scale any of the quantities it shows; if there are 175,000 lines in the file, it tries to set and show the control through a range from 0 to 175,000. But that doesn't work, since the limit is clamped to 65,536. From that point in the progress on, the control looks full (complete) but the program is still working and doesn't indicate progress.

Steps To Reproduce1) Fire up the Logbook
2) Connect to (or create) a new database
3) use the "Import" command to import a very large AIDF file

BUG#1) After a while the progress bar will be completely full, but the program is still working.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleAppearance/UI
Testing Beta Successful

Activities

K7ZCZ

2019-02-17 15:47

administrator   ~0007421

fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4833

WA9PIE

2019-02-20 00:07

administrator   ~0007444

Validated (nice work)

Issue History

Date Modified Username Field Change
2019-02-16 17:10 K7ZCZ New Issue
2019-02-17 15:47 K7ZCZ Assigned To => K7ZCZ
2019-02-17 15:47 K7ZCZ Status new => resolved
2019-02-17 15:47 K7ZCZ Resolution open => fixed
2019-02-17 15:47 K7ZCZ Note Added: 0007421
2019-02-19 19:04 K7ZCZ Fixed in Version => 6.5.0.194
2019-02-20 00:07 WA9PIE Status resolved => closed
2019-02-20 00:07 WA9PIE Description Updated View Revisions
2019-02-20 00:07 WA9PIE Steps to Reproduce Updated View Revisions
2019-02-20 00:07 WA9PIE Testing Not Started => Beta Successful
2019-02-20 00:07 WA9PIE Note Added: 0007444
2019-02-24 14:36 WA9PIE Fixed in Version 6.5.0.194 => 6.5.0.196
2019-02-24 15:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe