View Issue Details

IDProjectCategoryView StatusLast Update
0003185Ham Radio DeluxeBugpublic2019-02-24 15:12
ReporterK7ZCZAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version6.4.0.907 
Target VersionFixed in Version6.5.0.196 
Summary0003185: Logbook's metadata structures could be faster
DescriptionThe Logbook maintains several maps of logbook column names to various attributes, such as length, data type, screen name, and so on. Theses are implemented by instances of the MFC CMap<> templated class.

Each instance tracks about 140 columns. However, they use the default hash table size of 17, which results in poor, near-linear lookup performance. Because these maps are consulted once per column, once per row, the effect of any inefficiency in their implementation is significantly amplified. At intialization, InitHashTable() should be called to set the size of the hash table to a size appropriate for its anticipated capacity.

TagsNo tags attached.
ModuleLogbook
Sub-ModuleData
Testing Not Tested

Activities

K7ZCZ

2019-02-17 14:15

administrator   ~0007418

fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4831

WA9PIE

2019-02-19 23:59

administrator   ~0007442

Accepted without validation.

Issue History

Date Modified Username Field Change
2019-02-17 14:09 K7ZCZ New Issue
2019-02-17 14:15 K7ZCZ Assigned To => K7ZCZ
2019-02-17 14:15 K7ZCZ Status new => resolved
2019-02-17 14:15 K7ZCZ Resolution open => fixed
2019-02-17 14:15 K7ZCZ Note Added: 0007418
2019-02-19 19:04 K7ZCZ Fixed in Version => 6.5.0.194
2019-02-19 23:59 WA9PIE Status resolved => closed
2019-02-19 23:59 WA9PIE Description Updated View Revisions
2019-02-19 23:59 WA9PIE Testing Not Started => Not Tested
2019-02-19 23:59 WA9PIE Note Added: 0007442
2019-02-24 14:36 WA9PIE Fixed in Version 6.5.0.194 => 6.5.0.196
2019-02-24 15:12 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe