View Issue Details

IDProjectCategoryView StatusLast Update
0003190Ham Radio DeluxeBugpublic2019-05-27 15:04
ReporterWA9PIEAssigned ToJOSE 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.5.0.196 
Summary0003190: Cannot connect to rotor controller due to baud rate problem (GS-232B)
DescriptionWhen attempting to connect to the rotor controller with the Rotor Control app, the app attempts to connect with "600,n,8,1". Maybe this is a typo? It should be either 4800 or 9600. The rotor controller (GS-232B in this case) will not support a baud rate less than 1200.

We need to change the baud rate to either 4800 or 9600 baud (N, 8, 1).
Steps To ReproduceAttempt to connect... look in logfile and note that a connection fails when attempting to connect with 600,n,8,1.
Additional Information22:49:10 COM14 Rotator Yaesu GS-232B Az/El
22:49:10 COM14 Connecting to COM14
22:49:10 COM14 Setting I/O buffer queue sizes to 2048, 2048
22:49:10 COM14 Setting device control to 600,n,8,1
22:49:10 COM14 Setting comms state
22:49:10 COM14 DTR control ..: 1
22:49:10 COM14 RTS control ..: 0
22:49:10 COM14 XON char .....: 11
22:49:10 COM14 XOFF char ....: 13
22:49:10 COM14 Error char ...: 3F
22:49:10 COM14 XON limit ....: 512
22:49:10 COM14 XOFF limit ...: 512
22:49:10 COM14 Setting timeouts
22:49:10 COM14 Read interval ............: 2000
22:49:10 COM14 Read total multiplier ....: 400
22:49:10 COM14 Read total constant ......: 2000
22:49:10 COM14 Write total multiplier ...: 200
22:49:10 COM14 Write total constant .....: 1000
22:49:10 COM14 Setting DTR, clearing RTS
22:49:11 COM14 Connected to COM14
22:49:11 COM14 Get status> Send 43-32-0D
22:49:13 COM14 Get status> Timeout reading 20 bytes from COM14
22:49:13 COM14 Get status> Recv 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
TagsNo tags attached.
ModuleRotator
Sub-ModuleInterfacing
TestingNot Started

Activities

WA9PIE

2019-02-21 09:24

administrator   ~0007466

There was no problem. I just didn't see the setting. That said, I think we should change the default to 4800 (from 600).

JOSE

2019-02-24 19:12

developer   ~0007498

Default rate for all Yaesu Rotators has been change to 4800.

Issue History

Date Modified Username Field Change
2019-02-20 23:18 WA9PIE New Issue
2019-02-20 23:18 WA9PIE Status new => assigned
2019-02-20 23:18 WA9PIE Assigned To => JOSE
2019-02-21 09:24 WA9PIE Note Added: 0007466
2019-02-24 19:12 JOSE Status assigned => resolved
2019-02-24 19:12 JOSE Resolution open => fixed
2019-02-24 19:12 JOSE Fixed in Version => 6.5.0.196
2019-02-24 19:12 JOSE Note Added: 0007498
2019-02-24 20:46 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2019-03-01 19:26 WA9PIE Fixed in Version 6.5.0.196 => 6.5.0.199
2019-03-01 19:27 WA9PIE Fixed in Version 6.5.0.199 => 6.5.0.196
2019-04-28 11:45 WA9PIE Summary Cannot connect to rotor controller due to baud rate problem => Cannot connect to rotor controller due to baud rate problem (GS-232B)
2019-05-27 15:04 WA9PIE Status resolved => closed