View Issue Details

IDProjectCategoryView StatusLast Update
0003211Ham Radio DeluxeBugpublic2019-03-31 11:13
ReporterK7ZCZAssigned ToWA9PIE 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version6.5.0.197 
Target VersionFixed in Version6.5.0.207 
Summary0003211: neither CW pitch drop down nor the CW Pitch slider work for the FTDX-1200
DescriptionRig Control has both a drop down list and a slider to support the CW Pitch settings on the FTDX-1200. Neither of these controls work correctly.
Steps To Reproduce1) Open Rig Control and connect to an FTDX-1200 radio
2) Use the "Menu" button on the radio to access the menu settings
3) Use the VFO B dial to scroll to setting 56, which is "CW PITCH"

4) In Rig Control, add Slider "054 Pitch" to the layout
5) Make sure the "CW Pitch" drop-down is visible, too.

BUG#1) Adjusting the radio setting with the VFO B knob doesn't change the slider or the CW Pitch setting in Rig Control
BUG#2) Adjusting the slider in Rig Control doesn't change the radio setting
BUG#3) Adjusting the CW Pitch drop down in Rig Control doesn't change the radio setting, either


TagsFTDX-1200, Yaesu
ModuleRig Control
Sub-ModuleRadio Support
Testing Beta Successful

Relationships

related to 0003063 new 3 - Current Dev List Guidelines needed for design of Rig Control radio support 

Activities

K7ZCZ

2019-03-05 16:35

manager   ~0007578

fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4862

WA9PIE

2019-03-26 14:22

administrator   ~0007745

I was able to successfully test the CW pitch function.

However...

On the radio, it's menu item #56.
In Rig Control, there is no menu item for either "056 CW PITCH" or "054 CW PITCH" (as indicated in the steps above).
I tested this with the "Key pitch" slider.

MB question - do you want to relabel the "Key pitch" slider to "056 CW PITCH" before closing this out?

K7ZCZ

2019-03-26 16:47

manager   ~0007767

I don't think further changes for this issue are necessary because the team hasn't set a standard that dictacts which features of a radio are presented in Rig Control, or how they might be shown or name.

Mantis 3063 tracks the issue of coming up with some guidelines for which features appear and how they should be modeled. Until that issue is resolved, I don't think it makes much sense to block functional issues from being resolved and closed.

WA9PIE

2019-03-26 20:50

administrator   ~0007776

Validated

Issue History

Date Modified Username Field Change
2019-03-01 17:07 K7ZCZ New Issue
2019-03-01 17:08 K7ZCZ Tag Attached: FTDX-1200
2019-03-01 17:08 K7ZCZ Tag Attached: Yaesu
2019-03-05 16:35 K7ZCZ Assigned To => K7ZCZ
2019-03-05 16:35 K7ZCZ Status new => resolved
2019-03-05 16:35 K7ZCZ Resolution open => fixed
2019-03-05 16:35 K7ZCZ Note Added: 0007578
2019-03-06 21:45 K7ZCZ Fixed in Version => 6.5.0.200
2019-03-26 14:22 WA9PIE Status resolved => feedback
2019-03-26 14:22 WA9PIE Resolution fixed => reopened
2019-03-26 14:22 WA9PIE Steps to Reproduce Updated View Revisions
2019-03-26 14:22 WA9PIE Note Added: 0007745
2019-03-26 16:47 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-03-26 16:47 K7ZCZ Note Added: 0007767
2019-03-26 16:47 K7ZCZ Status feedback => assigned
2019-03-26 16:47 K7ZCZ Relationship added related to 0003063
2019-03-26 20:50 WA9PIE Status assigned => resolved
2019-03-26 20:50 WA9PIE Status resolved => closed
2019-03-26 20:50 WA9PIE Testing Not Started => Beta Successful
2019-03-26 20:50 WA9PIE Note Added: 0007776
2019-03-30 05:56 WA9PIE Resolution reopened => fixed
2019-03-31 11:13 WA9PIE Fixed in Version 6.5.0.200 => 6.5.0.207
2019-03-31 11:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe