View Issue Details

IDProjectCategoryView StatusLast Update
0003214Ham Radio DeluxeBugpublic2019-03-31 11:13
ReporterPD9FERAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.5.0.207 
Summary0003214: No radio control and missing buttons and sliders for FT-950 in 6.5.0.199
DescriptionI tried to install the two new versions of HRD, the .196 and the latest the .199 but both present me with problems with Rig Control: the radio no longer communicates with HRD in the sense that the software reads only the frequency of the VFO but everything the rest does not work (change frequency, NR, ATU, sliders, command buttons disappeared from the layout, etc.). On HRD logbook RADIO PANE appears but the sliders do not work and command buttons too. Returning to the last working one (the 183) everything is restored and works very well.
Steps To ReproduceConnect FT-950
Check all Buttons, Sliders in Rig control, Logbook and Digital Master
Additional InformationTicket #446642
Ticket #869510
TagsFT-950, Yaesu
ModuleRig Control
Sub-ModuleRadio Support
Testing Beta Successful

Activities

K7ZCZ

2019-03-03 16:21

administrator   ~0007568

I don't have an FT-950 to test. When I connect rig control to an FTDX-1200 as an FT-950, it works fine (as far as I expect it to, anyway); I'm able to tune and adjust most sliders. The ones that don't work are known to be different commands between the radio.

Button and slider appearance is governed by the configuration files, so I'm wondering what steps have been done to troubleshoot this issue.

K7ZCZ

2019-03-03 16:22

administrator   ~0007569

Ticket #446642 just says "we've confirmed this to be a problem". I wonder how that confirmation is established?

K7ZCZ

2019-03-04 09:02

administrator   ~0007570



Ticket #869510 actually has some details; fortunately the customer clearly wrote up what they observed.
 
I was able to reproduce the issue the customer sees by resetting the slider or button customization to the defaults. That led me to the issue in short order.


Fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4859

 

PD9FER

2019-03-04 09:03

viewer   ~0007571

Maybe because there are now 3 tickets on it?
Ticket #401608
Ticket #446642
Ticket #869510

Am trying to get some more info

PD9FER

2019-03-07 13:40

viewer   ~0007633

TX Button seems to be back in DM-780 according to Ticket 149994

WA9PIE

2019-03-10 17:44

administrator   ~0007659

Validated

Issue History

Date Modified Username Field Change
2019-03-02 04:40 PD9FER New Issue
2019-03-02 04:40 PD9FER Tag Attached: FT-950
2019-03-02 04:40 PD9FER Tag Attached: Yaesu
2019-03-03 16:21 K7ZCZ Note Added: 0007568
2019-03-03 16:22 K7ZCZ Note Added: 0007569
2019-03-04 09:02 K7ZCZ Assigned To => K7ZCZ
2019-03-04 09:02 K7ZCZ Status new => resolved
2019-03-04 09:02 K7ZCZ Resolution open => fixed
2019-03-04 09:02 K7ZCZ Note Added: 0007570
2019-03-04 09:02 K7ZCZ Summary No radio controll and missing buttons and sliders for FT-950 in 6.5.0.199 => No radio control and missing buttons and sliders for FT-950 in 6.5.0.199
2019-03-04 09:03 PD9FER Note Added: 0007571
2019-03-05 01:47 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2019-03-06 21:45 K7ZCZ Fixed in Version => 6.5.0.200
2019-03-07 13:40 PD9FER Note Added: 0007633
2019-03-10 17:44 WA9PIE Status resolved => closed
2019-03-10 17:44 WA9PIE Testing Not Started => Beta Successful
2019-03-10 17:44 WA9PIE Note Added: 0007659
2019-03-31 11:13 WA9PIE Fixed in Version 6.5.0.200 => 6.5.0.207
2019-03-31 11:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe