View Issue Details

IDProjectCategoryView StatusLast Update
0003218Ham Radio DeluxeBugpublic2019-03-31 11:13
ReporterK7ZCZAssigned ToWA9PIE 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version6.5.0.197 
Target VersionFixed in Version6.5.0.207 
Summary0003218: "Frequency display" slider for FTDX-1200 doesn't work
DescriptionRig Control offers a slider named "047 Frequency Display". This slider can be set to "Direct" or "Pitch Offset".

It's not clear which radio etting this is meant to control; seems like it's probably the "CW FREQ DISPLAY" setting, menu #66. It doesn't work.

Steps To Reproduce1) Open Rig Control and connect to an FTDX-1200 radio
2) Use the "Menu" button on the radio to access the menu settings
3) Use the VFO B dial to scroll to setting 47, which is "FREQUENCY DISPLAY"

4) Use the Customize Layout window to make sure the "047 CW Freq Display" slider is visible

BUG#1) Use the VFO B knob on the radio to change the setting. It can be set to "PITCH OFFSET" or "DIRECT". Changes to the radio aren't reflected in the HRD UI.

BUG#2) Use the Rig Control UI to change the slider. The radio's setting doesn't change.
TagsFTDX-1200, Yaesu
ModuleRig Control
Sub-ModuleRadio Support
Testing Beta Successful

Activities

K7ZCZ

2019-03-06 10:51

administrator   ~0007593

fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4872

WA9PIE

2019-03-26 14:33

administrator   ~0007749

On this test radio, menu item #47 is "MIC SCAN".

I'm not sure what to test here.

K7ZCZ

2019-03-26 16:51

administrator   ~0007768

This slider is named "066 Frequency Display", since that number matches the parameter number given in the CAT manual for the radio.

To test the fix:

1) Open Rig Control and connect to an FTDX-1200 radio
2) Use the "Menu" button on the radio to access the menu settings
3) Use the VFO B dial to scroll to setting 66, which is "MODE-CW CW FREQ DISPLAY"

4) Use the Customize Layout window to make sure the "66 Frequency Display" slider is visible

5) Adjusting the setting on the radio (With the VFO B knob) should switch between "PITCH OFFSET" and "DIRECT" on the radio. Changes should be reflected on the Rig Control UI.

6) Adjusting the Rig Control slider should change the setting in the radio.

WA9PIE

2019-03-26 20:49

administrator   ~0007775

I changed the status to Resolved so I can see it for retesting.

WA9PIE

2019-03-27 14:40

administrator   ~0007781

Validated

Issue History

Date Modified Username Field Change
2019-03-03 12:36 K7ZCZ New Issue
2019-03-04 12:58 K7ZCZ Tag Attached: Yaesu
2019-03-04 12:59 K7ZCZ Tag Attached: FTDX-1200
2019-03-06 10:51 K7ZCZ Assigned To => K7ZCZ
2019-03-06 10:51 K7ZCZ Status new => resolved
2019-03-06 10:51 K7ZCZ Resolution open => fixed
2019-03-06 10:51 K7ZCZ Note Added: 0007593
2019-03-06 21:45 K7ZCZ Fixed in Version => 6.5.0.200
2019-03-26 14:33 WA9PIE Status resolved => feedback
2019-03-26 14:33 WA9PIE Resolution fixed => reopened
2019-03-26 14:33 WA9PIE Description Updated View Revisions
2019-03-26 14:33 WA9PIE Steps to Reproduce Updated View Revisions
2019-03-26 14:33 WA9PIE Note Added: 0007749
2019-03-26 16:50 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-03-26 16:51 K7ZCZ Note Added: 0007768
2019-03-26 16:51 K7ZCZ Status feedback => assigned
2019-03-26 20:49 WA9PIE Status assigned => resolved
2019-03-26 20:49 WA9PIE Note Added: 0007775
2019-03-27 14:40 WA9PIE Status resolved => closed
2019-03-27 14:40 WA9PIE Testing Not Started => Beta Successful
2019-03-27 14:40 WA9PIE Note Added: 0007781
2019-03-30 05:55 WA9PIE Resolution reopened => fixed
2019-03-31 11:13 WA9PIE Fixed in Version 6.5.0.200 => 6.5.0.207
2019-03-31 11:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe