View Issue Details

IDProjectCategoryView StatusLast Update
0003219Ham Radio DeluxeBugpublic2019-03-31 11:13
ReporterK7ZCZAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version6.5.0.197 
Target VersionFixed in Version6.5.0.207 
Summary0003219: Rig Control lists several sliders twice for FDX-1200
DescriptionThe "Customize Layout" dialog in Rig Control allows users to decide which sliders they'd liek to see in the radio view. Silders for various radio settings can be added, removed, hidden, or moved within the layout.

For the FTDX-1200, the list of sliders contains several redundant entries.
Steps To Reproduce1) Start Rig Control and connect to an FTDX-1200 radio
2) Use the
3) In the resulting "Customie Layout" dialog, activate the "Sliders: Layout" tab
4) Drop down one of the controls. Note that it has several redundant choices; each is listed twice:

177 TX Power Level
179 External Tuner
180 VOX Operation
181 VOX Gain
182 VOX Delay
183 VOX Anti-Trip
184 Emergency Char


NOTE! This issue documents the fact that these are listed twice -- they shouldn't be. I haven't investigated if these are valid commands or not; maybe they shouldn't be listed at all, or maybe they're incorrectly described, or have other problems.
TagsNo tags attached.
ModuleRig Control
Sub-ModuleRadio Support
Testing Beta Successful

Activities

K7ZCZ

2019-03-03 16:03

manager   ~0007567

Fixed with this checkin. Note that this just removes the dupes; the remaining slidesr need to be tested to see if they're sane or not. But now that there's no redundancy, it's possible to proceed to that step ...

https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4858

WA9PIE

2019-03-26 14:35

administrator   ~0007750

I don't see any duplication. So I should consider this validated.

But there is no "177 TX Power Level" in the slider selections.

WA9PIE

2019-03-26 14:36

administrator   ~0007751

Validated during tests at HRO - Plano (TX)

(See note regarding menu 177)

K7ZCZ

2019-03-26 17:12

manager   ~0007771

"177 TX Power Level" was removed because the numbering was incorrect. This radio has a slider named "TX Power" which controls its output power setting.

Issue History

Date Modified Username Field Change
2019-03-03 12:48 K7ZCZ New Issue
2019-03-03 16:03 K7ZCZ Assigned To => K7ZCZ
2019-03-03 16:03 K7ZCZ Status new => resolved
2019-03-03 16:03 K7ZCZ Resolution open => fixed
2019-03-03 16:03 K7ZCZ Note Added: 0007567
2019-03-06 21:45 K7ZCZ Fixed in Version => 6.5.0.200
2019-03-26 14:35 WA9PIE Note Added: 0007750
2019-03-26 14:36 WA9PIE Status resolved => closed
2019-03-26 14:36 WA9PIE Description Updated View Revisions
2019-03-26 14:36 WA9PIE Steps to Reproduce Updated View Revisions
2019-03-26 14:36 WA9PIE Testing Not Started => Beta Successful
2019-03-26 14:36 WA9PIE Note Added: 0007751
2019-03-26 17:12 K7ZCZ Note Added: 0007771
2019-03-31 11:13 WA9PIE Fixed in Version 6.5.0.200 => 6.5.0.207
2019-03-31 11:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe