View Issue Details

IDProjectCategoryView StatusLast Update
0003232Ham Radio DeluxeBugpublic2019-03-31 11:13
ReporterK7ZCZAssigned ToWA9PIE 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version6.5.0.197 
Target VersionFixed in Version6.5.0.207 
Summary0003232: Rig Control slider doesn't set TX power for FTDX-1200
DescriptionThe Rig Control application has a slider for "TX Power Level", but this slider doesn't work.
Steps To Reproduce1) Open Rig Control and connect to an FTDX-1200 radio
2) Use the "Menu" button on the radio to access the menu settings
3) Use the VFO B dial to scroll to setting 178, which is "EXT AMP TUNING PWR"

4) Use the "Radio Layout" command in the "View" menu to reach the "Customize Layout" dialog
5) On the "Sliders: Layout" tab, make sure the "177 TX Power Level" slider is visible.

6) Exercise the "TX Power Level" slider.

BUG#1) The radio doesn't change the "EXT AMP TUNING PWR" setting

7) Use the VFO-B knob on the radio to change the radio's setting directly.

BUG#2) The UI doesn't reflect the radio's change.

I believe the TX Power level from the radios internal amplifier are controlled with the "PC" command, not by setting menu 178. 178 is intended to set the power level to drive an external amplifier. The "RF Power" slider (with no menu number) is the right command for setting the internal amp's drive.

TagsFTDX-1200, Yaesu
ModuleRig Control
Sub-ModuleRadio Support
Testing Beta Successful

Activities

K7ZCZ

2019-03-06 10:39

administrator   ~0007591

Turns out this setting runs the power output given when using an external amp and doing a tuning operation. Only a few steps: 10, 20, 50, 100.

Fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4870

WA9PIE

2019-03-26 15:00

administrator   ~0007761

I can't test this because there is no slider "177" available in the software.

On this rig, menu 177 is "TX PWR/PROC CONTROL". It's options are "TX PWR" and "PROC".

K7ZCZ

2019-03-26 16:39

administrator   ~0007765

The slider in Rig Control was renumbered to match the UI in the radio. It is now "178 Ext Amp Tuning Pwr"

WA9PIE

2019-03-27 14:40

administrator   ~0007780

Validated

Issue History

Date Modified Username Field Change
2019-03-05 15:22 K7ZCZ New Issue
2019-03-05 15:22 K7ZCZ Tag Attached: FTDX-1200
2019-03-05 15:22 K7ZCZ Tag Attached: Yaesu
2019-03-06 10:39 K7ZCZ Assigned To => K7ZCZ
2019-03-06 10:39 K7ZCZ Status new => resolved
2019-03-06 10:39 K7ZCZ Resolution open => fixed
2019-03-06 10:39 K7ZCZ Note Added: 0007591
2019-03-06 21:45 K7ZCZ Fixed in Version => 6.5.0.200
2019-03-26 15:00 WA9PIE Status resolved => feedback
2019-03-26 15:00 WA9PIE Resolution fixed => reopened
2019-03-26 15:00 WA9PIE Steps to Reproduce Updated View Revisions
2019-03-26 15:00 WA9PIE Testing Not Started => Beta Failed
2019-03-26 15:00 WA9PIE Note Added: 0007761
2019-03-26 16:39 K7ZCZ Status feedback => resolved
2019-03-26 16:39 K7ZCZ Resolution reopened => fixed
2019-03-26 16:39 K7ZCZ Note Added: 0007765
2019-03-26 20:44 WA9PIE Assigned To K7ZCZ => WA9PIE
2019-03-27 14:40 WA9PIE Status resolved => closed
2019-03-27 14:40 WA9PIE Testing Beta Failed => Beta Successful
2019-03-27 14:40 WA9PIE Note Added: 0007780
2019-03-31 11:13 WA9PIE Fixed in Version 6.5.0.200 => 6.5.0.207
2019-03-31 11:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe