View Issue Details

IDProjectCategoryView StatusLast Update
00032403 - Current Dev ListBugpublic2019-03-17 15:16
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version6.5.0.197 
Target VersionFixed in Version6.5.0.203 
Summary0003240: Command Tester doesn't work with Icom radios
DescriptionThe Command Tester tool in Rig Control doesn't work with Icom radios. It always reports an "ERROR", and doesn't show the radio's response.
Steps To Reproduce
1) Start Rig Control. Do not connect to a radio
2) Connect to any modern Icom radio.
3) Set the "From" field to "E0". The "To" field should match the address of your radio
4) Set the "Cmd" field to "03". This should read the operating frequency from the radio.
5) All the other fields are blank.
6) Press the "Send" button to send the command.

BUG#1) The command is sent, and the "Received" column shows "[Error]". No command works.

The data is actually sent to the radio. For a radio at address 0x60, this is sent, as expected:

FE FE 60 E0 03 FD


And, the radio does correctly respond:

 FE FE 60 E0 03 FD FE FE E0 60 03 00 40 97 46 01 FD


which indicates that the radio is tuned to 146.974.000 Hz. Nothing in the response indicates an error.


TagsICOM
ModuleRig Control
Sub-ModuleRadio Support
Testing Beta Successful

Relationships

related to 0003042 new Rig Control's Command Tester feature falsely reports comamnd errors 

Activities

K7ZCZ

2019-03-09 17:14

manager   ~0007652

fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4892

g3ypp

2019-03-13 08:52

updater   ~0007679

This now seems to be working fine on my IC-7600. I can use it to change settings etc on rig. Tested with a number of cat commands. All OK

g3ucq

2019-03-15 06:44

updater   ~0007687

Working with my IC-7610.

Issue History

Date Modified Username Field Change
2019-03-09 09:18 K7ZCZ New Issue
2019-03-09 09:18 K7ZCZ Relationship added related to 0003042
2019-03-09 09:18 K7ZCZ Tag Attached: ICOM
2019-03-09 17:14 K7ZCZ Assigned To => K7ZCZ
2019-03-09 17:14 K7ZCZ Status new => resolved
2019-03-09 17:14 K7ZCZ Resolution open => fixed
2019-03-09 17:14 K7ZCZ Note Added: 0007652
2019-03-12 22:19 K7ZCZ Fixed in Version => 6.5.0.203
2019-03-13 08:52 g3ypp Note Added: 0007679
2019-03-15 06:44 g3ucq Note Added: 0007687
2019-03-17 15:16 WA9PIE Status resolved => closed
2019-03-17 15:16 WA9PIE Steps to Reproduce Updated View Revisions
2019-03-17 15:16 WA9PIE Testing Not Started => Beta Successful