View Issue Details

IDProjectCategoryView StatusLast Update
0003273Ham Radio DeluxeBugpublic2019-11-08 02:32
ReporterPD9FERAssigned ToPD9FER 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.7.0.244 
Summary0003273: HAMQTH forces Callsigns Lowercase
DescriptionCustomers comment:
I have it set up such that when I have HRD logbook open and am working FT8, my contacts are automatically transferred into HRD Logbook.

I noticed that many of my contacts callsigns are being transferred into HRD Logbook in lowercase.
While this doesn't happen every time, I noticed that it does happen more often than not; I verify that they are in upper case in WSJT-X prior to the "transfer" but they still get inputted into HRD Logbook as lower case.
Steps To ReproduceConfigure Callsign Lookup in Logbook to be:

LOGBOOK
HAMQTH
COUNTRY LIST

Setup WSJT-X for logging via QSO Forwarding

When adding a QSO to the log and it parses from HAMQTH, the Callsign field is populated in Lowercase.

Remove HAMQTH from the lookup settings and replace it with QRZ.COM

Repeat the logging steps, you will notice the calls are now uppercase (as they should be)
Additional InformationTicket #272798
Also see https://forums.hamradiodeluxe.com/node/49493
TagsNo tags attached.
ModuleLogbook
Sub-ModuleCall lookup
Testing Beta Successful

Activities

K7ZCZ

2019-10-21 12:42

administrator   ~0008895

This is fixed in 6.7 builds due to the work rewriting call sign lookup

g3ucq

2019-10-23 03:20

viewer   ~0008909

I do not use HAMQTH so unable to test.
I have never seen lowercase callsigns from QSO forwarding.

WA9PIE

2019-10-23 04:14

administrator   ~0008935

There are other problems with HamQTH, but this particular item is resolved as part of 0003001.

WA9PIE

2019-10-23 04:14

administrator   ~0008936

Validated

Issue History

Date Modified Username Field Change
2019-04-05 04:39 PD9FER New Issue
2019-10-21 12:42 K7ZCZ Assigned To => PD9FER
2019-10-21 12:42 K7ZCZ Status new => resolved
2019-10-21 12:42 K7ZCZ Resolution open => fixed
2019-10-21 12:42 K7ZCZ Note Added: 0008895
2019-10-21 17:03 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2019-10-21 17:05 K7ZCZ Fixed in Version => 6.7.0.235
2019-10-23 03:20 g3ucq Note Added: 0008909
2019-10-23 04:14 WA9PIE Summary HAMQTH forces Callsingns Lowercase => HAMQTH forces Callsigns Lowercase
2019-10-23 04:14 WA9PIE Testing Not Started => Beta Successful
2019-10-23 04:14 WA9PIE Note Added: 0008935
2019-10-23 04:14 WA9PIE Status resolved => closed
2019-10-23 04:14 WA9PIE Note Added: 0008936
2019-11-08 02:12 WA9PIE Fixed in Version 6.7.0.235 => 6.7.0.244
2019-11-08 02:32 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe