View Issue Details

IDProjectCategoryView StatusLast Update
00033143 - Current Dev ListBugpublic2019-08-12 16:19
ReporterK7ZCZAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0003314: unable to attach files to Mantis issues
DescriptionI'm unable to attach files to Mantis isuses. When I try, the attachment silently fails -- no error message, it's just that the file doesn't appear in the Mantis issue. It's also not added to the history list for the issue.
Steps To Reproduce1) Create a new Mantis issue -- or use an existing one
2) Drag-and-drop a file to the "Drop files here to upload" box
3) Save changes
4) Refresh the browser window

BUG#1) The file doesn't appear. No error message is visible.
TagsNo tags attached.
ModuleWebsite
Sub-ModuleFunctional
TestingNot Started

Activities

K7ZCZ

2019-07-05 17:14

administrator   ~0008199

Is there anything I can do to help expedite a fix for this issue? It's been a problem for more than a month, and has a significant impact on productivity.

WA9PIE

2019-08-09 20:22

administrator   ~0008354

Daljeet - as a reminder, I think you may have changed the way these webapps save files... to a directory, rather than in the database?

WA9PIE

2019-08-09 20:46

administrator   ~0008355

Testing

LOTWDownload 2019-07-24 081709.ADI (3,721 bytes)

WA9PIE

2019-08-09 20:47

administrator   ~0008356

Testing

ProfileSite.png (67,782 bytes)
ProfileSite.png (67,782 bytes)

WA9PIE

2019-08-09 20:52

administrator   ~0008357

I may have fixed this one by making a change to the $g_allowed_files parameter in config_inc.php. The usage description is as follows:

"File types that are allowed. Separate items by commas. eg. "zip,bmp,gif,jpg,txt" If $g_allowed_files is filled in NO other file types will be allowed. If empty it will assume any files are accepted that pass the $g_disallowed_files list."

For whatever reason, this parameter previously included only "adi" files. I removed the files types so there are no restrictions.

WA9PIE

2019-08-09 20:53

administrator   ~0008358

K7ZCZ, since you're the "Reporter", I'll let you validate this change.

WA9PIE

2019-08-09 20:53

administrator  

Brisbane-Time Table.PNG (32,257 bytes)
Brisbane-Time Table.PNG (32,257 bytes)

K7ZCZ

2019-08-12 16:19

administrator   ~0008391

Looks like this is fixed. Yay!

Issue History

Date Modified Username Field Change
2019-05-13 13:04 K7ZCZ New Issue
2019-06-16 22:49 K7ZCZ Status new => assigned
2019-06-16 22:49 K7ZCZ Assigned To => WA9PIE
2019-07-05 17:14 K7ZCZ Note Added: 0008199
2019-08-09 20:22 WA9PIE Note Added: 0008354
2019-08-09 20:46 WA9PIE File Added: LOTWDownload 2019-07-24 081709.ADI
2019-08-09 20:46 WA9PIE Note Added: 0008355
2019-08-09 20:47 WA9PIE File Added: ProfileSite.png
2019-08-09 20:47 WA9PIE Note Added: 0008356
2019-08-09 20:52 WA9PIE Note Added: 0008357
2019-08-09 20:53 WA9PIE Assigned To WA9PIE => K7ZCZ
2019-08-09 20:53 WA9PIE Status assigned => resolved
2019-08-09 20:53 WA9PIE Resolution open => fixed
2019-08-09 20:53 WA9PIE Note Added: 0008358
2019-08-09 20:53 WA9PIE File Added: Brisbane-Time Table.PNG
2019-08-12 16:19 K7ZCZ Status resolved => closed
2019-08-12 16:19 K7ZCZ Note Added: 0008391