View Issue Details

IDProjectCategoryView StatusLast Update
00033153 - Current Dev ListBugpublic2019-08-10 04:45
ReporterK7ZCZAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0003315: attached files missing from old forum posts
DescriptionForums posts which previously had attached files (or images) no longer have them, and they can't be downloaded.
Steps To Reproduce1) Go to the forum
2) Find a post which has an attached file or image. Here is one example: https://forums.hamradiodeluxe.com/node/42078

BUG#1) The file isn't shown; a broken picture icon appears instead

3) Click on the link for the image. For this example, that link goes to this URL: https://forums.hamradiodeluxe.com/filedata/fetch?id=43319&d=1502890209

BUG#2) No image downloaded. Instead, a blank page with this text is displayed "Invalid File Specified"

TagsNo tags attached.
ModuleWebsite
Sub-ModuleFunctional
TestingNot Started

Activities

WA9PIE

2019-05-13 13:44

administrator   ~0007935

It displays for me. I'll need to figure this out.

K7ZCZ

2019-05-13 14:17

administrator   ~0007936

Perhaps you have an elevated account that's able to see the file, or maybe your request for the file is being serviced from cache. Or, maybe there's some other issue.

During the team call on May 2, 2019, other members of the team were able to demonstrate this issue.

WA9PIE

2019-08-09 20:59

administrator   ~0008359

When I follow the links posted by K7ZCZ using Chrome in "Incognito" mode, I get the same results that he describes. Perhaps it's a permissions thing (as mentioned)?

WA9PIE

2019-08-10 04:45

administrator   ~0008360

What I could find is a setting that changed during the upgrade that modified the attachment and thumbnail view permissions to the Announcements forum. That is the cause of the problem referenced in the links in "Steps to Reproduce". So that problem specific to those attachments in that forum is resolved. That said - it had nothing to do with the age of the post or attachments. (permissions thing)

If there are other attachments that can't be viewed, I'd need some of those examples and I'll investigate it. I think there is some parameter in vBulletin that causes posts to be deleted after a certain amount of time. I'll look into that.

Issue History

Date Modified Username Field Change
2019-05-13 13:12 K7ZCZ New Issue
2019-05-13 13:44 WA9PIE Note Added: 0007935
2019-05-13 14:17 K7ZCZ Note Added: 0007936
2019-05-13 14:18 K7ZCZ Assigned To => WA9PIE
2019-05-13 14:18 K7ZCZ Status new => assigned
2019-08-09 20:59 WA9PIE Note Added: 0008359
2019-08-10 04:45 WA9PIE Assigned To WA9PIE => K7ZCZ
2019-08-10 04:45 WA9PIE Status assigned => resolved
2019-08-10 04:45 WA9PIE Resolution open => fixed
2019-08-10 04:45 WA9PIE Description Updated View Revisions
2019-08-10 04:45 WA9PIE Steps to Reproduce Updated View Revisions
2019-08-10 04:45 WA9PIE Note Added: 0008360