View Issue Details

IDProjectCategoryView StatusLast Update
00033433 - Current Dev ListBugpublic2019-09-07 09:04
ReporterK7ZCZAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.7.0.226 
Summary0003343: LicenseValidator constructor catches all exceptions, then rethrows
DescriptionI found this cdoe in the constructor for LicenseValidator (in LicenseValidator.cpp)

    catch (...)
    {
        throw;
    }


There's really no reason for this code to exist. If an exception is thrown, it should be handled by trapping a specific exception type. Catching all exception types with "..." is an anti-pattern. Worse, this code catches all exceptions, then simply re-throws them; there's no conceivable reason for this.

Further, if there is an exception, I think this code leaks because the try block includes at least one statement that allocates resources without a path to free them during exception handling.

TagsNo tags attached.
ModuleSW License Mgmt
Sub-ModuleSW License Client
Testing N/A

Relationships

child of 0003370 closedWA9PIE 3 - Current Dev List Maintenance release for remaining license server topics 

Activities

K7ZCZ

2019-07-26 19:38

administrator   ~0008288

Fixed in the 66 branch with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5094

WA9PIE

2019-09-07 09:04

administrator   ~0008528

Taking the developer's account as valid.

Issue History

Date Modified Username Field Change
2019-06-11 08:33 K7ZCZ New Issue
2019-06-15 10:44 WA9PIE Description Updated View Revisions
2019-06-15 10:44 WA9PIE Module QLM => SW License Mgmt
2019-06-15 10:44 WA9PIE Sub-Module QLM Client => SW License Client
2019-06-23 13:03 WA9PIE Relationship added child of 0003370
2019-07-26 19:38 K7ZCZ Assigned To => K7ZCZ
2019-07-26 19:38 K7ZCZ Status new => resolved
2019-07-26 19:38 K7ZCZ Resolution open => fixed
2019-07-26 19:38 K7ZCZ Note Added: 0008288
2019-08-30 13:31 K7ZCZ Fixed in Version => 6.7.0.226
2019-09-07 09:04 WA9PIE Status resolved => closed
2019-09-07 09:04 WA9PIE Testing Not Started => N/A
2019-09-07 09:04 WA9PIE Note Added: 0008528