View Issue Details

IDProjectCategoryView StatusLast Update
00033453 - Current Dev ListBugpublic2019-09-07 09:07
ReporterK7ZCZAssigned ToDOUG 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.7.0.226 
Summary0003345: WriteProductProperties method in LicenseValidator catches all exceptions
DescriptionThe WriteProductProperties() method of LicenseValidator (in the LicenseValidator.cpp source file) catches all exceptions and rethrows:

    catch (...)
    {
        throw;
    }


If this code is concerned with handling exceptions, it should trap specific types. This specific try/catch block surrounds a crashing bug involving a bogus type cast (see the related issue 0003332) and debugging that issue is hampered by the catch all construct here.
TagsNo tags attached.
ModuleSW License Mgmt
Sub-ModuleSW License Client
Testing N/A

Relationships

related to 0003332 closedDOUG 3 - Current Dev List QLM license code incorrectly casts string, ignores error return from Soraco function 

Activities

DOUG

2019-06-12 16:07

developer   ~0008056

I am inclined to keep as is, that is code from the QLM sample project, and since we don't what happens inside the dll catching all might be safer.

WA9PIE

2019-06-22 11:23

administrator   ~0008171

Sounds like it's worth a conversation. It doesn't look like a show-stopper. I'll likely remove its relationship to 1990.

K7ZCZ

2019-07-26 19:30

administrator   ~0008287

Fixed in the 6.6 branch with this checkin
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5093

WA9PIE

2019-09-07 09:07

administrator   ~0008530

Taking the developer's account as valid.

Issue History

Date Modified Username Field Change
2019-06-11 08:34 K7ZCZ New Issue
2019-06-11 08:34 K7ZCZ Relationship added related to 0003332
2019-06-12 16:07 DOUG Note Added: 0008056
2019-06-13 14:47 WA9PIE Module QLM => SW License Mgmt
2019-06-13 15:24 WA9PIE Sub-Module QLM Client => SW License Client
2019-06-15 23:21 WA9PIE Assigned To => DOUG
2019-06-15 23:21 WA9PIE Status new => assigned
2019-06-22 11:23 WA9PIE Note Added: 0008171
2019-07-26 19:30 K7ZCZ Status assigned => resolved
2019-07-26 19:30 K7ZCZ Resolution open => fixed
2019-07-26 19:30 K7ZCZ Note Added: 0008287
2019-08-07 02:48 WA9PIE Fixed in Version => 6.6.0.239
2019-08-30 19:40 WA9PIE Fixed in Version 6.6.0.239 => 6.7.0.226
2019-09-07 09:07 WA9PIE Status resolved => closed
2019-09-07 09:07 WA9PIE Testing Not Started => N/A
2019-09-07 09:07 WA9PIE Note Added: 0008530