View Issue Details

IDProjectCategoryView StatusLast Update
00033463 - Current Dev ListBugpublic2019-07-21 06:12
ReporterK7ZCZAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0003346: LicenseValidator's ReadProductProperties method catches all exceptions
Description
    catch (...)
    {
        //errorMessage = ex.Message;
    }


It's an anti-pattern to catch all exceptions in most cases. Here, for sure -- no cleanup is performed, and the one chance at error reporting is commented-out (because it wouldn't work -- no such variables here). This code may pass a NULL pointer to OutputDebugString(), and the catch(...) code will make detecting and debugging that occurrence difficult.
TagsNo tags attached.
ModuleSW License Mgmt
Sub-ModuleSW License Client
TestingNot Started

Relationships

child of 0003370 assignedWA9PIE 3 - Current Dev List Maintenance release for remaining license server topics 

Activities

K7ZCZ

2019-07-21 06:12

administrator   ~0008252

fixed with this checkin in the 6.6 branch:

https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5084

Issue History

Date Modified Username Field Change
2019-06-11 08:35 K7ZCZ New Issue
2019-06-15 10:43 WA9PIE Description Updated View Revisions
2019-06-15 10:43 WA9PIE Module QLM => SW License Mgmt
2019-06-15 10:43 WA9PIE Sub-Module QLM Client => SW License Client
2019-06-23 13:04 WA9PIE Relationship added child of 0003370
2019-07-21 06:12 K7ZCZ Assigned To => K7ZCZ
2019-07-21 06:12 K7ZCZ Status new => resolved
2019-07-21 06:12 K7ZCZ Resolution open => fixed
2019-07-21 06:12 K7ZCZ Note Added: 0008252