View Issue Details

IDProjectCategoryView StatusLast Update
0003351Ham Radio DeluxeBugpublic2019-07-01 14:20
ReporterK7ZCZAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version6.6.0.214 
Target VersionFixed in Version6.6.0.236 
Summary0003351: Remove HRDVerify from build
DescriptionThe HRDVerify tool was used to "verify" and pseudo-sign HRD builds. It would also send a message to the legacy license server that a new build was available, and that fact could be queried by lcients which would prompt users to update.

We have real, cryptographic third-party signing now, with real certificates. The bogus signing is no longer necessary, and was never useful or secure.

It might be interesting to have an upgrade notification, and we can work on that by opening another Mantis issue once a design is available.

For now, though, the HRDVerify tool is removed from the product because it doesn't work against the new licensing server and is largely unnecessary.
TagsNo tags attached.
ModuleSW License Mgmt
Sub-ModuleSW License Server
Testing N/A

Activities

K7ZCZ

2019-06-15 17:11

administrator   ~0008087

fixed with these checkins:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5021
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5024

K7ZCZ

2019-06-16 11:34

administrator   ~0008098

Looks like I forgot to promote the deletion to a desired checkin previously. This checkin actually gets it right:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5026

WA9PIE

2019-06-22 10:59

administrator   ~0008155

Last edited: 2019-06-22 12:01

View 2 revisions

I'm going to take this as complete.

Issue History

Date Modified Username Field Change
2019-06-14 17:21 K7ZCZ New Issue
2019-06-15 17:11 K7ZCZ Note Added: 0008087
2019-06-15 23:16 WA9PIE Status new => resolved
2019-06-15 23:16 WA9PIE Resolution open => fixed
2019-06-15 23:16 WA9PIE Fixed in Version => 6.6.0.231
2019-06-15 23:19 WA9PIE Assigned To => K7ZCZ
2019-06-16 11:34 K7ZCZ Note Added: 0008098
2019-06-22 10:59 WA9PIE Note Added: 0008155
2019-06-22 12:01 WA9PIE Note Edited: 0008155 View Revisions
2019-06-22 12:01 WA9PIE Status resolved => closed
2019-06-22 12:01 WA9PIE Testing Not Started => N/A
2019-07-01 14:19 WA9PIE Fixed in Version 6.6.0.231 => 6.6.0.236
2019-07-01 14:20 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe