View Issue Details

IDProjectCategoryView StatusLast Update
0003358Ham Radio DeluxeBugpublic2019-07-01 14:20
ReporterWA9PIEAssigned ToWA9PIE 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version6.6.0.231 
Target VersionFixed in Version6.6.0.236 
Summary0003358: Slash calls in the QLM list of "additional callsigns" are being truncated
DescriptionOne of the use cases for "Additional Callsigns" is where calls are being used in a remote country location.

For example, I may be operating from Brisbane, Australia (VK4). My callsign will be "WA9PIE/VK4".

When I add callsign "WA9PIE/VK4" to my list of additional callsigns and then launch the software... I get a new tab that shows "WA9PIE/VK" (ie. the "4" is dropped).

I have added the callsign "K7ZCZ/VK4" to the additional callsigns for K7ZCZ for developer testing.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleData
Testing Beta Successful

Activities

K7ZCZ

2019-06-17 22:30

administrator   ~0008125

Works fine for me. I see "K7ZCZ/VK4" in the tab, and in the locations list I've got "Home - K7ZCZ/VK4".

WA9PIE

2019-06-17 22:44

administrator   ~0008127

I retested this. Still truncated. I see "WA9PIE/VK".

I removed all my entries and tried again with just one additional callsign to see if that makes a difference. No difference. I still get just "WA9PIE/VK" rather than "WA9PIE/VK4".

We could let this go until it happens to someone other than me.

WA9PIE

2019-06-17 22:51

administrator   ~0008128

Ok... let's try this. I think the additional calls may be truncated at a maximum of 9 characters. If that's true, then K7ZCZ/VK4 fits within 9 characters.

So I created a key for KB7ZCZ with an additional callsign of KB7ZCZ/VK4.

The key for KB7ZCZ is A9KE0W0S06GHJ5CQ8K2B3R6U57GP8H.

Can you try this call and key and see if you get KB7ZCZ/VK4 or KB7ZCZ/VK?

K7ZCZ

2019-06-18 11:46

administrator   ~0008129

thanks, that causes it to repro. Seems like the problem is the overall total length, not the presence of a slash suffix as originally reported.

K7ZCZ

2019-06-18 11:46

administrator   ~0008130


Fixed in the 66 tree with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5036

WA9PIE

2019-06-20 10:17

administrator   ~0008135

I tested this one myself. Not sure the beta team needs to test this.

WA9PIE

2019-06-22 11:00

administrator   ~0008157

Confirmed.

Issue History

Date Modified Username Field Change
2019-06-15 23:46 WA9PIE New Issue
2019-06-15 23:46 WA9PIE Status new => assigned
2019-06-15 23:46 WA9PIE Assigned To => K7ZCZ
2019-06-17 22:30 K7ZCZ Status assigned => resolved
2019-06-17 22:30 K7ZCZ Resolution open => unable to reproduce
2019-06-17 22:30 K7ZCZ Note Added: 0008125
2019-06-17 22:44 WA9PIE Status resolved => assigned
2019-06-17 22:44 WA9PIE Resolution unable to reproduce => reopened
2019-06-17 22:44 WA9PIE Note Added: 0008127
2019-06-17 22:51 WA9PIE Note Added: 0008128
2019-06-18 11:46 K7ZCZ Note Added: 0008129
2019-06-18 11:46 K7ZCZ Status assigned => resolved
2019-06-18 11:46 K7ZCZ Note Added: 0008130
2019-06-18 11:46 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-06-20 10:17 WA9PIE Resolution reopened => fixed
2019-06-20 10:17 WA9PIE Fixed in Version => 6.6.0.234
2019-06-20 10:17 WA9PIE Testing Not Started => Beta Successful
2019-06-20 10:17 WA9PIE Note Added: 0008135
2019-06-22 11:00 WA9PIE Status resolved => closed
2019-06-22 11:00 WA9PIE Note Added: 0008157
2019-07-01 14:18 WA9PIE Fixed in Version 6.6.0.234 => 6.6.0.236
2019-07-01 14:20 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe