View Issue Details

IDProjectCategoryView StatusLast Update
0003362Ham Radio DeluxeMaintenancepublic2019-07-01 14:20
ReporterWA9PIEAssigned ToWA9PIE 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.6.0.236 
Summary0003362: Revise the "My Station" tab in the ALE in support of the other changes made to the My Station dialog
DescriptionThe My Station tab in the ALE still contains "Callsign", "Owner", and "Operator."

We could leave "Callsign" as-is in this context.
We need to remove "Owner" from this tab for the same reasons we removed it from the My Station dialog box.
We need to deal with "Operator" in a way consistent with what we'll do with "3357." For now, change the label to "Operator Callsign".

I have an image that describes this. I've placed the file at:

Google Drive..\Shared drives\HRD Software\Attachments\ALE_My_Station.png
Steps To ReproduceRemove "Owner" from this dialog box.
Re-label "Operator" to "Operator Callsign" (and adjust spacing in the UI).
TagsNo tags attached.
ModuleLogbook
Sub-ModuleAppearance/UI
Testing Beta Successful

Relationships

related to 0003357 feedbackK7ZCZ 3 - Current Dev List Create a method to manage operator callsigns (remove "Operator" from the My Station dialog box) 

Activities

doug

2019-06-22 22:04

developer   ~0008180

removed owner, changed it to "operator callsign" on bot the logbook tab AND in the config my station page.
Reworked the controls a bit because "operator callsign" was a bit wider than the other labels.
Also moved license edit box up, just to make the layout look better
Screen shot attached.

I was going to remove references to the owner control in code, but it was in the middle of a static array in import/export code AND that array had a lot of hard coded index values scattered around in the code, removing it would probably break stuff. So I left that code AND just set "IDC_OWNER" to hidden on the dialog.

WA9PIE

2019-06-23 02:51

administrator   ~0008181

This is good.

When you said, "removed owner, changed it to "operator callsign"", I was concerned that you were saying you changed 'owner to operator callsign'. But the change is correct.

Owner is removed from the UI. The label for "Operator" now says "Operator Callsign" on both the My Station dialog box and in the My Station tab in the ALE.

Validated. Closing.

Issue History

Date Modified Username Field Change
2019-06-16 12:31 WA9PIE New Issue
2019-06-16 12:31 WA9PIE Status new => assigned
2019-06-16 12:31 WA9PIE Assigned To => K7ZCZ
2019-06-16 17:00 WA9PIE Relationship added related to 0003357
2019-06-22 12:11 WA9PIE Description Updated View Revisions
2019-06-22 12:11 WA9PIE Steps to Reproduce Updated View Revisions
2019-06-22 16:08 WA9PIE Assigned To K7ZCZ => doug
2019-06-22 22:04 doug Note Added: 0008180
2019-06-22 22:09 doug Assigned To doug => WA9PIE
2019-06-23 02:51 WA9PIE Note Added: 0008181
2019-06-23 02:53 WA9PIE Status assigned => closed
2019-06-23 02:53 WA9PIE Resolution open => fixed
2019-06-23 02:53 WA9PIE Fixed in Version => 6.6.0.235
2019-06-23 02:53 WA9PIE Testing Not Started => Beta Successful
2019-07-01 14:18 WA9PIE Fixed in Version 6.6.0.235 => 6.6.0.236
2019-07-01 14:20 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe