View Issue Details

IDProjectCategoryView StatusLast Update
0003371Ham Radio DeluxeEnhancementpublic2019-11-08 02:32
ReporterKB3NPHAssigned ToKB3NPH 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version6.7.0.244 
Summary0003371: Info for adding Brother PTouch P700 label printer to label printing options
DescriptionTicket #694417

I use a Brother PTouch P700 label printer. Pretty standard for labels. It uses a tape cartridge that is identified as 24mm TZe tape, laminated.

 

The HRD “context” menu brings up a print dialog box. It permits me to select this printer (presumably because it is in my windows printers file, not because of anything unique to HRD). The dialog box permits me to change font styles, but not sizes. I assume it is somehow auto-sizing. There are numerous labels to choose from (the list seems to be duplicated many many times), but does not appear to have the label type I have and need.

 

I went to the “Create New” option and attempted to create a label. Given the limited menu choices in the dialog box, that is easier said than done. Each time I would try a setting, if I wanted to change a parameter, I had to delete the label and create a new label – because the edit label option only permitted changing (i) side margin, (ii) top margin, (iii) horizontal gap, and (iv) vertical gap. I could not edit the (a) label brand, (b) type, (c) width, (d) height, or (e) page type or orientation. In other words, there were limited (at best) items that could be edited. Further, when I selected address (as contrasted with QSL), I could not change the content of what was printed (i.e., I don’t like printing the call sign prior to the name and if in the US, I don’t usually print United States). The only items that were shown related to the QSL and not the address.

 

So, it appears that HRD has some work left.

 

I am providing the details, not because I’m upset, but in hopes it helps the development team.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleLabel
TestingNot Started

Activities

K7ZCZ

2019-07-13 19:41

administrator   ~0008230

I don't think it's realistic to support these devices without having them available for testing and development. The PTouch PT-P700 is about $65, and the PT-P750 is around $125. The devices take tapes for printing; the one-inch-wide tapes are about $10 each. I don't think we should offer support for smallter tape widths, since they're unlikely to be used by operators for QSL cards.

WA9PIE

2019-09-22 02:52

administrator   ~0008574

Tim - have you checked to see if Doug has added this in the 6.7 beta?

I purchased a Brother label printer... but Doug already has one. I'm not sure if it's exactly the same model. But I think he has added the ability to connect to the printer if it's installed.

WA9PIE

2019-10-29 05:44

administrator   ~0009073

With the most recent changes made, this should be fixed. Needs testing.

g3ucq

2019-10-29 05:55

viewer   ~0009076

Unable to test

g3ypp

2019-11-07 08:32

viewer   ~0009196

Unable to test

Issue History

Date Modified Username Field Change
2019-06-24 09:28 KB3NPH New Issue
2019-07-13 19:41 K7ZCZ Note Added: 0008230
2019-09-22 02:50 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2019-09-22 02:52 WA9PIE Assigned To => KB3NPH
2019-09-22 02:52 WA9PIE Status new => feedback
2019-09-22 02:52 WA9PIE Note Added: 0008574
2019-10-29 05:44 WA9PIE Status feedback => resolved
2019-10-29 05:44 WA9PIE Resolution open => fixed
2019-10-29 05:44 WA9PIE Fixed in Version => 6.7.0.239
2019-10-29 05:44 WA9PIE Note Added: 0009073
2019-10-29 05:55 g3ucq Note Added: 0009076
2019-11-07 08:32 g3ypp Note Added: 0009196
2019-11-08 02:10 WA9PIE Fixed in Version 6.7.0.239 => 6.7.0.244
2019-11-08 02:32 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe