View Issue Details

IDProjectCategoryView StatusLast Update
0003376Ham Radio DeluxeBugpublic2019-11-08 02:32
ReporterKC7FPFAssigned ToKC7FPF 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.7.0.244 
Summary0003376: Incorrect QTH Data
DescriptionWhen you look at my address and QTH you find the word Kingstown, which is incorrect information. Several months ago, I talked with an HRD technician several times about this issue and was assured that the problem would be corrected with the next revision of HRD. That has been several months ago and it still hasn't been corrected.



Steps To ReproduceI did a callsign loop up on this customer as got the same result. With incorrect QTH information in the HRD logbook. However if you do a call sign lookup in QRZ is displays the correct information.
Additional InformationSeveral months ago, I talked with an HRD technician several times about this issue and was assured that the problem would be corrected with the next revision of HRD. That has been several months ago and it still hasn't been corrected. Both Ferry and Tim got the same result. Speaking with tim he indicated at some point. this issue was resolved.

I changed the call sign look up to the callook option in the logbook. At this point it did retrieve and display the correct QTH information for the customer.
Please refer to ticket 319986.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleCall lookup
Testing Beta Successful

Relationships

child of 0003001 closedWA9PIE Callsign lookup function does not appear to be working as designed 

Activities

K7ZCZ

2019-07-05 15:21

administrator   ~0008194

Please provide clear repro steps so that this issue can be investigated.

KC7FPF

2019-07-05 15:59

viewer   ~0008197

I changed the call sign look up option to callook.info option in the logbook Callsign lookup option. Once this was completed. Did a
Call sign lookup with the the callsign in question. At this point it did retrieve and display the correct QTH information for the customer.
Returned to the callsign lookup option. Changed it back the QRZ.com. Once this was completed. Did a callsign lookup with the callsign in question. Came back with the incorrect QTH information. QTH data is listed correctly on QRZ.

Please refer to ticket 319986.

K7ZCZ

2019-07-11 18:50

administrator   ~0008216

I've related this to 3001, which is the issue that's tracking the re-write of the callsign lookup. Odds are, this issue is resolved by that re-write.

If we think a fix is more urgent, that issue should be brought up with triage with suggested prioritization.

WA9PIE

2019-07-11 23:34

administrator   ~0008217

Last edited: 2019-09-22 11:46

View 3 revisions

This because of problems with the callsign lookup in the published versions. This will get corrected with the revision to callsign lookup (Mantis 3001).

K7ZCZ

2019-10-21 14:19

administrator   ~0008896

I think this is resolved in the current 6.7 builds

g3ucq

2019-10-23 03:51

viewer   ~0008921

Entering KC7FPF into the ALE I get Bronson as the QTH. Is that correct? If so, fixed.

WA9PIE

2019-10-23 03:58

administrator   ~0008924

The answer depends upon the callsign lookup options you choose.

We have mapped the fields from the callsign lookup options into the correct fields in Logbook. The "city" should go into the "QTH" field.

The objective of 0003001 was to fix all issues with callsign lookup, for which this is just one of them. The previous method used some zip code data to attempt to populate QTH and we had many complaints about this being wrong. At the very least, it didn't match the data being provided by lookup sources. For that reason, this will get resolved by way of getting 0003001 done right.

This should be a "child" of 0003001. As of this writing, there are problems with HamCall.net (0003510) and QRZCQ (0003493). Once those are done, we can verify that this can be closed. (It does work correctly with the other methods.)

WA9PIE

2019-10-29 03:36

administrator   ~0009058

It's good to have this one done. The QTH field is populated, per the ADIF specifications, with the City for the contacted station. This is true for all lookup sources that contain city data.

Validated.

Issue History

Date Modified Username Field Change
2019-07-05 09:51 KC7FPF New Issue
2019-07-05 15:21 K7ZCZ Assigned To => KC7FPF
2019-07-05 15:21 K7ZCZ Status new => feedback
2019-07-05 15:21 K7ZCZ Note Added: 0008194
2019-07-05 15:59 KC7FPF Note Added: 0008197
2019-07-11 14:23 K7ZCZ Relationship added related to 0003001
2019-07-11 18:50 K7ZCZ Note Added: 0008216
2019-07-11 23:34 WA9PIE Note Added: 0008217
2019-09-22 03:00 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2019-09-22 11:46 WA9PIE Note Edited: 0008217 View Revisions
2019-09-22 11:46 WA9PIE Note Edited: 0008217 View Revisions
2019-10-21 14:19 K7ZCZ Status feedback => resolved
2019-10-21 14:19 K7ZCZ Resolution open => fixed
2019-10-21 14:19 K7ZCZ Note Added: 0008896
2019-10-21 17:01 K7ZCZ Fixed in Version => 6.7.0.235
2019-10-23 03:51 g3ucq Note Added: 0008921
2019-10-23 03:58 WA9PIE Note Added: 0008924
2019-10-23 03:59 WA9PIE Relationship deleted related to 0003001
2019-10-23 03:59 WA9PIE Relationship added child of 0003001
2019-10-29 03:36 WA9PIE Status resolved => closed
2019-10-29 03:36 WA9PIE Fixed in Version 6.7.0.235 => 6.7.0.239
2019-10-29 03:36 WA9PIE Testing Not Started => Beta Successful
2019-10-29 03:36 WA9PIE Note Added: 0009058
2019-11-08 02:10 WA9PIE Fixed in Version 6.7.0.239 => 6.7.0.244
2019-11-08 02:32 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe