View Issue Details

IDProjectCategoryView StatusLast Update
0003377Ham Radio Deluxe[All Projects] Generalpublic2019-11-08 02:31
ReporterKB3NPHAssigned ToWA9PIE 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.7.0.244 
Summary0003377: V6.6.0.236 Logbook will not start without License Server coming up.
DescriptionTicket# 905491 - Most Flex operators to not use HRD Rig Control since they are controlling the radio via SmartSDR, DDUtil or SliceMaster. Once registered, when RC is run and the Logbook, DM-780, Rotor Control and/or Satellite tracker are started automatically, the License Manager does NOT come up. Many Flex operators add Logbook, and other modules to their Start Menu in Windows, so when Windows starts, the HRD modules they wish to use will auto start.

When the Logbook is started in this manner, from the Windows Start menu, the License Manager always comes up and requires the operator to click [OK] on the license manager before Logbook will load. This is quite annoying to these operators and they would like it to be where the logbook will load from the start menu when Windows boots up WITHOUT the license manager first coming up.
Steps To ReproduceSteps to replicate:

Add Logbook to the Windows Start menu so it will start when the computer is booted up.
Shut down computer and reboot.
Computer will begin rebooting and before Logbook starts, the License Manager will come up and you will have to click the [OK] button in order to get the logbook to load.
TagsNo tags attached.
ModuleSW License Mgmt
Sub-ModuleSW License Client
Testing Beta Successful

Activities

PD9FER

2019-07-05 11:36

viewer   ~0008193

Saw this happen also
"replicated"

KB3NPH

2019-07-10 01:49

administrator   ~0008208

Ticket# 181785 - Same thing is happening with another Flex radio user who is starting the rotor control without running HRD Rig Control because he uses his SmartSDR to control the radio, which gives better control than the HRD rig Control.

KB3NPH

2019-07-11 13:34

administrator   ~0008214

I just ran some tests on this which Mike C asked me to do. Did a freah install of V6.6.0.236 on a newly created W-10, 45-bit VM. Installed V6.6.0.236. When it came to the final screen where it gives you the checked selection to run HRD, I unchecked that option and clicked finish, so that it did NOT run the HRD software. After the box closed, I opened C:\Program Files (x86), navigated to the HRD Software LLC\Ham Radio Deluxe\ folder, located the HRDRotator.exe file and executed it. The License Manager came up first, allowing me to enter my callsign and activation key. Clicked the "Activate" button and after a few seconds it activated properly and the Rotator control screen appeared as normal. I then opened Logbook, which opened correctly without showing the License Manager. Checked License manager from the help screen in Logbook and it appeared proper, showing my Permanent license and SM&S exp. date. Checked all other modules individually and they opened with no issues as normal.

KB3NPH

2019-07-18 13:43

administrator   ~0008247

Ticket #224406
Same issue starting modules other than Rig Control as stand-alone programs.

PD9FER

2019-07-19 09:40

viewer   ~0008249

Ticket #345710
Same issue when using Win4K3

DOUG

2019-08-05 17:05

developer   ~0008328

There was a redundant license check, not 100% it was what was causing this one as reproducing in debugger was not possible. This change was done to the fundamental license code, so we should go through all licensing test procedures in next build.

WA9PIE

2019-08-09 19:32

administrator   ~0008352

Did this change go into a build?

Yes, we need to include this use case in test scenarios. If it's in a build, we can update this issue and have it tested (239?).

DOUG

2019-08-11 15:50

developer   ~0008377

yes this is in the 6.6 build from last week.

Issue History

Date Modified Username Field Change
2019-07-05 11:12 KB3NPH New Issue
2019-07-05 11:36 PD9FER Note Added: 0008193
2019-07-10 01:49 KB3NPH Note Added: 0008208
2019-07-11 13:34 KB3NPH Note Added: 0008214
2019-07-11 14:13 KB3NPH Assigned To => DOUG
2019-07-11 14:13 KB3NPH Status new => assigned
2019-07-18 13:43 KB3NPH Note Added: 0008247
2019-07-19 09:40 PD9FER Note Added: 0008249
2019-07-28 20:07 WA9PIE Project 1 - Backlog => 4 - Business Priorities
2019-07-28 20:07 WA9PIE Category Bug => General
2019-08-05 17:05 DOUG Note Added: 0008328
2019-08-05 20:54 DOUG Assigned To DOUG => WA9PIE
2019-08-09 19:32 WA9PIE Note Added: 0008352
2019-08-09 19:32 WA9PIE Assigned To WA9PIE => DOUG
2019-08-11 15:50 DOUG Assigned To DOUG => WA9PIE
2019-08-11 15:50 DOUG Status assigned => resolved
2019-08-11 15:50 DOUG Resolution open => fixed
2019-08-11 15:50 DOUG Note Added: 0008377
2019-08-11 16:09 WA9PIE Fixed in Version => 6.6.0.239
2019-08-30 16:25 K7ZCZ Fixed in Version 6.6.0.239 =>
2019-08-30 19:37 WA9PIE Project 4 - Business Priorities => 3 - Current Dev List
2019-08-30 19:38 WA9PIE Fixed in Version => 6.7.0.226
2019-09-14 01:28 WA9PIE Status resolved => closed
2019-09-14 01:28 WA9PIE Module (select) => SW License Mgmt
2019-09-14 01:28 WA9PIE Sub-Module (select) => SW License Client
2019-09-14 01:28 WA9PIE Testing Not Started => Beta Successful
2019-11-08 02:16 WA9PIE Fixed in Version 6.7.0.226 => 6.7.0.244
2019-11-08 02:31 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe