View Issue Details

IDProjectCategoryView StatusLast Update
00034203 - Current Dev ListBugpublic2019-09-22 17:37
ReporterWA9PIEAssigned ToWA9PIE 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.7.0.227 
Summary0003420: Deactivate not working
DescriptionLicense manager in our Ham Radio Deluxe code is not working. Deactivate should return a license back to the customer's key such that "Available Licenses" is incremented by 1.

As a result, there will come a time when people want to move from machine to machine (due to HW replacement) and there will be no Available Licenses in the key to allow it.

Because trial keys allow only 1 "Available License", we've already seen cases where customer want to move the trial to a different machine and they are unable to do so.
Steps To ReproduceI believe that a fresh key would begin life with:
Number of Licenses = 5
Available Licenses = 5
Activation Count = 0

After the first activation, it would look like this:
Number of Licenses = 5
Available Licenses = 4
Activation Count = 1
...this is working, as far as I can tell.

Upon a deactivation, it should look like this:
Number of Licenses = 5
Available Licenses = 5
Activation Count = 1
...this is not what's happening. Available Licenses remains at 4. Shouldn't it go to back to 5? Aren't we basically putting one of the licenses "back in the pool?"
TagsNo tags attached.
ModuleSW License Mgmt
Sub-ModuleSW License Client
Testing Beta Successful

Activities

DOUG

2019-08-11 15:42

developer   ~0008374

This is fixed in 6.7 change set 5117

This occurred after we added the ******* mask to the keys. It worked fine when doing the activate and deactivate at the same time, so that is why I couldn't reproduce it the first time.


WA9PIE

2019-08-11 16:07

administrator   ~0008378

Thanks Doug. That makes sense.

g3ucq

2019-09-22 15:51

updater   ~0008577

Unable to test

WA9PIE

2019-09-22 17:37

administrator   ~0008578

I validated this myself today. Nicely done, Doug.

Issue History

Date Modified Username Field Change
2019-08-10 22:20 WA9PIE New Issue
2019-08-10 22:20 WA9PIE Status new => assigned
2019-08-10 22:20 WA9PIE Assigned To => DOUG
2019-08-11 15:42 DOUG Status assigned => resolved
2019-08-11 15:42 DOUG Resolution open => fixed
2019-08-11 15:42 DOUG Note Added: 0008374
2019-08-11 16:07 WA9PIE Note Added: 0008378
2019-09-14 02:20 WA9PIE Fixed in Version => 6.7.0.227
2019-09-22 11:48 WA9PIE Assigned To DOUG => WA9PIE
2019-09-22 15:51 g3ucq Note Added: 0008577
2019-09-22 17:37 WA9PIE Status resolved => closed
2019-09-22 17:37 WA9PIE Testing Not Started => Beta Successful
2019-09-22 17:37 WA9PIE Note Added: 0008578