View Issue Details

IDProjectCategoryView StatusLast Update
0003439Ham Radio DeluxeBugpublic2019-11-08 02:32
ReporterK7ZCZAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.7.0.244 
Summary0003439: Panadapter dialog should not parent to the application window
Description
The panadapter dialogs parent to the application, which means they're always on top of the application. Tehy should be able to float so the application can be on top.


We might want to eventually give them an "always on top" option.

Steps To Reproduce1) Start up Rig Control
2) Connect to a panadapter-capable radio
3) Show the panadapter window
4) Position the panadapter window so it partially obscures the main Rig Control window
5) click on the main rig control application

BUG#1) The panadapter window remains on top, since it's a child of the main window. This obscures main window, and might make positioning the panadapter window(s) fussy and inconvenient
TagsNo tags attached.
ModuleRig Control
Sub-ModuleAppearance/UI
Testing Beta Successful

Relationships

related to 0003476 closedK7ZCZ Panadapter minimises with Rig Control 

Activities

K7ZCZ

2019-10-01 09:13

administrator   ~0008725

fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5179

g3ucq

2019-10-23 03:53

viewer   ~0008923

Fixed. Could the Panadapter screen have a "remain on top" option?

WA9PIE

2019-10-23 04:08

administrator   ~0008929

Validated

Issue History

Date Modified Username Field Change
2019-08-26 14:27 K7ZCZ New Issue
2019-10-01 09:12 K7ZCZ Relationship added related to 0003476
2019-10-01 09:13 K7ZCZ Assigned To => K7ZCZ
2019-10-01 09:13 K7ZCZ Status new => resolved
2019-10-01 09:13 K7ZCZ Resolution open => fixed
2019-10-01 09:13 K7ZCZ Note Added: 0008725
2019-10-21 17:01 K7ZCZ Fixed in Version => 6.7.0.235
2019-10-23 03:53 g3ucq Note Added: 0008923
2019-10-23 04:08 WA9PIE Status resolved => closed
2019-10-23 04:08 WA9PIE Description Updated View Revisions
2019-10-23 04:08 WA9PIE Steps to Reproduce Updated View Revisions
2019-10-23 04:08 WA9PIE Testing Not Started => Beta Successful
2019-10-23 04:08 WA9PIE Note Added: 0008929
2019-11-08 02:12 WA9PIE Fixed in Version 6.7.0.235 => 6.7.0.244
2019-11-08 02:32 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe