View Issue Details

IDProjectCategoryView StatusLast Update
0003456Ham Radio DeluxeBugpublic2019-11-08 02:32
Reporterg3ucqAssigned ToK7ZCZ 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSWindowsOS Version10 64 bit Home
Product Version 
Target VersionFixed in Version6.7.0.244 
Summary0003456: Panadapter causes Rig Control to close
DescriptionClosing the panadapter ceates a minidump file and closes Rig Control.
Steps To ReproduceUsing my IC-7610.
Open Rig Control and connect to the radio.
Open the Main panadapter from the RC Tools menu.
I notice that the screen update is very jerky with white rectangles appearing over the screen.
Click on the X close button and eventually the panadapter closes.
A few seconds later a minidump is created and Rig Control closes.
I was able to reproduce this twice so two minidump files were created.
One minidump is slightly large than the other so have included both in the zip file.
Additional InformationI have also opened the Sub panadapter but nothing is displayed on the screen and the contr5ols show no information.
TagsNo tags attached.
ModuleRig Control
Sub-ModulePanadapter
Testing Beta Successful

Relationships

related to 0002775 closedK7ZCZ Add Icom panadapter application to suite 

Activities

g3ucq

2019-09-25 03:46

viewer  

HRDLLC.zip (19,403,937 bytes)

K7ZCZ

2019-09-25 09:22

administrator   ~0008662

The HamRadioDeluxe_20190925_083312.mdmp attached to this issue is corrupt and can't be opened by WinDbg.

The HamRadioDeluxe_20190925_083456.mdmp attached here and the HamRadioDeluxe_20190902_134140.mdmp and HamRadioDeluxe_20190903_082249.mdmp files attached to 2775 are all the same call stack. They come from build 6.7.0.227.

The call stack is given here. At issue is the panadapter window notifying the main radio view that it has closed. The view still tries to send commands to it after being shut, but the main view is still carrying a pointer to the closed window.

0:000> kb
  *** Stack trace for last set context - .thread/.cxr resets it
 # ChildEBP RetAddr  Args to Child              
00 003aef84 00c9696a e498677a 00000000 0ccce438 HamRadioDeluxe!CWnd::SetFocus+0x62 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\winocc.cpp @ 367] 
01 003aefac 00d14892 00000000 012c0490 00000111 HamRadioDeluxe!CRadioView::OnToolsPanadapter+0x4a [c:\hrd67\hamradiodeluxe\radioview.cpp @ 7629] 
02 003aefc0 00d1468e 0ccce438 00008456 00000000 HamRadioDeluxe!_AfxDispatchCmdMsg+0x4e [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\cmdtarg.cpp @ 78] 
03 003aeff8 00d2c782 00008456 00000000 00000000 HamRadioDeluxe!CCmdTarget::OnCmdMsg+0x154 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\cmdtarg.cpp @ 372] 
04 003af038 00d1c7a9 00008456 00000000 00000000 HamRadioDeluxe!CView::OnCmdMsg+0x1f [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\viewcore.cpp @ 164] 
05 003af07c 00d0f7cd 00008456 00000000 00000000 HamRadioDeluxe!CFrameWnd::OnCmdMsg+0x47 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\winfrm.cpp @ 980] 
06 003af0cc 00d1c883 00008456 00000000 7fffffff HamRadioDeluxe!CWnd::OnCommand+0x61 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 2800] 
07 003af0e8 00d104f9 00008456 00000000 e498796e HamRadioDeluxe!CFrameWnd::OnCommand+0x7d [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\winfrm.cpp @ 384] 
08 003af1b8 00d11dbc 00000111 00008456 00000000 HamRadioDeluxe!CWnd::OnWndMsg+0x45 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 2113] 
09 003af1dc 00d0cc83 00000111 00008456 00000000 HamRadioDeluxe!CWnd::WindowProc+0x2d [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 2099] 
0a 003af250 00d35b9c 00835480 000706d0 00000111 HamRadioDeluxe!AfxCallWndProc+0xc6 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 268] 
0b 003af274 00d104f9 00008456 00000000 e4987b92 HamRadioDeluxe!CMDIFrameWnd::OnCommand+0x27 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\winmdi.cpp @ 43] 
0c 003af344 00c1c488 00000111 00008456 00000000 HamRadioDeluxe!CWnd::OnWndMsg+0x45 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 2113] 
0d 003af36c 00d11dbc 00000111 00008456 00000000 HamRadioDeluxe!CXTPCommandBarsSiteBase<CMDIFrameWnd>::OnWndMsg+0x68 [c:\hrd67\codejock software\mfc\xtreme toolkitpro v18.6.0\source\commandbars\xtpframewnd.h @ 204] 
0e 003af390 00d0cc83 00000111 00008456 00000000 HamRadioDeluxe!CWnd::WindowProc+0x2d [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 2099] 
0f 003af404 00d0d43e 00841fa8 0004098c 00000111 HamRadioDeluxe!AfxCallWndProc+0xc6 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 268] 
10 003af424 770d48eb 0004098c 00000111 00008456 HamRadioDeluxe!AfxWndProc+0x34 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 417] 
11 003af450 770b613c 00d0d40a 0004098c 00000111 user32!_InternalCallWinProc+0x2b
12 003af534 770b568f 00d0d40a 00000000 00000111 user32!UserCallWinProcCheckWow+0x3ac
13 003af56c 00f2a12a 00d0d40a 0004098c 00000111 user32!CallWindowProcW+0x7f
14 003af5b4 770d48eb 00d0d40a 00000111 00008456 HamRadioDeluxe!CXTPHookManager::HookWndProc+0xaa [c:\program files (x86)\codejock software\mfc\xtreme toolkitpro v18.6.0\source\common\xtphookmanager.cpp @ 440] 
15 003af5e0 770b613c 00f2a080 0004098c 00000111 user32!_InternalCallWinProc+0x2b
16 003af6c4 770b58ed 00f2a080 00000000 00000111 user32!UserCallWinProcCheckWow+0x3ac
17 003af728 770b55b3 01e50e30 00000000 00000000 user32!SendMessageWorker+0x1fd
18 003af758 00e93a98 0004098c 00000111 00008456 user32!SendMessageW+0x123
19 (Inline) -------- -------- -------- -------- HamRadioDeluxe!CWnd::SendMessageW+0x12 [c:\program files (x86)\microsoft visual studio\2017\professional\vc\tools\msvc\14.16.27023\atlmfc\include\afxwin2.inl @ 32] 
1a (Inline) -------- -------- -------- -------- HamRadioDeluxe!NotifyExecute+0x27 [c:\program files (x86)\codejock software\mfc\xtreme toolkitpro v18.6.0\source\commandbars\xtpcontrol.cpp @ 335] 
1b 003af794 00f9723e 00874bd0 00eeed74 00000047 HamRadioDeluxe!CXTPControl::OnExecute+0x188 [c:\program files (x86)\codejock software\mfc\xtreme toolkitpro v18.6.0\source\commandbars\xtpcontrol.cpp @ 577] 
1c 003af79c 00eeed74 00000047 000000fe 00eeed40 HamRadioDeluxe!CXTPControlButton::OnLButtonUp+0x2e [c:\program files (x86)\codejock software\mfc\xtreme toolkitpro v18.6.0\source\commandbars\xtpcontrolbutton.cpp @ 69] 
1d 003af7b0 00d10a30 00000000 00000047 000000fe HamRadioDeluxe!CXTPCommandBar::OnLButtonUp+0x34 [c:\program files (x86)\codejock software\mfc\xtreme toolkitpro v18.6.0\source\commandbars\xtpcommandbar.cpp @ 521] 
1e 003af884 00eef7ab 00000202 00000000 00fe0047 HamRadioDeluxe!CWnd::OnWndMsg+0x57c [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 2698] 
1f 003af8a0 00d11dbc 00000202 00000000 00fe0047 HamRadioDeluxe!CXTPCommandBar::OnWndMsg+0x2b [c:\program files (x86)\codejock software\mfc\xtreme toolkitpro v18.6.0\source\commandbars\xtpcommandbar.cpp @ 2621] 
20 003af8c4 00d0cc83 00000202 00000000 00fe0047 HamRadioDeluxe!CWnd::WindowProc+0x2d [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 2099] 
21 003af938 00d0d43e 00874bd0 0009069a 00000202 HamRadioDeluxe!AfxCallWndProc+0xc6 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 268] 
22 003af958 770d48eb 0009069a 00000202 00000000 HamRadioDeluxe!AfxWndProc+0x34 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 417] 
23 003af984 770b613c 00d0d40a 0009069a 00000202 user32!_InternalCallWinProc+0x2b
24 003afa68 770b568f 00d0d40a 00000000 00000202 user32!UserCallWinProcCheckWow+0x3ac
25 003afaa0 00f2a12a 00d0d40a 0009069a 00000202 user32!CallWindowProcW+0x7f
26 003afae8 770d48eb 00d0d40a 00000202 00000000 HamRadioDeluxe!CXTPHookManager::HookWndProc+0xaa [c:\program files (x86)\codejock software\mfc\xtreme toolkitpro v18.6.0\source\common\xtphookmanager.cpp @ 440] 
27 003afb14 770b613c 00f2a080 0009069a 00000202 user32!_InternalCallWinProc+0x2b
28 003afbf8 770b528e 00f2a080 00000000 00000202 user32!UserCallWinProcCheckWow+0x3ac
29 003afc6c 770b5070 00000202 003afca4 00d1ec12 user32!DispatchMessageWorker+0x20e
2a 003afc78 00d1ec12 007dd818 00000000 00d1f26c user32!DispatchMessageW+0x10
2b 003afc88 00d1f2da 01379898 00d2ecd5 ffffffff HamRadioDeluxe!AfxInternalPumpMessage+0x3e [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\thrdcore.cpp @ 183] 
2c 003afca4 01113683 00000000 01490b64 00564000 HamRadioDeluxe!CWinThread::Run+0x69 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\thrdcore.cpp @ 629] 
2d 003afcbc 00e5b883 00b30000 00000000 007810e8 HamRadioDeluxe!AfxWinMain+0x93 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\winmain.cpp @ 61] 
2e (Inline) -------- -------- -------- -------- HamRadioDeluxe!invoke_main+0x1a [d:\agent\_work\3\s\src\vctools\crt\vcstartup\src\startup\exe_common.inl @ 118] 
2f 003afd08 75ee6359 00564000 75ee6340 003afd74 HamRadioDeluxe!__scrt_common_main_seh+0xf8 [d:\agent\_work\3\s\src\vctools\crt\vcstartup\src\startup\exe_common.inl @ 288] 
30 003afd18 772a7b74 00564000 969fe492 00000000 kernel32!BaseThreadInitThunk+0x19
31 003afd74 772a7b44 ffffffff 772c8f15 00000000 ntdll!__RtlUserThreadStart+0x2f
32 003afd84 00000000 00e5b907 00564000 00000000 ntdll!_RtlUserThreadStart+0x1b

K7ZCZ

2019-09-25 17:15

administrator   ~0008673

I've checked in a fix here:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5168


but I'm concerned that the evidence in the minidump doesn't precisely match the given repro case. The minidumps show crashes in response to the user clicking on the "Panadapter" or "Sub Panadapter" menu items. The repro steps provided don't mention that action, and instead say that the crash happens after simply waiting a few seconds.

I'm not able to reproduce a crash after closing the panadapter window and simply waiting. Maybe the repro steps are just a bit off, or maybe there's a different bug here -- but I can't reproduce it. It would help to have a minidump from a crash that was actually caused by waiting and not by clicking on the menu item again.

g3ucq

2019-09-26 03:38

viewer   ~0008689

Because the reaction to menu selection and other clicks was so intermittent and erratic it was not possible to know what sequence of clicks caused the minidumps. The minidumps were certainly created after clicking the close button which also closed Rig Control.

g3ucq

2019-10-23 04:06

viewer   ~0008927

Fixed.

WA9PIE

2019-10-23 07:18

administrator   ~0008958

Validated.

Issue History

Date Modified Username Field Change
2019-09-25 03:46 g3ucq New Issue
2019-09-25 03:46 g3ucq File Added: HRDLLC.zip
2019-09-25 09:17 K7ZCZ Relationship added related to 0002775
2019-09-25 09:22 K7ZCZ Note Added: 0008662
2019-09-25 09:23 K7ZCZ Assigned To => K7ZCZ
2019-09-25 09:23 K7ZCZ Status new => assigned
2019-09-25 09:23 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2019-09-25 17:15 K7ZCZ Status assigned => resolved
2019-09-25 17:15 K7ZCZ Resolution open => fixed
2019-09-25 17:15 K7ZCZ Note Added: 0008673
2019-09-26 03:38 g3ucq Note Added: 0008689
2019-10-21 17:01 K7ZCZ Fixed in Version => 6.7.0.235
2019-10-23 04:06 g3ucq Note Added: 0008927
2019-10-23 07:18 WA9PIE Status resolved => closed
2019-10-23 07:18 WA9PIE Sub-Module (select) => Panadapter
2019-10-23 07:18 WA9PIE Testing Not Started => Beta Successful
2019-10-23 07:18 WA9PIE Note Added: 0008958
2019-11-08 02:12 WA9PIE Fixed in Version 6.7.0.235 => 6.7.0.244
2019-11-08 02:32 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe