View Issue Details

IDProjectCategoryView StatusLast Update
00034605 - Closed w/o ActionEnhancementpublic2019-11-08 04:25
Reporterg3ucqAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionwon't fix 
PlatformPCOSWindowsOS Version10 64 bit Home
Summary0003460: Panadapter drop down lists are too close and difficult to access the options
DescriptionThe drop down menus are too close and difficult to access the options.
Steps To ReproduceWith the panadapter open it is difficult to access the options from the drop down menus.
There is also room for them to be further apart.
TagsNo tags attached.
ModuleRig Control
Sub-Module(select)
TestingNot Started

Relationships

related to 0002775 closedK7ZCZ Ham Radio Deluxe Add Icom panadapter application to suite 

Activities

g3ucq

2019-09-25 10:46

updater  

Menus.jpg (21,428 bytes)
Menus.jpg (21,428 bytes)

K7ZCZ

2019-09-25 17:31

administrator   ~0008677

The combo-box controls have six dialog units of space between them. This is actually larger than the Microsoft-recommended four units of space. (See pages 450-452 of The Microsoft Windows User Experience book.)

The controls and their settings are accessible from the keyboard using the tab and arrow keys, as is the Windows standard.

Perhaps if a clear case can be made for how the usability of the dialog is impacted I can make an adjustment, but since the controls are already further apart than standard, I'm not compelled to entertain such a change.

g3ucq

2019-09-26 08:39

updater   ~0008692

How about this?

Menus-2.jpg (54,945 bytes)
Menus-2.jpg (54,945 bytes)

K7ZCZ

2019-09-26 09:11

administrator   ~0008695

This arrangement is too wide. Not all radios present a bandscope display as wide as yours does. We might consider the enhancement if we had more resources, but at this point I don't think it's worth the time to implement the code to provide per-radio layouts of the controls, or to implement dynamic layout in this area to support personal preferences when many other more pressing items are present.

WA9PIE

2019-11-08 04:25

administrator   ~0009210

Closing to move them into the w/o action bucket

Issue History

Date Modified Username Field Change
2019-09-25 10:46 g3ucq New Issue
2019-09-25 10:46 g3ucq File Added: Menus.jpg
2019-09-25 17:20 K7ZCZ Relationship added related to 0002775
2019-09-25 17:26 K7ZCZ Summary Panadapter enhancement => Panadapter drop down lists are too close and difficult to access the options
2019-09-25 17:31 K7ZCZ Note Added: 0008677
2019-09-25 17:31 K7ZCZ Assigned To => K7ZCZ
2019-09-25 17:31 K7ZCZ Status new => resolved
2019-09-25 17:31 K7ZCZ Resolution open => won't fix
2019-09-26 08:39 g3ucq File Added: Menus-2.jpg
2019-09-26 08:39 g3ucq Note Added: 0008692
2019-09-26 09:11 K7ZCZ Note Added: 0008695
2019-10-11 09:17 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2019-11-08 04:25 WA9PIE Status resolved => closed
2019-11-08 04:25 WA9PIE Note Added: 0009210
2019-11-08 04:25 WA9PIE Project 3 - Current Dev List => 5 - Closed w/o Action