View Issue Details

IDProjectCategoryView StatusLast Update
00034623 - Current Dev ListBugpublic2019-10-23 07:22
ReporterWA9PIEAssigned ToK7ZCZ 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version6.7.0.230 
Target VersionFixed in Version6.7.0.235 
Summary0003462: call sign lookup options should always list Unique Call sign Database first
DescriptionThe functional specifications for 0003001 was to have the HRD Country List listed, permanently as the "source of last resort."

The specification reads as follows:

The callsign lookup operation uses the remote station’s callsign to retrieve information about the callsign identified in the QSO. The lookup operation proceeds with these steps:
1. The Public Unique Callsign Database (UCSDB) is searched for the target callsign. This data source is used unconditionally; the user may not re-order it or disable it.
2. The Private UCSDB is searched for the callsign. This option is performed unconditionally.
3. Each of the options specified by the user as “enabled” in the Callsign Lookup settings dialog box are visited. These sources are visited in the order specified.
4. The Ham Radio Deluxe Country List is visited to retrieve the callsign’s country (FLD_QSO_COUNTRY). No other fields are retrieved from this source. The Country List data source is used unconditionally.

Then...

The Public UCSDB, Private UCSDB, and HRD Country List sources are always listed, since they’re unconditionally considered. Their entries are not movable. They are shown in the UI for discover-ability; so that users understand they exist and understand their relative position.
Steps To Reproduce- Launch Logbook
- Go to Tools > Configure > Callsign Lookup

In the Enable tab, refer the Enabled Methods...
- Country List can be moved from the bottom of the list... rather than being stuck at the bottom of the list or displayed under the Enabled Methods.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleCall lookup
TestingNot Started

Relationships

related to 0003511 assignedWA9PIE Callsign Lookup dialog box has confusing UI 
child of 0003001 assignedWA9PIE Callsign lookup function does not appear to be working as designed 

Activities

WA9PIE

2019-09-25 22:20

administrator  

HRD_CountryList.PNG (36,196 bytes)
HRD_CountryList.PNG (36,196 bytes)

K7ZCZ

2019-09-25 22:35

administrator   ~0008684

Does the existing "Country list" source need to be split into separate "Private UCSDB" and "Public UCSDB" sources?

WA9PIE

2019-10-01 15:40

administrator   ~0008729

This had been discussed back prior to 2017. We decided not to break them up because it just creates one more file to manage. At this point, I don't think it's necessary to split them up.

When we refer to the UCSDB (either Public or Private) and the HRD Country List... we're really talking about as logically separate things - even though they exist in the same file... which happens to be called "countrylist.xml" (or whatever it is).

So...

If we're going to show people that the callsign lookup function unconditionally includes the UCSDB (and HRD Country List)... then those things should be shown outside of the "Enabled Methods" so that the user doesn't get the impression that they can change the order. For example:

------------
UCSDB Public
UCSDB Private
=======
"Enabled Methods" (QRZ.com, QRZCQ, HamCall... etc... as the users may enable); this section should be the only section that the users can re-order.
=======
HRD Country list

K7ZCZ

2019-10-01 18:40

administrator   ~0008730

My question isn't about files. Instead, it's about the sources listed in the "Enabled" list box in the configuration UI.

Can we confirm that the list should show separate entries for "UCSDB Public", "UCSDB Private", and "HRD Country List"? Right now, the box shows only "Country List".

WA9PIE

2019-10-02 11:35

administrator   ~0008732

Yes, exactly. The UCSDB options should appear in a section above "Enabled Methods". HRD Country List should appear below "Enabled Methods."

------------
UCSDB Public
UCSDB Private
=======
"Enabled Methods" (QRZ.com, QRZCQ, HamCall... etc... as the users may enable); this section should be the only section that the users can re-order.
=======
HRD Country list

[Frankly, I'd be fine if we didn't show users the UCSDB (Public and Private) or the HRD Country List at all.]

K7ZCZ

2019-10-02 21:09

administrator   ~0008735

Great, thanks. I'll see if I can get it wired-up that way.

K7ZCZ

2019-10-05 18:59

administrator   ~0008757

resolved with this change set:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5185

note that this changes the option persistence and the UI. The new UCSDB entries are also added, since they didn't exist before. However, the logic of the call sign lookup code doesn't yet consider these sources explicitly because some questions remain about their definition.

WA9PIE

2019-10-07 06:01

administrator   ~0008761

What questions remain?

I'm looking in the 6.7.0.230 beta and I don't see the UCSDB. There was no request to change the way the UCSDB was treated in the lookup... only a concern that we should display it as a lookup source.

WA9PIE

2019-10-23 04:07

administrator   ~0008928

Last edited: 2019-10-23 04:07

View 2 revisions

As soon as 0003510 is complete, I'll get back to testing this one. 0003510 is somewhat of a prerequisite. I'm pretty sure is working now though.

g3ucq

2019-10-23 04:16

updater   ~0008938

Public UCSDB and Private USCDB available but cannot be removed, nor the Country List.

WA9PIE

2019-10-23 07:22

administrator   ~0008959

That's by design, John.

It's not very clear in the UI... so I've written Mantis 0003511 to help clarify it.

Point is... the top two options will always be UCSDB Public... and UCSDB Private (in that order). It's always been that way. But there was an idea that we should actually show it to people this way now.

Country List will always be the last option... because it's the least specific option.

Issue History

Date Modified Username Field Change
2019-09-25 22:20 WA9PIE New Issue
2019-09-25 22:20 WA9PIE File Added: HRD_CountryList.PNG
2019-09-25 22:20 WA9PIE Relationship added child of 0003001
2019-09-25 22:21 WA9PIE Assigned To => K7ZCZ
2019-09-25 22:21 WA9PIE Status new => assigned
2019-09-25 22:21 WA9PIE Description Updated View Revisions
2019-09-25 22:21 WA9PIE Steps to Reproduce Updated View Revisions
2019-09-25 22:34 K7ZCZ Summary Callsign lookup function does not appear to be working as designed #2 => call sign lookup options should always list Unique Call sign Database first
2019-09-25 22:34 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-09-25 22:35 K7ZCZ Note Added: 0008684
2019-10-01 15:40 WA9PIE Note Added: 0008729
2019-10-01 15:40 WA9PIE Assigned To WA9PIE => K7ZCZ
2019-10-01 18:40 K7ZCZ Note Added: 0008730
2019-10-01 18:40 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-10-02 11:35 WA9PIE Note Added: 0008732
2019-10-02 11:35 WA9PIE Assigned To WA9PIE => K7ZCZ
2019-10-02 21:09 K7ZCZ Note Added: 0008735
2019-10-05 18:59 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-10-05 18:59 K7ZCZ Status assigned => resolved
2019-10-05 18:59 K7ZCZ Resolution open => fixed
2019-10-05 18:59 K7ZCZ Note Added: 0008757
2019-10-07 06:01 WA9PIE Assigned To WA9PIE => K7ZCZ
2019-10-07 06:01 WA9PIE Note Added: 0008761
2019-10-21 17:01 K7ZCZ Fixed in Version => 6.7.0.235
2019-10-23 04:01 WA9PIE Relationship added related to 0003511
2019-10-23 04:07 WA9PIE Note Added: 0008928
2019-10-23 04:07 WA9PIE Note Edited: 0008928 View Revisions
2019-10-23 04:16 g3ucq Note Added: 0008938
2019-10-23 07:22 WA9PIE Note Added: 0008959