View Issue Details

IDProjectCategoryView StatusLast Update
00034723 - Current Dev ListEnhancementpublic2019-11-08 02:18
Reporterg3ucqAssigned Tog3ucq 
PrioritynormalSeverityminorReproducibilityhave not tried
Status feedbackResolutionreopened 
PlatformPCOSWindowsOS Version10 64 bit Home
Product Version 
Target VersionFixed in Version 
Summary0003472: settings for brightness and contrast in waterfall
DescriptionPlease add controls to adjust Brightness and Contrast for the waterfall.
TagsNo tags attached.
ModuleRig Control
Sub-ModulePanadapter
TestingNot Started

Relationships

related to 0002718 new 1 - Backlog Development of high-contrast screens 
related to 0003471 closedK7ZCZ Ham Radio Deluxe Panadapter colors could be settable 

Activities

K7ZCZ

2019-09-27 09:08

administrator   ~0008711

For now, the value reported from the radio is mapped to a range of 0..255. The color is chosen by using the mapped value for the red and green components of the color. The blue component is chosen by taking three times the mapped value, capped at 255. Thus, no signal strength maps to black, and full signal strength maps to white. Intermediate signals map to other colors with a stronger blue component; 50% signal strength is shown with #8080FF, for example.

Mathematically, the color is chosen by:

scale = 255 * (sample / fullScale)
color = RGB(scale, scale, max(255, scale * 3))


where sample is the given sample value in the radio's scale and fullScale is the radio's documented full-scale value.

The existing function, then, already has 100% dynamic range as it uses the full range of colors for the full intensity of the radio's scale; an since that range is drawn on a black background, it already has maximum contrast.

There are any number of different ways to convert signal strength into a visual representation, including color and intensity. I don't know of any standardized algorithms or transforms. Since this is largely a matter of preference, I think we should explore different mappings and keep those that seem particularly popular or effective. It will take time to collect feedback and suggestions and test.

Until then, the easiest way to adjust the display is with the base-line reference setting either in the panadapter window or on the radio.

K7ZCZ

2019-10-13 14:29

administrator   ~0008811

With the color settings available, I'm resolving this fixed. If you have some specific idea of how you'd like to mathematically define "contrast" and "brightness" as quantities in the context I've supplied, please do let me know and we can consider it.

WA9PIE

2019-10-23 08:12

administrator   ~0008973

Any word on the disposition of this item?

Code needed? Or not?

g3ucq

2019-10-23 08:14

updater   ~0008974

Which ever way is implemented, the waterfall is too dark with poor contrast.

g3ucq

2019-11-06 04:13

updater   ~0009156

N1MM+ has a contrast control so I can match the waterfall to that on my IC-7610.

N1MM.jpg (78,825 bytes)
N1MM.jpg (78,825 bytes)

WA9PIE

2019-11-06 16:31

administrator   ~0009183

I'm taking this out of Resolved status. It's clearly not "resolved."

It may be something we take-on after the initial 6.7 release.

Issue History

Date Modified Username Field Change
2019-09-27 03:59 g3ucq New Issue
2019-09-27 09:08 K7ZCZ Note Added: 0008711
2019-09-27 10:04 K7ZCZ Summary Panadapter enhancement => settings for brightness and contrast in waterfall
2019-10-13 12:54 K7ZCZ Relationship added related to 0002718
2019-10-13 12:55 K7ZCZ Relationship added related to 0003471
2019-10-13 14:29 K7ZCZ Assigned To => K7ZCZ
2019-10-13 14:29 K7ZCZ Status new => resolved
2019-10-13 14:29 K7ZCZ Resolution open => fixed
2019-10-13 14:29 K7ZCZ Note Added: 0008811
2019-10-13 14:29 K7ZCZ Assigned To K7ZCZ => g3ucq
2019-10-21 17:03 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2019-10-23 08:12 WA9PIE Note Added: 0008973
2019-10-23 08:14 g3ucq Note Added: 0008974
2019-10-29 15:52 K7ZCZ Fixed in Version => 6.7.0.239
2019-11-06 04:13 g3ucq File Added: N1MM.jpg
2019-11-06 04:13 g3ucq Note Added: 0009156
2019-11-06 16:31 WA9PIE Status resolved => feedback
2019-11-06 16:31 WA9PIE Resolution fixed => reopened
2019-11-06 16:31 WA9PIE Sub-Module (select) => Panadapter
2019-11-06 16:31 WA9PIE Note Added: 0009183
2019-11-08 02:18 WA9PIE Fixed in Version 6.7.0.239 =>