View Issue Details

IDProjectCategoryView StatusLast Update
0003474Ham Radio DeluxeMaintenancepublic2019-11-08 02:32
ReporterK7ZCZAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version6.7.0.227 
Target VersionFixed in Version6.7.0.244 
Summary0003474: CLookupFieldComputer is mostly no longer used
DescriptionWith the call sign lookup rewrite in place, the CLookupFieldComputer class is mostly unused. A couple of utility functions remain; seems best to rename the class to match those utility functions and delete the unused code.

TagsNo tags attached.
ModuleLogbook
Sub-ModuleCall lookup
Testing N/A

Relationships

has duplicate 0003443 resolvedK7ZCZ CLookupFieldComputer can mostly be removed 

Activities

K7ZCZ

2019-09-29 10:16

administrator   ~0008721

fixed with these checkins:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5173
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5174

the CLookupFieldComputer class is no longer involved in lookups. It had some poorly-factore static members; one is moved to the CHRDLogbookApp class. The others remain, but the CLookupFieldComputer class is renamed to CStationFieldManager to reflect the usage of those methods.


WA9PIE

2019-10-23 04:17

administrator   ~0008939

Due to the nature of this change, it is difficult to repro/test. Therefore, I'll accept it as complete and close it.

Issue History

Date Modified Username Field Change
2019-09-28 17:37 K7ZCZ New Issue
2019-09-29 10:16 K7ZCZ Assigned To => K7ZCZ
2019-09-29 10:16 K7ZCZ Status new => resolved
2019-09-29 10:16 K7ZCZ Resolution open => fixed
2019-09-29 10:16 K7ZCZ Note Added: 0008721
2019-09-30 19:26 K7ZCZ Relationship added has duplicate 0003443
2019-10-21 17:01 K7ZCZ Fixed in Version => 6.7.0.235
2019-10-23 04:17 WA9PIE Status resolved => closed
2019-10-23 04:17 WA9PIE Testing Not Started => N/A
2019-10-23 04:17 WA9PIE Note Added: 0008939
2019-11-08 02:12 WA9PIE Fixed in Version 6.7.0.235 => 6.7.0.244
2019-11-08 02:32 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe