View Issue Details

IDProjectCategoryView StatusLast Update
00034785 - Closed w/o ActionEnhancementpublic2019-11-08 04:25
ReporterWA9PIEAssigned ToK7ZCZ 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionwon't fix 
Summary0003478: Add the option for the users to populate only first name into the FLD_QSO_NAME field
DescriptionWe have a request to add an option for the users to populate only first name into the FLD_QSO_NAME field
https://support.hamradiodeluxe.com/scp/tickets.php?id=10644

Meanwhile, the FLD_QSO_ADDRESS would continue contain the full name (no change).
Steps To ReproduceGiven that this is a feature request, there aren't steps to reproduce this.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleALE Window
TestingNot Started

Activities

K7ZCZ

2019-10-02 18:55

administrator   ~0008734

This request can't be accommodated as some data sources don't provide distinct first, middle, and last name fields. HamQTH and QRZCQ, for example, provide only "adr_name" and "name" (respectively). These fields include the whole name.

Parsing names isn't trivial, and since they're names, people are sensitive to them being wrong. In some languages (Chinese, Japanese, Arabic, ...) parsing is very complicated and requires semantic analysis. Even in western names, ambiguity is significant. For such data sources given "Jean Luc Picard", we'd be forced to guess the first name as "Jean" when it might be "Jean Luc". The new call sign lookup code has "no guessing" as one of its fundamental tenets; as such, the request can't be accommodated. Honorifics (eg, "Cpt. Jean Luc Picard") and multi-part names ("George Herbert Walker Bush") add more complications.

If we'd like to relax that tenet and allow guessing; or if we'd like to make an exception, then we should carefully review and decide how to do so.

WA9PIE

2019-11-08 04:25

administrator   ~0009209

Closing to move them into the w/o action bucket

Issue History

Date Modified Username Field Change
2019-10-01 15:49 WA9PIE New Issue
2019-10-01 15:49 WA9PIE Project 3 - Current Dev List => 1 - Backlog
2019-10-02 18:55 K7ZCZ Assigned To => K7ZCZ
2019-10-02 18:55 K7ZCZ Status new => resolved
2019-10-02 18:55 K7ZCZ Resolution open => won't fix
2019-10-02 18:55 K7ZCZ Note Added: 0008734
2019-10-11 09:17 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2019-11-08 04:25 WA9PIE Status resolved => closed
2019-11-08 04:25 WA9PIE Note Added: 0009209
2019-11-08 04:25 WA9PIE Project 3 - Current Dev List => 5 - Closed w/o Action