View Issue Details

IDProjectCategoryView StatusLast Update
0003485Ham Radio DeluxeBugpublic2019-11-11 05:38
ReporterKB3NPHAssigned ToK7ZCZ 
PriorityurgentSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version6.7.0.231 
Target VersionFixed in Version6.7.0.244 
Summary0003485: Logbook Lookup Pane does not fully populate
DescriptionWhen clicking on a spot in the DX cluster to add the call to the Lookup Pane (on left side of display), the "Callsign", the "Country", and the "IOTA" portions of the Lookup pane do no populate as shown in the image I have attached.
Steps To Reproduce1. Open HRD Logbook
2. On the top menu click on "VIEW" and select "Lookup"
3. The Lookup Pane will then be visible on the left side of the Logbook display.
4. Open the DX Cluster panel.
5. When the DX Cluster panel begins to populate with DX records, click on one of the DX records to populate the Lookup Pane.
6. Notice that the Lookup panel does not populate properly. (see Logbook Pane Bug.jpg)

The way it should be populated and look is demonstrated in the image MyLogbook Proper Lookup Pane display.pgn shown in the attacjed images.
Additional InformationI can't tell when this broke. The image I've added comments to for 9Z4CT was provided by Ferry. I don't know which version he pulled it from.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleCall lookup
Testing Beta Successful

Relationships

related to 0003538 closedK7ZCZ Ham Radio Deluxe Lookup Pane sections now always begin as retracted (6.7.0.240 build) 
related to 0003482 new 3 - Current Dev List Improve timeout detection in call sign lookup operation completion 
related to 0003532 new 3 - Current Dev List Lookup pane in Logbook suffers from race condition 
related to 0003531 new 3 - Current Dev List Logbook Lookup Pane ignores or doesn't handle database errors 
related to 0003530 new 3 - Current Dev List Lookup Pane uses WSI-configured databases for lookups 
related to 0003529 new 3 - Current Dev List Lookup Pane works even when no Logbook database has focus 
related to 0003534 new 3 - Current Dev List Lookup pane spuriously looks up call signs only partially entered 
related to 0003533 new 3 - Current Dev List Lookup pane in Logbook doesn't update highlight of current radio band or mode 
related to 0003562 closedK7ZCZ 3 - Current Dev List Latitude and Longitude in the Country section of the Lookup pane always displays "0.00, 0.00" when any enabled method is include 
related to 0003574 assignedK7ZCZ 3 - Current Dev List Lat/Long in the Logbook Lookup Pane are on different rows 

Activities

K7ZCZ

2019-10-17 09:15

administrator   ~0008840

This report says "MyLogbook Proper Lookup Pane display.pgn shown in the attacjed images", but no images are attached. Can the image please be added?

KB3NPH

2019-10-21 15:21

administrator   ~0008898

This is very weird. The attachments were here early this morning. I will re-enter them separately. In The image attached to this note, indicates the Lookup Pane does NOT populate with all of the data when clicking on a DX spot. Only the License tab is populated. The Country and IOTA tabs indicated by the #1 are not populated and does not populate no matter what DX spot you choose.

DX Cluster Lookup Not Populating Lookup Pane.jpg (263,867 bytes)

WA9PIE

2019-10-22 10:19

administrator   ~0008903

Okay... this was created "way back when" Simon was coding this. I can't find any documentation about how this is built. I generally know what it's intended to show. So all I can do is describe it as best I can. I've done that in the attached picture.

Lookup.jpg (312,561 bytes)

PD9FER

2019-10-22 10:24

viewer   ~0008904

The version I used was the latest 6.5 release
Also, I did not clicked on a DX Spot but manually entered the call in the Lookup Pane

WA9PIE

2019-10-28 19:48

administrator   ~0009049

I cannot reproduce any problem with the Lookup Pane prior to the 6.7 beta builds.

The attached image was created using 6.6.0.237. I've got a couple images I'll post.

Lookup237Release.png (192,284 bytes)
Lookup237Release.png (192,284 bytes)

WA9PIE

2019-10-28 19:53

administrator   ~0009050

In this image, I do a lookup for OH4UI (same call as Tim is showing) where I'm using only Country List as a callsign lookup source. This makes me curious about why the licensee info is filled out at all. I'm inclined to believe that the lookup pane is using QRZ.com's XML lookup, regardless of whether or not it's selected (a point that we could tackle separately).

OH4UI.png (44,201 bytes)
OH4UI.png (44,201 bytes)

K7ZCZ

2019-10-30 18:32

administrator   ~0009099

This checkin gets the Lookup pane working more reliably in the 6.7 builds:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5253

There are several discrepancies from the notes in the picture posted here, so I'll be opening some other issues and relating them back to this one to document those issues.

WA9PIE

2019-11-02 00:07

administrator   ~0009109

Validated. Now tracking new item 0003538

Issue History

Date Modified Username Field Change
2019-10-10 10:40 KB3NPH New Issue
2019-10-10 10:40 KB3NPH Status new => assigned
2019-10-10 10:40 KB3NPH Assigned To => K7ZCZ
2019-10-10 11:42 K7ZCZ Relationship added related to 0003482
2019-10-17 09:15 K7ZCZ Assigned To K7ZCZ => KB3NPH
2019-10-17 09:15 K7ZCZ Status assigned => feedback
2019-10-17 09:15 K7ZCZ Module => (select)
2019-10-17 09:15 K7ZCZ Sub-Module => (select)
2019-10-17 09:15 K7ZCZ Note Added: 0008840
2019-10-17 16:38 WA9PIE Description Updated View Revisions
2019-10-17 16:38 WA9PIE Steps to Reproduce Updated View Revisions
2019-10-17 16:38 WA9PIE Module (select) => Logbook
2019-10-17 16:38 WA9PIE Sub-Module (select) => Call lookup
2019-10-17 16:38 WA9PIE Testing => Not Started
2019-10-21 15:21 KB3NPH File Added: DX Cluster Lookup Not Populating Lookup Pane.jpg
2019-10-21 15:21 KB3NPH Note Added: 0008898
2019-10-22 10:19 WA9PIE File Added: Lookup.jpg
2019-10-22 10:19 WA9PIE Note Added: 0008903
2019-10-22 10:21 WA9PIE Assigned To KB3NPH => K7ZCZ
2019-10-22 10:21 WA9PIE Status feedback => assigned
2019-10-22 10:21 WA9PIE Additional Information Updated View Revisions
2019-10-22 10:24 PD9FER Note Added: 0008904
2019-10-28 19:48 WA9PIE File Added: Lookup237Release.png
2019-10-28 19:48 WA9PIE Note Added: 0009049
2019-10-28 19:53 WA9PIE File Added: OH4UI.png
2019-10-28 19:53 WA9PIE Note Added: 0009050
2019-10-30 18:32 K7ZCZ Status assigned => resolved
2019-10-30 18:32 K7ZCZ Resolution open => fixed
2019-10-30 18:32 K7ZCZ Note Added: 0009099
2019-10-30 18:37 K7ZCZ Relationship added related to 0003532
2019-10-30 18:37 K7ZCZ Relationship added related to 0003531
2019-10-30 18:37 K7ZCZ Relationship added related to 0003530
2019-10-30 18:37 K7ZCZ Relationship added related to 0003529
2019-10-30 19:03 K7ZCZ Relationship added related to 0003534
2019-10-30 19:03 K7ZCZ Relationship added related to 0003533
2019-11-02 00:04 WA9PIE Relationship added related to 0003538
2019-11-02 00:07 WA9PIE Status resolved => closed
2019-11-02 00:07 WA9PIE Fixed in Version => 6.7.0.240
2019-11-02 00:07 WA9PIE Testing Not Started => Beta Successful
2019-11-02 00:07 WA9PIE Note Added: 0009109
2019-11-08 02:09 WA9PIE Fixed in Version 6.7.0.240 => 6.7.0.244
2019-11-08 02:32 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2019-11-09 03:24 WA9PIE Relationship added related to 0003562
2019-11-11 05:38 WA9PIE Issue cloned: 0003574
2019-11-11 05:38 WA9PIE Relationship added related to 0003574