View Issue Details

IDProjectCategoryView StatusLast Update
0003486Ham Radio DeluxeBugpublic2019-11-08 02:32
ReporterKB3NPHAssigned ToK7ZCZ 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version6.7.0.244 
Summary0003486: In V6.7.0.232 Callsign Lookup Pane does not populate
DescriptionWhen clicking on a DX Cluster spot record to add the DX Call to the Lookup Pane, the Pane does not populate fully with all the information as it should. The "Callsign", "Country" and "IOTA" sections of the Lookup Panel do not expand and populate with the proper data from the lookup.

TagsNo tags attached.
ModuleLogbook
Sub-ModuleCall lookup
Testing N/A

Relationships

related to 0003187 closedWA9PIE Ham Radio Deluxe V6.5.0.187 to 6.5.0.190 has problems with the Callsign Lookup Pane in the Logbook. 
related to 0003482 new 1 - Backlog Improve timeout detection in call sign lookup operation completion 
related to 0003484 closedWA9PIE Ham Radio Deluxe Call sign lookup not working correctly or will freeze Logbook 

Activities

KB3NPH

2019-10-10 11:14

administrator   ~0008781

Last edited: 2019-10-10 11:30

View 3 revisions

Steps to replicate the issue.
1. Open Logbook
2. On the top menu, select "View" and select "Lookup" from the View dropdown menu
3. Open your DX Cluster and select the "WA9PIE-2" Node.
4. When the spots start populating the DX Cluster display, left click on any spot to add it to the "Lookup Pane"
5. Notice in the Lookup Pane that only the "Licensee" portion is expanded with data.
6. Notice in the Lookup Pane that the "Callsign", "Country", and "IOTA" portions are not expanded with data
7. Repeat step 4 with several spots and observe the "Licensee" data changes but no data in the other portions of the Lookup pane.

See the attached images. The bug is shown in "Lookup Pane Bug.jpg" and the correct way it should show is in image
"My Logbook] Proper Lookup Pane Display.png"

KB3NPH

2019-10-10 11:25

administrator  

Lookup Pane Bug.jpg (521,138 bytes)

KB3NPH

2019-10-10 11:26

administrator  

K7ZCZ

2019-10-25 04:08

developer   ~0009014

As far as I can tell, this is a duplicate of 3485.

Issue History

Date Modified Username Field Change
2019-10-10 10:48 KB3NPH New Issue
2019-10-10 10:48 KB3NPH Status new => assigned
2019-10-10 10:48 KB3NPH Assigned To => K7ZCZ
2019-10-10 10:57 KB3NPH Description Updated View Revisions
2019-10-10 11:14 KB3NPH Note Added: 0008781
2019-10-10 11:24 KB3NPH Note Edited: 0008781 View Revisions
2019-10-10 11:25 KB3NPH File Added: Lookup Pane Bug.jpg
2019-10-10 11:26 KB3NPH File Added: My Logbook] Proper Lookup Pane Display.png
2019-10-10 11:30 KB3NPH Note Edited: 0008781 View Revisions
2019-10-10 11:42 K7ZCZ Relationship added related to 0003482
2019-10-16 00:23 K7ZCZ Relationship added related to 0003187
2019-10-16 15:59 K7ZCZ Relationship added related to 0003484
2019-10-25 04:08 K7ZCZ Status assigned => resolved
2019-10-25 04:08 K7ZCZ Resolution open => duplicate
2019-10-25 04:08 K7ZCZ Note Added: 0009014
2019-11-04 03:31 WA9PIE Fixed in Version => 6.7.0.241
2019-11-04 03:31 WA9PIE Testing Not Started => N/A
2019-11-04 03:31 WA9PIE Status resolved => closed
2019-11-08 02:08 WA9PIE Fixed in Version 6.7.0.241 => 6.7.0.244
2019-11-08 02:32 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe