View Issue Details

IDProjectCategoryView StatusLast Update
0003494Ham Radio DeluxeBugpublic2019-11-08 02:32
ReporterWA9PIEAssigned ToWA9PIE 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.7.0.244 
Summary0003494: Complete the Callsign Lookup function for the HamQTH method
DescriptionSome fields or data are missing from the HamQTH callsign lookup method.

Once the HamQTH data is obtained for a given callsign, the following ALE fields should be populated from the data found as follows:
- COL_QSL_VIA should contain the data in the "qsl_via" tag in the response
- COL_QSL_AGE should contain the calculation of the current year minus the data in the "birth_year" tag in the response
- COL_QSO_IOTA should contain the data in the "iota" tag in the response
- COL_QSO_LAT should contain the data in the "latitude" tag in the response
- COL_QSO_LON should contain the data in the "longitude" tag in the response
- COL_QSO_STATE should contain the data in the "us_state" tag in the response
- COL_QSO_QTH should contain the data in the "qth" tag in the response
- COL_QSO_DXCC should contain the data in the "adif" tag in the response
- COL_COUNTRY should contain the Country name found in the Country List for the "adif" tag found in the response
- COL_CONT should contain the Continent name found in the Country List for the "adif" tag found in the response

None of these fields are being populated.

Additionally:
- The Country name found in the Country List for the "adif" tag found in the response should be added as the last line in COL_QSO_ADDRESS
- The data currently found in the COL_QSO_NAME field is repeated below the address in COL_QSO_ADDRESS and should be removed
Steps To ReproduceI repro this in the 6.7.0.232 beta build (6.7.0.234 can't be tested because it crashes 0003484).

- Open up Logbook
- Setup Callsign Lookup by Tools > Configure > Callsign Lookup and make sure that HamQTH is the only Enabled method listed above Country List in Enabled Methods
- Click "Ok"
- Open an ALE
- Enter the callsign "WA9PIE" (without the quotes)
- Press the "Lookup" button or hit tab

Result: These fields are populated in the respective fields in the ALE
Additional InformationThe correct result should be:

- COL_QSL_VIA should contain "WA9PIE"
- COL_QSL_AGE should contain "58"
- COL_QSO_IOTA should contain "NA-001"
- COL_QSO_LAT should contain "33.24"
- COL_QSO_LON should contain "-96.78"
- COL_QSO_STATE should contain "TX"
- COL_QSO_QTH should contain "Prosper"
- COL_QSO_DXCC should contain "291"
- COL_COUNTRY should contain "United States"
- COL_CONT should contain "NA"
- COL_QSO_ADDRESS should contain
"Michael G Carper, WA9PIE
Po Box 995
Prosper, TX 75078
United States"

None of these fields are being populated.

I'm attaching a copy of the field mapping spec and the XML document provided by HamQTH for WA9PIE
TagsNo tags attached.
ModuleLogbook
Sub-ModuleCall lookup
Testing Beta Successful

Activities

WA9PIE

2019-10-13 07:02

administrator  

CallsignLookupMapping32 (most_current)c.xlsx (25,768 bytes)
HamQTH (WA9PIE).xml (1,364 bytes)

K7ZCZ

2019-10-17 18:44

administrator   ~0008849

Last edited: 2019-10-17 18:45

View 2 revisions

This data source also returns CQ Zone, County, email, ITU Zone, and a Locator. These values aren't enumerated above; should they be discarded?

WA9PIE

2019-10-17 19:36

administrator   ~0008852

The purpose of this Mantis issue is to describe the fields that are NOT being populated. I did not clutter it with fields that ARE being populated. I would refer to the field mapping spec that the items highlighted red or yellow are the ones that need to be fixed. the ones that are not highlighted were tested and do work.

So yes... all those fields you mention should be used. But that said - they already work and should continue to work.

K7ZCZ

2019-10-17 21:52

administrator   ~0008856

Thanks for the clarification. In the future, you might consider writing something like "the correct results should also include" to indicate the augmentation of the existing results.

WA9PIE

2019-10-17 22:07

administrator   ~0008858

Point taken. I'll take that approach in the future. It just seemed like it would cause confusion by adding detail regarding things that actually do work.

K7ZCZ

2019-10-19 10:52

administrator   ~0008868

This checkin looks for state, oblast, and DOK in that order; adds a guess for age based on birth date, and adds IOTA ... plus the country list look-aside.
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5220

WA9PIE

2019-10-21 09:49

administrator   ~0008888

I checked this and was able to verify that everything is populating correctly with one caveat. I have not found any records in HamQTH that contain the IOTA data. I searched many known island stations and can't find one in HamQTH where IOTA is populated.

As a result, and because everything else is working as designed, I'm accepting this with that caveat.

WA9PIE

2019-10-21 09:50

administrator   ~0008889

Accepted with the noted IOTA caveat.

Issue History

Date Modified Username Field Change
2019-10-13 07:02 WA9PIE New Issue
2019-10-13 07:02 WA9PIE Status new => assigned
2019-10-13 07:02 WA9PIE Assigned To => K7ZCZ
2019-10-13 07:02 WA9PIE File Added: CallsignLookupMapping32 (most_current)c.xlsx
2019-10-13 07:02 WA9PIE File Added: HamQTH (WA9PIE).xml
2019-10-13 07:29 WA9PIE Description Updated View Revisions
2019-10-13 07:29 WA9PIE Steps to Reproduce Updated View Revisions
2019-10-13 07:29 WA9PIE Additional Information Updated View Revisions
2019-10-13 07:51 WA9PIE Steps to Reproduce Updated View Revisions
2019-10-13 09:05 WA9PIE Description Updated View Revisions
2019-10-17 18:44 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-10-17 18:44 K7ZCZ Status assigned => feedback
2019-10-17 18:44 K7ZCZ Note Added: 0008849
2019-10-17 18:45 K7ZCZ Note Edited: 0008849 View Revisions
2019-10-17 19:36 WA9PIE Note Added: 0008852
2019-10-17 19:36 WA9PIE Assigned To WA9PIE => K7ZCZ
2019-10-17 21:52 K7ZCZ Note Added: 0008856
2019-10-17 22:07 WA9PIE Note Added: 0008858
2019-10-17 22:07 WA9PIE Status feedback => assigned
2019-10-19 10:52 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-10-19 10:52 K7ZCZ Status assigned => resolved
2019-10-19 10:52 K7ZCZ Resolution open => fixed
2019-10-19 10:52 K7ZCZ Note Added: 0008868
2019-10-21 09:49 WA9PIE Note Added: 0008888
2019-10-21 09:50 WA9PIE Fixed in Version => 6.7.0.235
2019-10-21 09:50 WA9PIE Testing Not Started => Beta Successful
2019-10-21 09:50 WA9PIE Note Added: 0008889
2019-10-21 09:53 WA9PIE Status resolved => closed
2019-11-08 02:12 WA9PIE Fixed in Version 6.7.0.235 => 6.7.0.244
2019-11-08 02:32 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe