View Issue Details

IDProjectCategoryView StatusLast Update
0003496Ham Radio DeluxeBugpublic2019-11-08 02:32
ReporterWA9PIEAssigned ToWA9PIE 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.7.0.244 
Summary0003496: Complete the Callsign Lookup function for the QRZ.com Subscription method
DescriptionSome fields or data are missing from the QRZ.com Subscription callsign lookup method.

Once the QRZ.com Subscription data is obtained for a given callsign, the following ALE fields should be populated from the data found as follows:
- COL_QSL_VIA should contain the data in the "qslmgr" tag in the response
- COL_QSO_IOTA should contain the data in the "iota" tag in the response
- COL_QSO_DXCC should contain the data in the "dxcc" tag in the response
- COL_COUNTRY should contain the Country name found in the Country List for the "dxcc" tag found in the response
- COL_CONT should contain the Continent name found in the Country List for the "dxcc" tag found in the response
- COL_HRDCOUNTRYNO should contain the HRD Country number found in the Country List for the "dxcc" tag found in the response

None of these fields are being populated.
Steps To ReproduceI repro this in the 6.7.0.232 beta build (6.7.0.234 can't be tested because it crashes 0003484).

- Open up Logbook
- Setup Callsign Lookup by Tools > Configure > Callsign Lookup and make sure that QRZ.com Subscription is the only Enabled method listed above Country List in Enabled Methods
- Click "Ok"
- Open an ALE
- Enter the callsign "KH0A" (without the quotes)
- Press the "Lookup" button or hit tab

Result: These fields are populated in the respective fields in the ALE
Additional InformationThe correct result should be:

- COL_QSL_VIA should contain "JF1MIA" (without quotes)
- COL_QSO_IOTA should be empty (we need to test with a different callsign; I'll write a note about that in addition)
- COL_QSO_DXCC should contain "291" (without quotes)
- COL_COUNTRY should contain "United States" (without quotes)
- COL_CONT should contain "NA" (without quotes)
- COL_HRDCOUNTRYNO should contain "291" (without quotes)
TagsNo tags attached.
ModuleLogbook
Sub-ModuleCall lookup
Testing Beta Successful

Relationships

related to 0003464 closedWA9PIE Some fields missing from QRZ.com call sign lookup 
child of 0003001 closedWA9PIE Callsign lookup function does not appear to be working as designed 

Activities

WA9PIE

2019-10-13 07:45

administrator  

QRZ Subscription (KH0A).xml (1,259 bytes)

WA9PIE

2019-10-13 07:48

administrator   ~0008798

If we do the same test using KH2A as the callsign, then:

- COL_QSO_IOTA should contain "OC-026" (without quotes)

K7ZCZ

2019-10-16 15:57

administrator   ~0008833

Seems like this is mostly a duplicate of 3646. For me, the code behaves as described here.

WA9PIE

2019-10-21 10:19

administrator   ~0008891

I validated it.

Issue History

Date Modified Username Field Change
2019-10-13 07:45 WA9PIE New Issue
2019-10-13 07:45 WA9PIE Status new => assigned
2019-10-13 07:45 WA9PIE Assigned To => K7ZCZ
2019-10-13 07:45 WA9PIE File Added: QRZ Subscription (KH0A).xml
2019-10-13 07:46 WA9PIE Relationship added child of 0003001
2019-10-13 07:46 WA9PIE Relationship added related to 0003464
2019-10-13 07:48 WA9PIE Note Added: 0008798
2019-10-13 07:52 WA9PIE Description Updated View Revisions
2019-10-13 07:52 WA9PIE Steps to Reproduce Updated View Revisions
2019-10-13 07:52 WA9PIE Additional Information Updated View Revisions
2019-10-13 09:03 WA9PIE Issue cloned: 0003498
2019-10-13 09:06 WA9PIE Description Updated View Revisions
2019-10-16 15:57 K7ZCZ Note Added: 0008833
2019-10-16 15:57 K7ZCZ Status assigned => resolved
2019-10-16 15:57 K7ZCZ Resolution open => fixed
2019-10-21 10:19 WA9PIE Assigned To K7ZCZ => WA9PIE
2019-10-21 10:19 WA9PIE Status resolved => closed
2019-10-21 10:19 WA9PIE Fixed in Version => 6.7.0.235
2019-10-21 10:19 WA9PIE Testing Not Started => Beta Successful
2019-10-21 10:19 WA9PIE Note Added: 0008891
2019-11-08 02:12 WA9PIE Fixed in Version 6.7.0.235 => 6.7.0.244
2019-11-08 02:32 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe