View Issue Details

IDProjectCategoryView StatusLast Update
0003497Ham Radio DeluxeBugpublic2019-11-08 02:32
ReporterWA9PIEAssigned ToWA9PIE 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.7.0.244 
Summary0003497: Complete the Callsign Lookup function for the Logbook method
DescriptionSome fields or data are missing from the Logbook callsign lookup method.

Once the Logbook data is obtained for a given callsign, the following ALE fields should be populated from the data found as follows:
- FLD_QSL_VIA should contain the data from the following field in the previous QSO; FLD_QSL_VIA
- FLD_QSO_ADDRESS should contain the data from the following field in the previous QSO; FLD_QSO_ADDRESS
- FLD_QSO_AGE should contain the data from the following field in the previous QSO; FLD_QSO_AGE
- FLD_QSO_ARRL_SECT should contain the data from the following field in the previous QSO; FLD_QSO_ARRL_SECT
- FLD_QSO_BIOGRAPHY should contain the data from the following field in the previous QSO; FLD_QSO_BIOGRAPHY
- FLD_QSO_CONT should contain the data from the following field in the previous QSO; FLD_QSO_CONT
- FLD_QSO_COUNTRY should contain the data from the following field in the previous QSO; FLD_QSO_COUNTRY
- FLD_QSO_COUNTY should contain the data from the following field in the previous QSO; FLD_QSO_COUNTY
- FLD_QSO_CQZ should contain the data from the following field in the previous QSO; FLD_QSO_CQZ
- FLD_QSO_DISTANCE should be calculated
- FLD_QSO_EMAIL should contain the data from the following field in the previous QSO; FLD_QSO_EMAIL
- FLD_QSO_GRIDSQUARE should contain the data from the following field in the previous QSO; FLD_QSO_GRIDSQUARE
- FLD_QSO_HRDCOUNTRYNO should contain the data from the following field in the previous QSO; FLD_QSO_HRDCOUNTRYNO
- FLD_QSO_IOTA should contain the data from the following field in the previous QSO; FLD_QSO_IOTA
- FLD_QSO_IOTA_ISLAND should contain the data from the following field in the previous QSO; FLD_QSO_IOTA_ISLAND
- FLD_QSO_ITUZ should contain the data from the following field in the previous QSO; FLD_QSO_ITUZ
- FLD_QSO_LAT should contain the data from the following field in the previous QSO; FLD_QSO_LAT
- FLD_QSO_LON should contain the data from the following field in the previous QSO; FLD_QSO_LON
- FLD_QSO_NAME should contain the data from the following field in the previous QSO; FLD_QSO_NAME
- FLD_QSO_QTH should contain the data from the following field in the previous QSO; FLD_QSO_QTH
- FLD_QSO_SIG should contain the data from the following field in the previous QSO; FLD_QSO_SIG
- FLD_QSO_SIG_INFO should contain the data from the following field in the previous QSO; FLD_QSO_SIG_INFO
- FLD_QSO_STATE should contain the data from the following field in the previous QSO; FLD_QSO_STATE
- FLD_QSO_TEN_TEN should contain the data from the following field in the previous QSO; FLD_QSO_TEN_TEN
- FLD_QSO_WEB should contain the data from the following field in the previous QSO; FLD_QSO_WEB
- FLD_QSO_DXCC should contain the data from the following field in the previous QSO; FLD_QSO_DXCC
- FLD_RIG should contain the data from the following field in the previous QSO; FLD_RIG

None of these fields are being populated.
Steps To ReproduceI repro this in the 6.7.0.232 beta build (6.7.0.234 can't be tested because it crashes 0003484)

- Open up Logbook
- Import the QSO attached to this Mantis issue
- Setup Callsign Lookup by Tools > Configure > Callsign Lookup and make sure that Logbook is the only Enabled method listed above Country List in Enabled Methods
- Click "Ok"
- Open an ALE
- Enter the callsign "AA5PK" (without the quotes)
- Press the "Lookup" button or hit tab

Result: These fields are populated in the respective fields in the ALE
Additional InformationThe correct result should be:

FLD_QSL_VIA should contain "LoTW preferred. In eQSL use Prop Mode = Satellite for sat QSOs" (without quotes)
FLD_QSO_ADDRESS should contain "" (without quotes)
FLD_QSO_AGE should contain "58" (without quotes)
FLD_QSO_ARRL_SECT should contain "NTX" (without quotes)
FLD_QSO_BIOGRAPHY should contain "http://xmldata.qrz.com/xml?s=dbcf8cd33e4c9b06d05154881268df42&html=AA5PK" (without quotes)
FLD_QSO_CONT should contain "NA" (without quotes)
FLD_QSO_COUNTRY should contain "United States" (without quotes)
FLD_QSO_COUNTY should contain "Tom Green" (without quotes)
FLD_QSO_CQZ should contain "4" (without quotes)
FLD_QSO_DISTANCE should be calculated
FLD_QSO_EMAIL should contain "aa5pk@hotmail.com" (without quotes)
FLD_QSO_GRIDSQUARE should contain "DM91sk" (without quotes)
FLD_QSO_HRDCOUNTRYNO should contain "291" (without quotes)
FLD_QSO_IOTA should contain "AF-001" (without quotes)
FLD_QSO_IOTA_ISLAND should contain "North" (without quotes)
FLD_QSO_ITUZ should contain "7" (without quotes)
FLD_QSO_LAT should contain "31.4276030000" (without quotes)
FLD_QSO_LON should contain "-100.4837660000" (without quotes)
FLD_QSO_NAME should contain "GLENN A MILLER" (without quotes)
FLD_QSO_QTH should contain "San Angelo" (without quotes)
FLD_QSO_SIG should contain "Carper Ham Club" (without quotes)
FLD_QSO_SIG_INFO should contain "www.carper.com" (without quotes)
FLD_QSO_STATE should contain "TX" (without quotes)
FLD_QSO_TEN_TEN should contain "5000" (without quotes)
FLD_QSO_WEB should contain "www.google.com" (without quotes)
FLD_QSO_DXCC should contain "291" (without quotes)
FLD_RIG should contain "Fantastic stuff" (without quotes)
TagsNo tags attached.
ModuleLogbook
Sub-ModuleCall lookup
Testing Beta Successful

Relationships

related to 0003464 closedWA9PIE Some fields missing from QRZ.com call sign lookup 
related to 0003502 closedK7ZCZ call sign lookup in ALE doesn't fill all field types correctly 
child of 0003001 closedWA9PIE Callsign lookup function does not appear to be working as designed 

Activities

WA9PIE

2019-10-13 08:29

administrator  

AA5PK.ADI (2,119 bytes)

K7ZCZ

2019-10-18 08:05

administrator   ~0008862

It seems like this repro case should cause the call sign lookup code to get data from the most recent AA5PK. (I guess -- I don't see any advice about which logbook record should be retrieved. Maybe closest to the entered QSO date? Maybe the most recent absolutely? Maybe something else?)

When imported, the ADI file's record doesn't contain information in its "Biography" field. Looks like the ADI file does have data there, but the logbook doesn't import it. Is this a separate issue in the import implementation?

The imported record does have an address, but this issue says that the address in the look up result should be "" (without the quotes). Is the logbook data source meant to force the address to be an empty string on a matched record?

The imported record ends up showing "Agalega Islands -" for the IOTA island name. The ADI file does contain "North", but it seems like the import doesn't work. (In the Logbook database view, the IOTA Island is blank. In the ALE, "Agalega Islands -" is selected in the dropdown). Maybe this is a separate issue with import, or even the ALE itself, but doesn't seem related to the callsign lookup implementation.

WA9PIE

2019-10-18 09:07

administrator   ~0008863

I think it was always intended that it should be looking into the active logbook. At this point, to keep things simple... let's go with that (good question).

Yes (agreed), I think there are problems with the import that are separate from this issue for sure. I can repro this after the build though... with the existing record I have in the log.

(both import problems, that is)

K7ZCZ

2019-10-19 10:21

administrator   ~0008866

I think you've misread my question.

I'm wondering which record from the active logbook should be returned, not which logbook database should be used. Since a given call can appear in a logbook database any number of times, it's not clear which data for that call should be considered a match for the purposes of the call sign lookup operation. In fact, maybe more than one entry is considered, accumulating some fields as it goes based on some heuristic.

Please open Mantis issues for the import issues so they can be fixed.

I guess there's not much more that can be done for this issue, so I've made this check in with the added fields I have so far.
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5218

WA9PIE

2019-10-19 17:26

administrator   ~0008871

The intention was to use the most recent record. The thinking there is... as long as the user gets the most recent one correct, they won't have to worry about data that is more likely to be stale.

WA9PIE

2019-10-21 10:24

administrator   ~0008892

I validated this myself. This is a big win. This one never really worked correctly before.

Issue History

Date Modified Username Field Change
2019-10-13 08:29 WA9PIE New Issue
2019-10-13 08:29 WA9PIE Status new => assigned
2019-10-13 08:29 WA9PIE Assigned To => K7ZCZ
2019-10-13 08:29 WA9PIE File Added: AA5PK.ADI
2019-10-13 08:30 WA9PIE Relationship added child of 0003001
2019-10-13 08:30 WA9PIE Relationship added related to 0003464
2019-10-13 09:05 WA9PIE Description Updated View Revisions
2019-10-13 09:05 WA9PIE Steps to Reproduce Updated View Revisions
2019-10-13 09:05 WA9PIE Additional Information Updated View Revisions
2019-10-18 08:05 K7ZCZ Note Added: 0008862
2019-10-18 08:06 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-10-18 08:06 K7ZCZ Status assigned => feedback
2019-10-18 09:07 WA9PIE Note Added: 0008863
2019-10-18 09:08 WA9PIE Assigned To WA9PIE => K7ZCZ
2019-10-19 09:58 K7ZCZ Relationship added related to 0003502
2019-10-19 10:21 K7ZCZ Note Added: 0008866
2019-10-19 10:21 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-10-19 17:26 WA9PIE Note Added: 0008871
2019-10-19 17:26 WA9PIE Assigned To WA9PIE => K7ZCZ
2019-10-21 10:24 WA9PIE Assigned To K7ZCZ => WA9PIE
2019-10-21 10:24 WA9PIE Status feedback => closed
2019-10-21 10:24 WA9PIE Fixed in Version => 6.7.0.235
2019-10-21 10:24 WA9PIE Testing Not Started => Beta Successful
2019-10-21 10:24 WA9PIE Note Added: 0008892
2019-10-21 10:25 WA9PIE Resolution open => fixed
2019-11-08 02:12 WA9PIE Fixed in Version 6.7.0.235 => 6.7.0.244
2019-11-08 02:32 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe