View Issue Details

IDProjectCategoryView StatusLast Update
0003498Ham Radio DeluxeBugpublic2019-11-08 02:32
ReporterWA9PIEAssigned ToWA9PIE 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.7.0.244 
Summary0003498: Complete the Callsign Lookup function for the UCSDB (Public) method
DescriptionSome fields or data are missing from the UCSDB (Public) callsign lookup method.

Once the UCSDB (Public) data is obtained for a given callsign, the following ALE fields should be populated from the data found as follows:
- COL_QSL_VIA should contain the data in the "QSL Manager" tag in the UCSDB (Public)
- COL_QSO_IOTA should contain the data in the "IOTA" tag in the UCSDB (Public)
- COL_QSO_DXCC should contain the data in the "DXCC" tag in the UCSDB (Public)
- COL_COUNTRY should contain the data in the "Country" tag in the UCSDB (Public)
- COL_CONT should contain the Continent name found in the Country List for the "DXCC" tag found in the response
- COL_HRDCOUNTRYNO should contain the HRD Country number found in the Country List for the "DXCC" tag found in the response

None of these fields are being populated.

I probably missed these last two items in the field mapping spec
Steps To ReproduceI repro this in the 6.7.0.232 beta build (6.7.0.234 can't be tested because it crashes 0003484).

- Open up Logbook
- Setup Callsign Lookup by Tools > Configure > Callsign Lookup and make sure that Country List is the only Enabled method
- Click "Ok"
- Open an ALE
- Enter the callsign "3C0E" (without the quotes)
- Press the "Lookup" button or hit tab

Result: These fields are populated in the respective fields in the ALE
Additional InformationThe correct result should be:

- COL_QSL_VIA should contain "EA5BYP LOTW--->Yes Eqsl--->No" (without Quotes)
- COL_QSO_IOTA should contain "AF-039" (without Quotes)
- COL_QSO_DXCC should contain "195" (without Quotes)
- COL_COUNTRY should contain "Annobon Is." (without Quotes)
- COL_CONT should contain "AF" (without Quotes)
- COL_HRDCOUNTRYNO should contain "195" (without Quotes)
TagsNo tags attached.
ModuleLogbook
Sub-ModuleCall lookup
Testing Beta Successful

Relationships

related to 0003464 closedWA9PIE Some fields missing from QRZ.com call sign lookup 
child of 0003001 closedWA9PIE Callsign lookup function does not appear to be working as designed 

Activities

K7ZCZ

2019-10-15 09:39

administrator   ~0008822

I have some concerns with the repro steps offered here.

It's not possible to make the "UCSDB (Public)" source the only configured source. The private UCSDB and Country List are always enabled and can't be turned off. Is this another area where I've misunderstood the specification?

The instructions suggest using the ALE to add a QSO for 3C0E, then expect certain results. As written, the instructions would give that QSO the current date -- the date test was performed would be entered in the ALE's "(F2) Start" field by default. In the public UCSDB that I have, the 3C0E record has effective dates from 2012-02-15 to 2012-03-16. Are the effective dates meant to be ignored when looking up in the UCSDB? What about the "Active" check mark in the UCSDB?

WA9PIE

2019-10-15 16:18

administrator   ~0008823

Given the steps above, the effective lookup order is the following:
- UCSDB (Public); this is the data in the "UniqueCalls001" section of LogbookCountryDataEx.xml (always 1st)
- UCSDB (Private); it looks like this is in the "UniqueCalls001" section of LogbookCountryDataExPrivate.xml (always 2nd)
- Country List; this is the data in the "Countries001" and "NonDXCCCountries001" section of LogbookCountryDataEx.xml (always last)

All these options above need to be locked in to these positions (1st, 2nd, and last, respectively). I don't think they should be inside the list of "Enabled Methods" at all. But was waiting until we fix the lookup to raise this point (and I'll do so in another Mantis issue). That said...

With the above in mind, the repro steps are accurate.

It's good that you raised the point about the date range and the check-mark. I've never been able to verify whether they work or what the desired behavior is. So let's do the following:
- if the record is "Active"... then the unique call can be considered in the lookup, when...
- the date range of the QSO fits the date range inside the unique call's 'properties'

K7ZCZ

2019-10-16 08:56

administrator   ~0008830

The repro steps here should describe the enabled sources as well as the date range. The spec should be amended with the newly discovered decisions.

With the completed specification about the date range and entry activation behaviour, this checkin should resolve this issue:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5212

WA9PIE

2019-10-21 10:31

administrator   ~0008893

With the same repro steps, the following fields are not being populated:

- COL_QSL_VIA should contain "EA5BYP LOTW--->Yes Eqsl--->No" (without Quotes)
- COL_QSO_IOTA should contain "AF-039" (without Quotes)

K7ZCZ

2019-10-21 14:47

administrator   ~0008897

Sorry, I thought you said this source was meant to consider the date range. The repro steps here don't give any date range, so I'm assuming the lookup is done with a current date -- for us right now, 2019-10-21 or so. 2019-10-21 is outside of the effective date range for 3C0E in the public call sign lookup list I have; there, I see 2012-02-15 to 2012-03-15 as the active dates.

If I follow these steps:

- Open up Logbook
- Setup Callsign Lookup by Tools > Configure > Callsign Lookup and make sure that Country List is the only Enabled method

(Which can't be done -- I'm using "Public UCSDB", "Private UCSDB", and "Country List" in that order)

- Click "Ok"
- Open an ALE
- Enter the callsign "3C0E" (without the quotes)
- Press the "Lookup" button or hit tab

The only fields in the result are COL_COUNTRY (Annobon Is.), COL_CONT (AF), COL_DXCC (195), and COL_HRDCN (195), which all come from the country list. The UCSDB generates no results at all since the QSO date in the ALE is outside the active range of the UCSDB record.

If I use these reviesed steps:

1) Open up Logbook. No particular database; a blank DB is probably best
2) Setup Callsign Lookup by Tools > Configure > Callsign Lookup and make sure that "Public UCSDB", "Private UCSDB", and "Country List" in that order; and that no other items appear
3) Click "Ok" to dismiss the "Callsign Lookup" dialog
4) Open an ALE to add using the "+" button in the toolbar
5) In the "(F2) Start:" field, enter the date "2012-02-22", though you might need a different format depending on local settings.
6) Enter the callsign "3C0E" (without the quotes)
7) Press the "Lookup" button

I find that:


  • "Via" on the "QSL" tab has "EA5BYP LOTW--->Yes Eqsl--->No"

  • "IOTA" in the main area of the ALE window has "AF-039"

  • "Continent" in the "Location" tab has "AF"

  • "Country" on the main area of the ALE window has "Annobon Is."

  • "IOTA" on the "IOTA" tab has "AF-039"



Am I misunderstanding your previous answer about "the date range of the QSO fits the date range inside the unique call's 'properties'"?

WA9PIE

2019-10-21 17:35

administrator   ~0008901

No Mike... you're completely correct. I just missed this as a testing scenario.

I've now created a UCSDB entry for VP6R that is active, has a valid date range that is current, IOTA, and QSL Manager info.

With these things set, it works perfectly.

I'm going to moved this to Closed, Fixed, FiV=6.7.0.235.

WA9PIE

2019-10-21 17:36

administrator   ~0008902

I validated this one.

Issue History

Date Modified Username Field Change
2019-10-13 09:03 WA9PIE New Issue
2019-10-13 09:03 WA9PIE Status new => assigned
2019-10-13 09:03 WA9PIE Assigned To => K7ZCZ
2019-10-13 09:03 WA9PIE Issue generated from: 0003496
2019-10-13 09:03 WA9PIE Relationship added child of 0003001
2019-10-13 09:03 WA9PIE Relationship added related to 0003464
2019-10-13 09:15 WA9PIE Issue cloned: 0003499
2019-10-15 09:39 K7ZCZ Note Added: 0008822
2019-10-15 09:39 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-10-15 09:39 K7ZCZ Status assigned => feedback
2019-10-15 16:18 WA9PIE Note Added: 0008823
2019-10-15 16:19 WA9PIE Assigned To WA9PIE => K7ZCZ
2019-10-16 08:56 K7ZCZ Status feedback => resolved
2019-10-16 08:56 K7ZCZ Resolution open => fixed
2019-10-16 08:56 K7ZCZ Note Added: 0008830
2019-10-21 10:31 WA9PIE Note Added: 0008893
2019-10-21 10:31 WA9PIE Status resolved => assigned
2019-10-21 14:47 K7ZCZ Note Added: 0008897
2019-10-21 14:47 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-10-21 14:47 K7ZCZ Status assigned => feedback
2019-10-21 17:35 WA9PIE Note Added: 0008901
2019-10-21 17:36 WA9PIE Status feedback => closed
2019-10-21 17:36 WA9PIE Fixed in Version => 6.7.0.235
2019-10-21 17:36 WA9PIE Testing Not Started => Beta Successful
2019-10-21 17:36 WA9PIE Note Added: 0008902
2019-11-08 02:12 WA9PIE Fixed in Version 6.7.0.235 => 6.7.0.244
2019-11-08 02:32 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe