View Issue Details

IDProjectCategoryView StatusLast Update
0003502Ham Radio DeluxeBugpublic2019-11-08 02:32
ReporterK7ZCZAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.7.0.244 
Summary0003502: call sign lookup in ALE doesn't fill all field types correctly
DescriptionThe new call sign lookup code standardizes on a representation for its results (in contrast to the previous implementation, which picked apart individual data types for each of the data sources). The new code presently only sets data to text controls; it won't correctly find (or add?) and select text strings in combo boxes ... or any other non-text control, really.

Steps To Reproduce1) Start up the Logbook. Empty database is probably best, but no real requirements.
2) Use the "Callsign Lookup" menu in the "Settings" tear off of the "Tools" menu
3) In the resulting "Callsign Lookup" dialog, remove all lookup sources except QRZ.com
4) Use the "QRZ" tab to make sure QRZ is correctly configured with your account
5) Press "OK" to save these settings
6) Invoke the ALE to add an entry
7) Enter "K7ZCZ"
8) Press the "Lookup" push button

When results appear, the "Name" and "Address" fields are correctly populated

BUG#1) The "Country" drop-down on the main part of the ALE window is not set;
neither is the "County" drop-down on the Location tab
TagsNo tags attached.
ModuleLogbook
Sub-ModuleALE Window
Testing Beta Successful

Relationships

related to 0003492 closedWA9PIE Complete the Callsign Lookup function for the Country List method 
related to 0003497 closedWA9PIE Complete the Callsign Lookup function for the Logbook method 

Activities

K7ZCZ

2019-10-15 09:05

administrator   ~0008819

fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5208

K7ZCZ

2019-10-16 08:50

administrator   ~0008829

one more field fixed here:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5211

K7ZCZ

2019-10-19 09:49

administrator   ~0008864

Issue 3497 reveals that FLD_QSO_RIG will come back from call sign lookup operations. Because FLD_QSO_RIG is not mentioned in the spreadsheet part of the specification (the file CallsignLookupMapping32 (most_current)c.xlsx for now), this is a surprise.

This checkin is made to compensate, and adds mapping and handling for FLD_QSO_RIG:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5217

WA9PIE

2019-10-23 04:16

administrator   ~0008937

Yes, we've found a number of surprises as we work through this. I'll update the field mapping spreadsheet and we'll have a correct one as of the time we complete this.

g3ucq

2019-10-23 04:39

viewer   ~0008950

I do not see the address populated.

WA9PIE

2019-10-23 07:37

administrator   ~0008962

Again, it depends upon which callsign lookup method you use.

When the rest of the lookup methods are working correctly, I'm going to record a video describing the behavior of this and add some documentation in the wiki.

g3ucq

2019-10-23 08:09

viewer   ~0008971

Data under the ALE/Logbook tab is not populated from previous QSOs with Logbook selected for Lookup

k2ie

2019-10-23 11:12

viewer   ~0008980

All data now appears to be correctly populated using qrz.com.

k2ie

2019-10-23 11:15

viewer   ~0008982

Should the name be duplicated in the address field of the Location tab?

WA9PIE

2019-10-23 21:29

administrator   ~0008991

K2IE; No. The name should not be duplicating in the address field of the location tab. Which lookup method are you using?

k2ie

2019-10-23 22:23

viewer   ~0008999

I am using qrz.com. I took a look at some older loggings from 2011 and they also have the name in the address field. So it has been putting the name in the address field for some time.

WA9PIE

2019-10-25 17:00

administrator   ~0009020

To clarify...

The address field should be in the following format:

name, callsign
address
city, state zip
country

This is the field used for mailing labels... so we do need the name in there.

What was happening (and what I thought you were referring to) is that the name was being repeated below country (for some lookup sources). We needed to fix that.

WA9PIE

2019-10-29 03:35

administrator   ~0009057

Validated

Issue History

Date Modified Username Field Change
2019-10-14 18:07 K7ZCZ New Issue
2019-10-14 18:08 K7ZCZ Relationship added related to 0003492
2019-10-15 09:05 K7ZCZ Assigned To => K7ZCZ
2019-10-15 09:05 K7ZCZ Status new => resolved
2019-10-15 09:05 K7ZCZ Resolution open => fixed
2019-10-15 09:05 K7ZCZ Note Added: 0008819
2019-10-16 08:50 K7ZCZ Note Added: 0008829
2019-10-19 09:49 K7ZCZ Note Added: 0008864
2019-10-19 09:58 K7ZCZ Relationship added related to 0003497
2019-10-21 17:01 K7ZCZ Fixed in Version => 6.7.0.235
2019-10-23 04:16 WA9PIE Note Added: 0008937
2019-10-23 04:39 g3ucq Note Added: 0008950
2019-10-23 07:37 WA9PIE Note Added: 0008962
2019-10-23 08:09 g3ucq Note Added: 0008971
2019-10-23 11:12 k2ie Note Added: 0008980
2019-10-23 11:15 k2ie Note Added: 0008982
2019-10-23 21:29 WA9PIE Note Added: 0008991
2019-10-23 22:23 k2ie Note Added: 0008999
2019-10-25 17:00 WA9PIE Note Added: 0009020
2019-10-29 03:35 WA9PIE Status resolved => closed
2019-10-29 03:35 WA9PIE Fixed in Version 6.7.0.235 => 6.7.0.239
2019-10-29 03:35 WA9PIE Description Updated View Revisions
2019-10-29 03:35 WA9PIE Steps to Reproduce Updated View Revisions
2019-10-29 03:35 WA9PIE Testing Not Started => Beta Successful
2019-10-29 03:35 WA9PIE Note Added: 0009057
2019-11-08 02:10 WA9PIE Fixed in Version 6.7.0.239 => 6.7.0.244
2019-11-08 02:32 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe