View Issue Details

IDProjectCategoryView StatusLast Update
0003510Ham Radio DeluxeBugpublic2019-11-08 02:32
ReporterWA9PIEAssigned ToK7ZCZ 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.7.0.244 
Summary0003510: Some HamCall.net fields are not being populated
DescriptionWhen the HamCall.net callsign lookup method is enabled, some fields that are returned from the query to HamCall.net are not being populated into the ALE as follows:

- COL_ADDRESS is missing Country at the bottom of the address. It should be populated with:
Michael G Carper, WA9PIE
Po Box 995
Prosper, TX 75078
United States

- COL_QSL_VIA is missing QSL manager from field 208. It should be populated with "Direct, LOTW" without quotes.

- COL_QSO_AGE is missing the calculation of age. It should be populated with "58" without quotes, based on the caculation of current year minus the contents of field 194.

- COL_QSO_EMAIL is missing the data from field 207. It should be populated with "mike@wa9pie.net" without quotes.

- COL_QSO_IOTA is missing the data from field 218. It should be populated with "NA-001" without the quotes.

- COL_LON is missing the data from field 201. It should be "-96.79" without the quotes. There is a number in the upper ALE, but there is no data in the "Lon" field in the "Location" tabe of the ALE. The data in the upper ALE seems to be coming from the Country List insteat of being populated.

- COL_QSO_QTH is missing the data from field 191. It should be populated with "Prosper" without quotes.

Further investigation of the data in field 251 (CQZ) and 252 (ITUZ) have rendered is unusable because the data contains more than one numeric value. (It contains all the zone values for a given country. Thus, we can't use it.) I'm changing the fiel mapping spec accordingly.
Steps To ReproduceI repro this in the 6.7.0.235 beta build.

- Open up Logbook
- Setup Callsign Lookup by Tools > Configure > Callsign Lookup and make sure that HamCall.net is the only Enabled method listed above Country List in Enabled Methods
- Click "Ok"
- Open an ALE
- Enter the callsign "WA9PIE" (without the quotes)
- Press the "Lookup" button or hit tab

Result: These fields are populated in the respective fields in the ALE
Additional InformationThis one was difficult for me to collect data on because the format of the data returned from HamCall.net is not similar to the XML format used by other systems. So I did the best I could with this one.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleCall lookup
Testing Beta Successful

Relationships

related to 0003545 closedK7ZCZ HamCall.net, the Callsign Lookup does not correctly assign DXCC, Country, Continent, and HRDCountry 
child of 0003001 closedWA9PIE Callsign lookup function does not appear to be working as designed 

Activities

K7ZCZ

2019-10-25 09:32

administrator   ~0009016

It's not clear to me what you want done with the CQZ and ITUZ fields. How do I get a copy of the revised spec so I can see the changes you've made?

WA9PIE

2019-10-25 10:01

administrator   ~0009017

For the HamCall.net method, we cannot use the data for CQZ (251) and ITUZ (252) because the data in that field contains more than one zone. As such, it's not specific. Because it's not specific, it's invalid by nature.

So for the HamCall.net method, leave the CQZ and ITUZ empty and ignore the data in fields 251 and 252 respectively.

I'm attaching a tracking copy of the spec. You can ignore the highlighting in this file. I'm using it to give me a place to come back and test. I'm trying to update this as we learn new things so that - when we're done - we'll have an "as-built" copy of the field mapping spec.

CallsignLookupMapping4x.xlsx (25,809 bytes)

K7ZCZ

2019-10-26 09:39

administrator   ~0009021

The spreadsheet specification says to use field #209 for the country name in the mailing list. On the WA9PIE record I get back, that field is blank, so this is behaving per the spec.

The other fields are fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5234

WA9PIE

2019-10-26 20:02

administrator   ~0009026

Thanks. I'll do some testing of other calls. I think I need to tweak this part of the spec, because we get Country from the cross-reference to the Country List and that's where the country should come from, not field 209 (and that's my bad).

WA9PIE

2019-10-29 03:33

administrator   ~0009056

I'm going to close this.

There is one minor problem where the country is not added below the address. This is due to a mistake that I made in the field mapping spec. We'll deal with it later through another Mantis issue. (It is not serious)

This is otherwise done.

Validated.

Issue History

Date Modified Username Field Change
2019-10-22 18:52 WA9PIE New Issue
2019-10-22 18:52 WA9PIE Status new => assigned
2019-10-22 18:52 WA9PIE Assigned To => K7ZCZ
2019-10-22 19:03 WA9PIE Relationship added child of 0003001
2019-10-25 09:32 K7ZCZ Note Added: 0009016
2019-10-25 09:32 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-10-25 09:32 K7ZCZ Status assigned => feedback
2019-10-25 10:01 WA9PIE File Added: CallsignLookupMapping4x.xlsx
2019-10-25 10:01 WA9PIE Note Added: 0009017
2019-10-25 10:02 WA9PIE Assigned To WA9PIE => K7ZCZ
2019-10-26 09:39 K7ZCZ Note Added: 0009021
2019-10-26 10:09 K7ZCZ Status feedback => resolved
2019-10-26 10:09 K7ZCZ Resolution open => fixed
2019-10-26 20:02 WA9PIE Note Added: 0009026
2019-10-29 03:33 WA9PIE Status resolved => closed
2019-10-29 03:33 WA9PIE Fixed in Version => 6.7.0.239
2019-10-29 03:33 WA9PIE Testing Not Started => Beta Successful
2019-10-29 03:33 WA9PIE Note Added: 0009056
2019-11-04 21:57 K7ZCZ Relationship added related to 0003545
2019-11-08 02:10 WA9PIE Fixed in Version 6.7.0.239 => 6.7.0.244
2019-11-08 02:32 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe