View Issue Details

IDProjectCategoryView StatusLast Update
00035123 - Current Dev ListGeneralpublic2019-11-08 02:22
ReporterWA9PIEAssigned ToWA9PIE 
PrioritynormalSeveritymajorReproducibilityalways
Status assignedResolutionreopened 
Product Version 
Target VersionFixed in Version 
Summary0003512: Redesign of the Callsign Lookup's Enable tab UI
DescriptionIn the 6.7.0.235 beta build, the Callsign Lookup dialog box contains a list of things that are meant to be re-ordered with things that are not meant to be re-ordered (meanwhile, I was able to move things that were not meant to be moved). I think this will confuse customers.

The purpose of this change request is to suggest a change in the UI that is intended to provide better clarity for the users about how the dialog box and feature works.
Steps To Reproduce- Launch Logbook
- Go to Tools, Configure, Callsign Lookup... Enable tab
- Observe how this could be confusing (those things that aren't meant to be reordered are among things that are meant to be reordered)
TagsNo tags attached.
ModuleLogbook
Sub-ModuleCall lookup
TestingNot Started

Relationships

related to 0003514 closedK7ZCZ Ham Radio Deluxe Only "Enabled Methods" should be allowed to reorder; UCSDB (Public and Private) and Country List should not 
child of 0003511 assignedWA9PIE 3 - Current Dev List Callsign Lookup dialog box has confusing UI 

Activities

WA9PIE

2019-10-23 00:34

administrator  

K7ZCZ

2019-10-28 12:19

administrator   ~0009037

I don't think we have any evidence that this is confusing to our customers; we also haven't yet had a build where the implementation has been completely bug-free. It is thus hasty to discard hours of work until we have some concrete feedback from customers who've had a chance to use the completed implementation. If we find evidence that there are misunderstandings caused by the UI, I think we can come up with changes or enhancements to the existing design based on that feedback before we entertain a redesign.

With this reasoning, I'm resolving this as won't fix.

WA9PIE

2019-11-08 02:22

administrator   ~0009206

Reopened for further/future conversation.

Issue History

Date Modified Username Field Change
2019-10-23 00:34 WA9PIE New Issue
2019-10-23 00:34 WA9PIE Status new => assigned
2019-10-23 00:34 WA9PIE Assigned To => K7ZCZ
2019-10-23 00:34 WA9PIE File Added: CallsignLookupEnabledMethods.png
2019-10-23 00:34 WA9PIE Issue generated from: 0003511
2019-10-23 00:34 WA9PIE Relationship added child of 0003511
2019-10-23 00:47 WA9PIE Relationship added related to 0003514
2019-10-28 12:19 K7ZCZ Status assigned => resolved
2019-10-28 12:19 K7ZCZ Resolution open => won't fix
2019-10-28 12:19 K7ZCZ Note Added: 0009037
2019-11-08 02:22 WA9PIE Assigned To K7ZCZ => WA9PIE
2019-11-08 02:22 WA9PIE Status resolved => assigned
2019-11-08 02:22 WA9PIE Resolution won't fix => reopened
2019-11-08 02:22 WA9PIE Description Updated View Revisions
2019-11-08 02:22 WA9PIE Steps to Reproduce Updated View Revisions
2019-11-08 02:22 WA9PIE Note Added: 0009206