View Issue Details

IDProjectCategoryView StatusLast Update
0003520Ham Radio DeluxeBugpublic2019-11-08 02:32
ReporterK7ZCZAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version6.7.0.227 
Target VersionFixed in Version6.7.0.244 
Summary0003520: Setup installs wrong version of HRDRemoteSvr.EXE
DescriptionThe setup application installs the wrong build of the HRDRemoteSvr.EXE file.
Steps To Reproduce
While the file is not stamped with a version number (see related issue), the application an be identified by its file size and date stamp. The installed HRDRemoteSvr.exe file has a date stamp of 2018-11-21, which is quite old. It should show the same date as the build -- the same date as the other executable files. Further, the installed file size is 1959672 bytes. Current builds are producing a file of about 2110000 bytes.
Additional Information1) Install HRD. I used build 6.7.0.227
2) Go to the "C:\Program Files (x86)\HRD Software LLC\Ham Radio Deluxe" directory
3) find the the "HRDRmoteSvr" application; view its date modified and size.

BUG#1) This is an old file, per the description here.


TagsNo tags attached.
ModuleSetup
Sub-ModuleInstall
Testing Beta Successful

Relationships

related to 0003519 closedK7ZCZ HRDRemoteSvr.exe doesn't have version stamp 

Activities

K7ZCZ

2019-10-26 15:41

administrator   ~0009024

It's fortunate this was found and fixed, but it means that we have never updated HRDRemoteSvr.EXE since at least the 6.4 release (I think ...? But for sure a long time.) That means whatever changes made to it since then have never been tested.

The team will have to catch up with those changes all at once, in this release.

https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5241

WA9PIE

2019-10-29 16:41

administrator   ~0009090

Validated (good catch)

Issue History

Date Modified Username Field Change
2019-10-26 13:57 K7ZCZ New Issue
2019-10-26 13:57 K7ZCZ Relationship added related to 0003519
2019-10-26 15:41 K7ZCZ Assigned To => K7ZCZ
2019-10-26 15:41 K7ZCZ Status new => resolved
2019-10-26 15:41 K7ZCZ Resolution open => fixed
2019-10-26 15:41 K7ZCZ Note Added: 0009024
2019-10-29 15:51 K7ZCZ Fixed in Version => 6.7.0.239
2019-10-29 16:41 WA9PIE Status resolved => closed
2019-10-29 16:41 WA9PIE Description Updated View Revisions
2019-10-29 16:41 WA9PIE Steps to Reproduce Updated View Revisions
2019-10-29 16:41 WA9PIE Testing Not Started => Beta Successful
2019-10-29 16:41 WA9PIE Note Added: 0009090
2019-11-08 02:10 WA9PIE Fixed in Version 6.7.0.239 => 6.7.0.244
2019-11-08 02:32 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe