View Issue Details

IDProjectCategoryView StatusLast Update
0003542Ham Radio DeluxeBugpublic2019-11-08 02:32
Reporterw4elpAssigned ToK7ZCZ 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSWin 10 64 homeOS Version
Product Version 
Target VersionFixed in Version6.7.0.244 
Summary0003542: HRD Beta 6.7.0.241 - Problem logging QSOs
DescriptionLogging QSOs results in blank log record showing an incorrect date.
In my case, 2 QSOs logged showed date of March 1, 2013 (displayed as 03/01/2013).
No other date appears to have been saved in log record.
This appears to be same whether using Logbook ALE or DM780.
Using Access database for log file.
Steps To ReproduceUsing either DM780 or Logbook ALE, enter a call sign, do the lookup and add any comments as in regular QSO.
Save the QSO to log
Observe the QSO record date and whether any additional data was saved.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleALE Window
Testing Beta Successful

Relationships

has duplicate 0003543 closedK7ZCZ Contents of ALE are not saved to log/database when attempting to save a QSO (6.7.0.241) 

Activities

w4elp

2019-11-03 19:11

viewer   ~0009122

Tried reverting back to 6.7.0.227 but on startup it demanded license key and always showed it was invalid. Then reinstalled 6.6.0.237. It installed and ran, except that entering a call in DM780 would cause Logbook to crash, creating minidump and DM780 to freeze, requiring Task Manager to shut it down. Otherwise, 6.6.0.237 was running. Then ran 6.7.0.227 again and it ran ok, including handling call signs in DM780. Note that the "bogus" log entries with V241 disappeared upon trying to run other versions. Minidump uploaded below.

HRDLogbook_20191103_215412.mdmp (760,365 bytes)

K7ZCZ

2019-11-04 07:57

administrator   ~0009129

The copying of the ALE data back to the new logbook record is fixed with this change set:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5262

I'll have to look at the cross-version DM780 issues separately.

K7ZCZ

2019-11-04 08:46

administrator   ~0009130

The provided dump is from 6.6.0.237:

0:021> lmDvmHRDLogbook
Browse full module list
start    end        module name
00be0000 02543000   HRDLogbook   (deferred)             
    Mapped memory image file: F:\dumps\Mantis3542\HRDLogbook.exe
    Image path: C:\Program Files (x86)\HRD SOFTWARE LLC\HAM RADIO DELUXE\HRDLogbook.exe
    Image name: HRDLogbook.exe
    Browse all global symbols  functions  data
    Timestamp:        Sun Jul 14 16:55:23 2019 (5D2BC0EB)
    CheckSum:         0173EB7A
    ImageSize:        01963000
    File version:     6.6.0.237
    Product version:  6.6.0.237
    File flags:       0 (Mask 3F)
    File OS:          40004 NT Win32
    File type:        1.0 App
    File date:        00000000.00000000
    Translations:     0409.04b0
    CompanyName:      HRD Software, LLC
    ProductName:      HRD Logbook
    InternalName:     HRD Logbook
    OriginalFilename: HRDLogbook.EXE
    ProductVersion:   6.6.0.237
    FileVersion:      6.6.0.237
    SpecialBuild:     RELEASE 6.6.0.237
    FileDescription:  Ham Radio Deluxe Logbook Application
    LegalCopyright:   Copyright © 2003 - 2019 by HRD Software, LLC
    Comments:         Ham Radio Logbook


In it, we find a crash while handling a callback after performing a call sign lookup operation:

0:021> kb
  *** Stack trace for last set context - .thread/.cxr resets it
 # ChildEBP RetAddr  Args to Child              
00 (Inline) -------- -------- -------- -------- HRDLogbook!CXMLMgr::LoadFromString+0xa [c:\hrd66\hrdcommon\xmlmgr.cpp @ 593] 
01 1610e9bc 00c45b85 00000409 1610f488 18297d1d HRDLogbook!RSDCallback+0x60 [c:\hrd66\logbook\hrdlogbook\iplistenercallsignlookup.cpp @ 33] 
02 1610f460 00d2523c 18297fb1 05e55088 06006608 HRDLogbook!CallsignLookup+0x2475 [c:\hrd66\logbook\hrdlogbook\backgroundprocessingthreadlookupcallsigns.cpp @ 586] 
03 1610f6f4 00d20e90 1610f958 182970e5 1b2a8c80 HRDLogbook!CIPListenerCallsignLookup::Perform+0xafc [c:\hrd66\logbook\hrdlogbook\iplistenercallsignlookup.cpp @ 301] 
04 1610f9ac 00d23786 1610fa00 1610fa08 1829720d HRDLogbook!CIpThread::DispatchCommand+0x380 [c:\hrd66\logbook\hrdlogbook\iplistener.cpp @ 958] 
05 1610fb50 00d208ee 182972c9 0663ac78 00d20830 HRDLogbook!CIpThread::ProcessConnection+0x276 [c:\hrd66\logbook\hrdlogbook\iplistener.cpp @ 1906] 
06 (Inline) -------- -------- -------- -------- HRDLogbook!CIpThread::ReEnterObject+0x1f [c:\hrd66\logbook\hrdlogbook\iplistener.cpp @ 756] 
07 1610fb8c 00f7b572 1b2a8c80 18297505 1c3e3180 HRDLogbook!CIpThread::StartThreadPoint+0xbe [c:\hrd66\logbook\hrdlogbook\iplistener.cpp @ 729] 
08 1610fc40 014737c0 173ff650 18297539 01473769 HRDLogbook!_AfxThreadEntry+0xfe [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\thrdcore.cpp @ 109] 
09 (Inline) -------- -------- -------- -------- HRDLogbook!invoke_thread_procedure+0xd [d:\th\minkernel\crts\ucrt\src\appcrt\startup\thread.cpp @ 91] 
0a 1610fc7c 77096359 1c3e3180 77096340 1610fce8 HRDLogbook!thread_start<unsigned int (__stdcall*)(void *)>+0x57 [d:\th\minkernel\crts\ucrt\src\appcrt\startup\thread.cpp @ 115] 
0b 1610fc8c 77b37b74 1c3e3180 6ee4e5f8 00000000 kernel32!BaseThreadInitThunk+0x19
0c 1610fce8 77b37b44 ffffffff 77b58efc 00000000 ntdll!__RtlUserThreadStart+0x2f
0d 1610fcf8 00000000 01473769 1c3e3180 00000000 ntdll!_RtlUserThreadStart+0x1b


This crash is due to bad data coming back from the RSDCallback after a lookup is done for the IP listener thread.

The callback field still exists in the REQUEST_SIGNAL_DATA structure, so I've removed it just to tidy up. But since the mechanism that invokes it doesn't exist and no handler for it exists, this failure mechanism no longer exists in the product. Due to the call sign lookup re-write, this code no longer exists in the 6.7 versions of the product.

That change set is here:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5263

With the underlying record copying issue fixed, I think this issue can be resolved. Thank you for providing a detailed, complete, and clear report; it's quite refreshing.

w4elp

2019-11-04 11:46

viewer   ~0009132

Sorry about the minidump being from v6.6. It did the same this morning running 6.7.0.227. Minidump below should be from 6.7.

HRDLogbook_20191104_131602.mdmp (788,842 bytes)

WA9PIE

2019-11-05 20:29

administrator   ~0009150

Validated

Issue History

Date Modified Username Field Change
2019-11-03 10:47 w4elp New Issue
2019-11-03 19:11 w4elp File Added: HRDLogbook_20191103_215412.mdmp
2019-11-03 19:11 w4elp Note Added: 0009122
2019-11-04 07:15 K7ZCZ Relationship added has duplicate 0003543
2019-11-04 07:57 K7ZCZ Note Added: 0009129
2019-11-04 08:46 K7ZCZ Assigned To => K7ZCZ
2019-11-04 08:46 K7ZCZ Status new => resolved
2019-11-04 08:46 K7ZCZ Resolution open => fixed
2019-11-04 08:46 K7ZCZ Testing => Not Started
2019-11-04 08:46 K7ZCZ Note Added: 0009130
2019-11-04 11:46 w4elp File Added: HRDLogbook_20191104_131602.mdmp
2019-11-04 11:46 w4elp Note Added: 0009132
2019-11-05 20:17 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2019-11-05 20:19 K7ZCZ Fixed in Version => 6.7.0.242
2019-11-05 20:29 WA9PIE Status resolved => closed
2019-11-05 20:29 WA9PIE Testing Not Started => Beta Successful
2019-11-05 20:29 WA9PIE Note Added: 0009150
2019-11-08 02:08 WA9PIE Fixed in Version 6.7.0.242 => 6.7.0.244
2019-11-08 02:32 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe