View Issue Details

IDProjectCategoryView StatusLast Update
0003545Ham Radio DeluxeBugpublic2019-11-08 02:32
ReporterWA9PIEAssigned ToK7ZCZ 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.7.0.244 
Summary0003545: HamCall.net, the Callsign Lookup does not correctly assign DXCC, Country, Continent, and HRDCountry
DescriptionThe cross-referencing for DXCC to the country list for Enabled Methods is not gathering the DXCC, Country, Continent, and HRDCountry values correctly.

As a result, the awards would could be incorrect.
Steps To Reproduce1 - Launch Rig Control
2 - Launch Logbook
3 - Go to Tools > Configure > Callsign Lookup... Enable tab
4 - Add only HamCall.net Subscription
resulting order is UCSDB (Public), UCSDB (Private), HamCall.net, Country List
5 - Press "Apply"
6 - Click the "Test" tab
7 - Enter "KH0A" (without quotes) and click "Lookup"
8 - Observe the results where the HamCall.net row does not populate Country, DXCC, HRD Country Number, and Continent correctly...

It shows them all blank.

It should show "United States", 291, 291, and NA.

As a result, the "distilled results" incorrectly show "Mariana Is.", 166, 166, and OC... rather than "United States", 291, 291, and NA.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleCall lookup
Testing Beta Successful

Relationships

related to 0003510 closedK7ZCZ Some HamCall.net fields are not being populated 

Activities

WA9PIE

2019-11-04 04:18

administrator  

KH0A (HamCall net).png (47,238 bytes)
KH0A (HamCall net).png (47,238 bytes)

K7ZCZ

2019-11-04 21:57

administrator   ~0009133

It's not clear what fix is desired here.

The issue here says "cross-referencing for DXCC to the country list for Enabled Methods is not gathering the DXCC, Country, Continent, and HRDCountry values correctly". But the HRDCallLookup.NET source doesn't produce a DXCC value with its results.

Maybe we're meant to look up the country value it produces. But it produces two, as noted in issue 0003510: prefix country and mailing country. 3510 says that the country should come from "the cross-reference to the Country List and that's where the country should come from, not field 209", but it doesn't explain what data from the lookup data source is meant to be used as a key to find the country name from the country list.

Even if we knew which country field to use, it seems dubious to use the country name at the source to find a DXCC code since a country name doesn't identify a single unique DXCC entity number.

Maybe some other algorithm is intended, but this issue doesn't make that clear.

WA9PIE

2019-11-04 22:51

administrator   ~0009139

This is another case where I missed an update. When we began this rewrite, HamCall.net data did not contain the DXCC numeric. I contacted them about this and didn't get the information into the Field Mapping Spec.

The HamCall.net owner came back to me via email and said, "I've added field #225 to HamCall, DXCC number." He went on to say that it's not been added for all calls... but here are a few to test with - 5P1S, 9A3PAJ, LY2VB, 7K2ABV, EI3IDB.

So... for HamCall.net, the DXCC numeric is included in "field #225". We should use that as the DXCC value and obtain the Country, HRD Country Number, and Continent from the Country List to augment and complete the data obtained from HamCall.net.

K7ZCZ

2019-11-05 09:41

administrator   ~0009140

parsing of new #225 field added, lookups for Country, HRDCN, Continent added in this checkin
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5268

WA9PIE

2019-11-05 20:23

administrator   ~0009145

The scope of this change is now complete. I validated it.

That said... there's a new (and likely minor) item here that I'll record separately (when field #225 is empty in HamCall.net's data, the program is not allowing the Country List to populate DXCC, Country, Continent, and HRD Country Number).

Issue History

Date Modified Username Field Change
2019-11-04 04:00 WA9PIE New Issue
2019-11-04 04:00 WA9PIE Issue generated from: 0003544
2019-11-04 04:01 WA9PIE Summary For any "Enabled Method", the Callsign Lookup does not correctly assign DXCC, Country, Continent, and HRDCountry (QRZ.com XML) => For any "Enabled Method", the Callsign Lookup does not correctly assign HRDCountry (QRZ.com XML)
2019-11-04 04:01 WA9PIE Description Updated View Revisions
2019-11-04 04:07 WA9PIE Summary For any "Enabled Method", the Callsign Lookup does not correctly assign HRDCountry (QRZ.com XML) => For any "Enabled Method", the Callsign Lookup does not correctly assign DXCC, Country, Continent, and HRDCountry (HamCall.net)
2019-11-04 04:07 WA9PIE Steps to Reproduce Updated View Revisions
2019-11-04 04:09 WA9PIE Assigned To => K7ZCZ
2019-11-04 04:09 WA9PIE Status new => assigned
2019-11-04 04:09 WA9PIE Steps to Reproduce Updated View Revisions
2019-11-04 04:10 WA9PIE Summary For any "Enabled Method", the Callsign Lookup does not correctly assign DXCC, Country, Continent, and HRDCountry (HamCall.net) => For HamCall.net, the Callsign Lookup does not correctly assign DXCC, Country, Continent, and HRDCountry
2019-11-04 04:11 WA9PIE Summary For HamCall.net, the Callsign Lookup does not correctly assign DXCC, Country, Continent, and HRDCountry => HamCall.net, the Callsign Lookup does not correctly assign DXCC, Country, Continent, and HRDCountry
2019-11-04 04:12 WA9PIE Issue cloned: 0003546
2019-11-04 04:18 WA9PIE File Added: KH0A (HamCall net).png
2019-11-04 04:32 WA9PIE Description Updated View Revisions
2019-11-04 04:59 WA9PIE Priority normal => high
2019-11-04 05:00 WA9PIE Severity minor => major
2019-11-04 21:57 K7ZCZ Status assigned => feedback
2019-11-04 21:57 K7ZCZ Note Added: 0009133
2019-11-04 21:57 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-11-04 21:57 K7ZCZ Relationship added related to 0003510
2019-11-04 22:51 WA9PIE Note Added: 0009139
2019-11-04 22:51 WA9PIE Assigned To WA9PIE => K7ZCZ
2019-11-04 22:51 WA9PIE Status feedback => assigned
2019-11-05 09:41 K7ZCZ Status assigned => resolved
2019-11-05 09:41 K7ZCZ Resolution open => fixed
2019-11-05 09:41 K7ZCZ Note Added: 0009140
2019-11-05 20:19 K7ZCZ Fixed in Version => 6.7.0.242
2019-11-05 20:23 WA9PIE Status resolved => closed
2019-11-05 20:23 WA9PIE Testing Not Started => Beta Successful
2019-11-05 20:23 WA9PIE Note Added: 0009145
2019-11-08 02:08 WA9PIE Fixed in Version 6.7.0.242 => 6.7.0.244
2019-11-08 02:32 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe