View Issue Details

IDProjectCategoryView StatusLast Update
0003546Ham Radio DeluxeBugpublic2019-11-08 02:32
ReporterWA9PIEAssigned ToK7ZCZ 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.7.0.244 
Summary0003546: Callook.info, the Callsign Lookup does not correctly assign DXCC, Country, Continent, and HRDCountry
DescriptionThe cross-referencing for DXCC to the country list for Enabled Methods is not gathering the DXCC, Country, Continent, and HRDCountry values correctly.

As a result, the awards would could be incorrect.
Steps To Reproduce1 - Launch Rig Control
2 - Launch Logbook
3 - Go to Tools > Configure > Callsign Lookup... Enable tab
4 - Add only Callook.info
resulting order is UCSDB (Public), UCSDB (Private), Callook.info, Country List
5 - Press "Apply"
6 - Click the "Test" tab
7 - Enter "KH0A" (without quotes) and click "Lookup"
8 - Observe the results where the Callook.info row does not populate Country, DXCC, HRD Country Number, and Continent correctly...

It shows them all blank.

It should show "United States", 291, 291, and NA.

As a result, the "distilled results" incorrectly show "Mariana Is.", 166, 166, and OC... rather than "United States", 291, 291, and NA.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleCall lookup
Testing Beta Successful

Relationships

related to 0003495 closedK7ZCZ Complete the Callsign Lookup function for the Callook.info method 
child of 0003001 closedWA9PIE Callsign lookup function does not appear to be working as designed 

Activities

WA9PIE

2019-11-04 04:16

administrator  

KH0A (Callook info).png (47,238 bytes)
KH0A (Callook info).png (47,238 bytes)

K7ZCZ

2019-11-04 21:57

administrator   ~0009134

This issue says the code should be "cross-referencing for DXCC to the country list". The "CallsignLookupMapping32 (most_current)c.xlsx" spreadsheet also says that the DXCC value from this source should come from the "dxcc" field.

Problem is, the callook.info source doesn't produce a DXCC field.

Is the code meant to look up the DXCC value from the country name? This doesn't seem right, since a country name doesn't uniquely identify a DXCC code. For example, Alaska and Hawaii are part of the United States, but those two states have their own DXCC entity numbers.

WA9PIE

2019-11-04 22:42

administrator   ~0009138

Here is a problem that hadn't occurred to me in the past. I will need to correct my previous point-of-view on this and ask that we take a different approach with regards to the population of Country, DXCC, HRD Country Number, and Continent. (I will correct the field mapping spec with the changes we make here.)

The desired result here is to look at the information coming from this source and use it to determine the correct Country, DXCC, HRD Country Number, and Continent. But given that the DXCC numeric isn't in the Callook.info data, then using the DXCC numeric isn't possible in this case.

Problem - if we don't sort out a way to augment the Callook.info data with correct information to augment to the Callook.info data, the Country List (as the last option) will get the values for Country, DXCC, HRD Country Number, and Continent wrong (as shown in the initial example here).

What other alternative do we have?

Suggestion: Because Callook.info contains only callsigns assigned by the FCC in the USA, then we can lookup the State provided in the Callook.info to determine the proper "ham radio country."

I used the following examples to sort this out:
https://callook.info/wa9pie/xml (State = TX); result should be United States, 291, 291, and NA
https://callook.info/kh0a/xml (State = NY); result should be United States, 291, 291, and NA
https://callook.info/kh6a/xml (State = HI); result should be Hawaii, 110, 110, and OC
https://callook.info/kl7a/xml (State = AK); result should be Alaska, 6, 6, NA
https://callook.info/kp4a/xml (State = PR); result should be Puerto Rico, 202, 202, NA

This would solve the problem.

Without solving this problem, we know that a great number of calls that were assigned while a person was living in someplace like Mariana Is. (KH0A)... will be wrong if this hits the Country List (as the last resort)... where it should be United States, 291, 291, NA (because that's where the guy currently lives).

Let me know if we can do it this way.

Really sorry I didn't catch this previously.

K7ZCZ

2019-11-05 09:53

administrator   ~0009141

It's not clear to me what you specifically mean by "look up the state".

Seems like you're proposing that we build a new reference table that translates state abbreviations like "HI" and "AK" and "PA" to DXCC entities. I guess it would also need to have things commonly listed as states (like "PR"). And it would also somehow resolve DXCC lookups for places like American Samoa, Guam, and whatever other US territories the FCC has jurisdiction and issues licenses.

I don't believe we have such a table (or set of tables) now.

WA9PIE

2019-11-05 15:17

administrator   ~0009142

Last edited: 2019-11-05 15:19

View 3 revisions

I actually woke up from a dream about this today. Sorry about that... should have provided the table.

I'm attaching a table that has a list of the abbreviations for the US States and Territories and their respective DXCC numeric.

If we can lookup the State abbreviation in this table... get the DXCC numeric... and then fill Country, HRD Country Number, and Continent from "cross-referencing" the Country List... and DXCC from this table... that should get us to the solution (and a really good one).



US-States-Territories.xlsx (10,654 bytes)

K7ZCZ

2019-11-05 17:15

administrator   ~0009143

updated to implement the new specification with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5270

WA9PIE

2019-11-05 20:28

administrator   ~0009148

This is complete and it's absolutely brilliant!

The changes we've made in this most recent change have taken a fairly weak data source and improved it to where it is absolutely (and finally) accurate for DXCC, Country, and Continent.

Great job!

Validated

Issue History

Date Modified Username Field Change
2019-11-04 04:12 WA9PIE New Issue
2019-11-04 04:12 WA9PIE Status new => assigned
2019-11-04 04:12 WA9PIE Assigned To => K7ZCZ
2019-11-04 04:12 WA9PIE Issue generated from: 0003545
2019-11-04 04:16 WA9PIE File Added: KH0A (Callook info).png
2019-11-04 04:29 WA9PIE Description Updated View Revisions
2019-11-04 04:59 WA9PIE Priority normal => high
2019-11-04 05:00 WA9PIE Severity minor => major
2019-11-04 21:57 K7ZCZ Status assigned => feedback
2019-11-04 21:57 K7ZCZ Note Added: 0009134
2019-11-04 21:57 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-11-04 21:58 K7ZCZ Relationship added related to 0003495
2019-11-04 22:42 WA9PIE Note Added: 0009138
2019-11-04 22:42 WA9PIE Assigned To WA9PIE => K7ZCZ
2019-11-04 22:52 WA9PIE Status feedback => assigned
2019-11-05 09:53 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-11-05 09:53 K7ZCZ Status assigned => feedback
2019-11-05 09:53 K7ZCZ Note Added: 0009141
2019-11-05 15:17 WA9PIE File Added: US-States-Territories.xlsx
2019-11-05 15:17 WA9PIE Note Added: 0009142
2019-11-05 15:18 WA9PIE Assigned To WA9PIE => K7ZCZ
2019-11-05 15:18 WA9PIE Status feedback => assigned
2019-11-05 15:19 WA9PIE Note Edited: 0009142 View Revisions
2019-11-05 15:19 WA9PIE Note Edited: 0009142 View Revisions
2019-11-05 17:15 K7ZCZ Status assigned => resolved
2019-11-05 17:15 K7ZCZ Resolution open => fixed
2019-11-05 17:15 K7ZCZ Note Added: 0009143
2019-11-05 20:19 K7ZCZ Fixed in Version => 6.7.0.242
2019-11-05 20:28 WA9PIE Status resolved => closed
2019-11-05 20:28 WA9PIE Testing Not Started => Beta Successful
2019-11-05 20:28 WA9PIE Note Added: 0009148
2019-11-06 16:20 WA9PIE Relationship added child of 0003001
2019-11-08 02:08 WA9PIE Fixed in Version 6.7.0.242 => 6.7.0.244
2019-11-08 02:32 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe