View Issue Details

IDProjectCategoryView StatusLast Update
0003552Ham Radio DeluxeBugpublic2019-11-08 02:31
Reporterg3yppAssigned Tog3ypp 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.7.0.244 
Summary0003552: Panadapter does not work with Icom IC-9700
DescriptionI've been trying for a couple of days to get the panadapter to work on the IC-9700 and I can't.

I have also tried connecting using the IC-7300 and IC-7610 protocols with the same result. The waterfall is black and the control boxes are empty.
The controls DO work to change the ref level, Mode, VBW and Speed on the rig Spectrum scope, but nothing is displayed on the HRD panadapter waterfall.

This morning I downloaded and printed off the Icom CI-V Reference Guides for the 9700 and 7610 to compare and contrast. With regard to the scope data there are several differences between the two and this may be where the issue lies.
Steps To ReproduceWith HRD Rig control open and connected to IC-9700
Go to Tools>Panadapter (Main) and Click
Panadapter opens with black waterfall and blank control boxes.
TagsNo tags attached.
ModuleRig Control
Sub-ModulePanadapter
Testing Beta Successful

Activities

K7ZCZ

2019-11-06 04:35

administrator   ~0009157

Works fine for me.

You can't expect the panadapter displays to work when connecting with a mismatched radio model, as almost all of the comamnds and features are unique to each model. We have no reason to support people connecting to radios where the connection model doesn't match the actual radio model; it isn't expected to work and doesn't provide any diagnostic information when it doesn't work.

If you're connecting to an IC-9700 as an IC-9700, then my guess is that you've got some mode setting that I dont' have (or haven't tested with) that prevents yours from working.

Here are the settings I have:


  • 115,200 bps connection -- won't work at all without highest data setting, as the radio won't send data.

  • need to have the panadapter display visible on the radio

  • Matching CI-V address

  • CI-V Transcieve ON or OFF, shouldn't matter

  • CI-V USB Echo Back OFF

  • CI-V USB Port set to "Unlink from [REMOTE]"



I guess it's possible that you have one of the references values so low, or have no signal, so there's nothing to plot. That would result in a plain black waveform, too.

g3ypp

2019-11-06 04:53

viewer   ~0009160

Thanks. The 115,200 bps setting was the key. All other settings were already the same as yours.
The panadapter is now working for me. Lot to learn with this radio.

K7ZCZ

2019-11-06 05:08

administrator   ~0009161

great

WA9PIE

2019-11-08 02:19

administrator   ~0009203

Validated

Issue History

Date Modified Username Field Change
2019-11-05 06:32 g3ypp New Issue
2019-11-06 04:35 K7ZCZ Assigned To => g3ypp
2019-11-06 04:35 K7ZCZ Status new => assigned
2019-11-06 04:35 K7ZCZ Status assigned => feedback
2019-11-06 04:35 K7ZCZ Note Added: 0009157
2019-11-06 04:53 g3ypp Note Added: 0009160
2019-11-06 05:08 K7ZCZ Status feedback => resolved
2019-11-06 05:08 K7ZCZ Resolution open => unable to reproduce
2019-11-06 05:08 K7ZCZ Note Added: 0009161
2019-11-07 04:31 WA9PIE Project 2 - Next Dev List (Holding Area) => 3 - Current Dev List
2019-11-08 02:19 WA9PIE Status resolved => closed
2019-11-08 02:19 WA9PIE Resolution unable to reproduce => fixed
2019-11-08 02:19 WA9PIE Fixed in Version => 6.7.0.244
2019-11-08 02:19 WA9PIE Testing Not Started => Beta Successful
2019-11-08 02:19 WA9PIE Note Added: 0009203
2019-11-08 02:31 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe