View Issue Details

IDProjectCategoryView StatusLast Update
0003560Ham Radio DeluxeBugpublic2020-04-06 07:47
Reporterw4elpAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSOS Version
Product Version 
Target VersionFixed in Version6.7.0.269 
Summary0003560: HRD V6.7.0.xxx Logbook API query involving call sign causes Logbook to crash.
DescriptionI am using a separate program which uses the Logbook API to gather data on previous QSOs with the station in the ALE. Upon sending the API query, the Logbook crashes every time.
This worked prior to v6.7. Using Access database.

Steps To ReproduceOpen HRD Logbook
Using PuTTY or similar program, open port 7826.
Send "db" and Enter - you get "Unrecognized Command" - that's ok.
Send "db list" and Enter - you get a list of the databases - That's ok.
Send "db get {CALL="W1AW"}" and Enter - No API response and Logbook immediately crashes.
Additional InformationI realize the Logbook API is not a priority, but it might be good to prevent Logbook from crashing in the event a query is received. Perhaps a "Not Available" response or something similar, if it is intended that the API will not be supported going forward.
Minidump attached below.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleInterfacing
Testing Beta Successful

Activities

w4elp

2019-11-08 13:33

viewer  

HRDLogbook_20191108_191126.mdmp (735,568 bytes)

WA9PIE

2020-04-05 09:25

administrator   ~0009651

I followed these instructions today and I didn't get a crash. (Screenshot attached)

Going out on a limb here... I feel that this may be related to Access and the problems about versions of Runtime... locally installed 64-bit versions of Office and so on. I suspect we should migrate off of Access first... and then sort out what to do with this API.

I'd love it if someone could document how this is intended to work. Is it for "reads" only? Or is it for "writes" (and THAT would be pretty scary stuff)?

API gather.PNG (33,147 bytes)
API gather.PNG (33,147 bytes)

w4elp

2020-04-05 12:11

viewer   ~0009655

You're right - it's working again. Don't know when that happened.
The only documentation I've seen is W4PC's entries in the API section of the forum. That indicates it's possible to write to the database - agree that's scary. Would prefer to query the database, but only write to ALE fields - not the database itself.

WA9PIE

2020-04-06 07:47

administrator   ~0009657

This was retested on 6.7.0.269 and this no longer occurs. As such we'll close this one under the the version it was validated on.

Issue History

Date Modified Username Field Change
2019-11-08 13:33 w4elp New Issue
2019-11-08 13:33 w4elp File Added: HRDLogbook_20191108_191126.mdmp
2020-04-05 09:25 WA9PIE File Added: API gather.PNG
2020-04-05 09:25 WA9PIE Note Added: 0009651
2020-04-05 12:11 w4elp Note Added: 0009655
2020-04-06 07:27 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2020-04-06 07:47 WA9PIE Status new => closed
2020-04-06 07:47 WA9PIE Resolution open => fixed
2020-04-06 07:47 WA9PIE OS Win 10 =>
2020-04-06 07:47 WA9PIE Fixed in Version => 6.7.0.269
2020-04-06 07:47 WA9PIE Module (select) => Logbook
2020-04-06 07:47 WA9PIE Sub-Module (select) => Interfacing
2020-04-06 07:47 WA9PIE Testing => Beta Successful
2020-04-06 07:47 WA9PIE Note Added: 0009657
2020-04-06 07:47 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe