View Issue Details

IDProjectCategoryView StatusLast Update
00035613 - Current Dev ListBugpublic2019-11-16 16:47
ReporterKB3NPHAssigned ToWA9PIE 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.7.0.247 
Summary0003561: DM-780 The Licensee section of the Callsign Lookup pane in DM-780 is not being populated
DescriptionTicket #781932 With Version 6.7.0.244, the callsign lookup pane in DM-780 is not populating the "Licensee" panel.
Steps To ReproduceOpen HRD Logbook.

1. Insure you have QRZ.com XML Lookup option configured.
2. Open DM-780
3. Click on the "View" menu and select "Callsign Lookup"
4. In the Callsign Lookup pane, enter any callsign that does NOT appear in your active logbook and click [Enter] on your keyboard.

Notice that the Lookup pane will populate with all the information except the Licensee information which remains in the collapsed state.

Tags6.7 defects
ModuleDM780
Sub-ModuleCall lookup
Testing Alpha Successful

Relationships

has duplicate 0003563 closedWA9PIE The Licensee section of the Callsign Lookup pane in DM-780 is always empty 

Activities

KB3NPH

2019-11-08 23:12

administrator  

See ticket..jpg (95,305 bytes)
See ticket..jpg (95,305 bytes)

WA9PIE

2019-11-10 18:38

administrator   ~0009234

Moved this from the Backlog to the Current Dev list and attached the "6.7 defects" tag to it.

g3ucq

2019-11-12 03:46

updater   ~0009277

I confirm this issue.

PD9FER

2019-11-12 09:33

updater   ~0009287

Saw it happen in a remote: Ticket #351663
confirming the issue

DOUG

2019-11-13 00:39

developer   ~0009290

Reproduced, and tracked down the issue. The xml passed back from the logbook isn't being parsed correctly.

DOUG

2019-11-13 22:21

developer   ~0009300

So it looks like the call sign lookup changes in log manager effected this. The xml sent to DM no longer matched what it used to. I mapped the fields that are in the xml sent to DM so it shows up now. Someone with more DM experience than me will need to tell me if it is enough. If it is now, let me know exactly is still needed in that section (give descriptions if it is a HAM acronym that I might not know).

Checked in and will be in the the build I put together later tonight.

DOUG

2019-11-14 00:30

developer   ~0009307

in the build just posted

WA9PIE

2019-11-14 02:47

administrator   ~0009308

I tested it and it's good. I'm going to leave this open so that others can comment.

I noticed that the lat/long are absent. I'll open a separate one for that.

WA9PIE

2019-11-16 16:47

administrator   ~0009334

Validated in 6.7.0.247 alpha.

Issue History

Date Modified Username Field Change
2019-11-08 23:12 KB3NPH New Issue
2019-11-08 23:12 KB3NPH File Added: See ticket..jpg
2019-11-10 17:28 K7ZCZ Relationship added has duplicate 0003563
2019-11-10 18:38 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2019-11-10 18:38 WA9PIE Tag Attached: 6.7 defects
2019-11-10 18:38 WA9PIE Note Added: 0009234
2019-11-10 18:42 WA9PIE Summary DM-780 Callsign Lookup Not Populating Properly => DM-780 The Licensee section of the Callsign Lookup pane in DM-780 is not being populated
2019-11-10 18:42 WA9PIE Steps to Reproduce Updated View Revisions
2019-11-11 15:30 WA9PIE Assigned To => K7ZCZ
2019-11-11 15:30 WA9PIE Status new => assigned
2019-11-12 03:46 g3ucq Note Added: 0009277
2019-11-12 09:33 PD9FER Note Added: 0009287
2019-11-12 18:46 DOUG Assigned To K7ZCZ => DOUG
2019-11-13 00:39 DOUG Note Added: 0009290
2019-11-13 22:21 DOUG Note Added: 0009300
2019-11-14 00:30 DOUG Assigned To DOUG => WA9PIE
2019-11-14 00:30 DOUG Status assigned => resolved
2019-11-14 00:30 DOUG Resolution open => fixed
2019-11-14 00:30 DOUG Note Added: 0009307
2019-11-14 02:47 WA9PIE Fixed in Version => 6.7.0.247
2019-11-14 02:47 WA9PIE Testing Not Started => Beta Successful
2019-11-14 02:47 WA9PIE Note Added: 0009308
2019-11-16 16:47 WA9PIE Status resolved => closed
2019-11-16 16:47 WA9PIE Testing Beta Successful => Alpha Successful
2019-11-16 16:47 WA9PIE Note Added: 0009334