View Issue Details

IDProjectCategoryView StatusLast Update
00035643 - Current Dev ListBugpublic2019-11-11 05:48
ReporterWA9PIEAssigned ToWA9PIE 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version6.7.0.245 
Summary0003564: Users receive an "Unspecified Error" in Logbook with AR Cluster connection in DX cluster
DescriptionUsers receive an "Unspecified Error" in Logbook when the DX Cluster is connected to an AR Cluster node and we send the "Echo #" command to the cluster. It seems that Logbook has a problem parsing the response and it throws an "Unspecified Error."

I think that "Echo #" (which is common in DX Spider node connections) is sent as a "keep alive" for the connection.
Steps To Reproduce- Launch Rig Control (any radio or Demomatic is fine)
- Launch Logbook
- In DX cluster options (Tools > Configure > DX Cluster), add the following "AR Cluster" node:
Title: K1TTT test
Address: dxc.k1ttt.net
Port 7373
- Save it and connect to that node
- The node will be identified as an "AR Cluster" node in the title line of the DX cluster pane (Logbook parses the initial response from the node to determine the cluster node type)
- Wait a bit (it took about a minute for me)

BUG: After some period of time, the "Unspecified error" will be displayed.
Additional InformationYou can click through the "Unspecified error" until it goes away. Then you can open the DX cluster console (by clicking the "Show" tear-off... dropping down to Console". You can see the lines that were causing the problem. They are as follows:

"Unknown command - (echo #) - Type Help for a list of commands" (without quotes)

With all of this as fact, here are some things that one can infer:
- AR Cluster nodes don't have an "echo #"command
- When we send this command to an AR Cluster node, and it responds with "Unknown command - (echo #) - Type Help for a list of commands", then the parsing logic in Logbook's DX cluster freaks out and generates an "Unspecified error" message.

If these things are true, we could do one of two things:
1. We could stop sending the "echo #" command to the AR Cluster nodes
2. We could just add a case where the parsing logic knows to ignore "Unknown command - (echo #) - Type Help for a list of commands"

WORKAROUND: Connect to anything else but an AR Cluster node and it works fine and doesn't generate an error (like WA9PIE-2 or VE7CC-1).
Tags6.7 defects
ModuleLogbook
Sub-ModuleDX Cluster
Testing N/A

Relationships

related to 0003549 new station info structure not initialized when debugging without QLM Developer license 

Activities

WA9PIE

2019-11-09 05:57

administrator  

K7ZCZ

2019-11-10 16:47

administrator   ~0009231

I'm not able to reproduce this issue. The issue can't be reproduced on my laptop because I don't have a QLM development license for my laptop and the problem described in Matnis 3549 prevents me from using this feature without a QLM license installed.

I've tried to repro this issue on my desktop. I see the error about the echo command go by almost immediately afer connecting, but I don't get a message box from the application afterward. I've tried twice, waiting about 20 minutes each time.

WA9PIE

2019-11-10 18:36

administrator   ~0009233

Do you need a QLM dev license to repro this? I don't have a QLM license on my laptop and the repro is pretty solid there.

Which message box are you referring to? The "Unspecified error" one? With an AR Cluster node... those things are pinging me to death.

K7ZCZ

2019-11-10 18:58

administrator   ~0009237

Developers need a QLM license to run a QLM-protected application under a debugger. Applications in the HRD suite are QLM-protected. The Logbook won't connect to a DX Cluster without some (all?) fields in the My Station window set. Since the application won't load the My Station data under the debugger when no QLM license is present, I'm unable to open the DX Cluster and connect on my laptop.

Yes, I'm referring to the "HRD Logbook" message box in your screenshot with the error message. No such error messages appear for me after I follow your repro steps.

WA9PIE

2019-11-10 19:03

administrator   ~0009238

I've asked Soraco for support on this. As I've said before, I have no problem obtaining another QLM Dev license. Last time this came up, I was under the impression that it wasn't needed.

As quickly as I can get feedback from Soraco, I can solve this problem.

K7ZCZ

2019-11-10 19:15

administrator   ~0009239

I think there have been email conversations about this problem, and for sure Mantis 3549 is documenting the issue. As I'm not going to be spending much time on this project in the future, the purchase of an additional license for me isn't warranted. Further notes about the issue should be made in Mantis 3549 so that this issue isn't diluted.

WA9PIE

2019-11-10 19:18

administrator   ~0009240

While I'm sorting out the Soraco response... to verify...

You're connected to the K1TTT cluster with the following?
Title: K1TTT test
Address: dxc.k1ttt.net
Port 7373

The only way this error will repro is if the connection is made to an AR Cluster. K1TTT is an AR Cluster. (The "echo #" command is no problem for other types of nodes.)

K7ZCZ

2019-11-10 19:21

administrator   ~0009241

My connection settings match those given in the repro

PD9FER

2019-11-11 01:49

updater   ~0009249

You need to have an active database with WSI enabled

WA9PIE

2019-11-11 05:29

administrator   ~0009254

With the 6.7.0.245 build, I am unable to repro this.

WA9PIE

2019-11-11 05:48

administrator   ~0009255

After receiving the 6.7.0.245 beta build, Ferry and I can no longer reproduce this.

Closing

Issue History

Date Modified Username Field Change
2019-11-09 05:57 WA9PIE New Issue
2019-11-09 05:57 WA9PIE Tag Attached: 6.7 defects
2019-11-09 05:57 WA9PIE File Added: Logbook-Unspecified-error.PNG
2019-11-09 05:58 WA9PIE Description Updated View Revisions
2019-11-09 05:58 WA9PIE Steps to Reproduce Updated View Revisions
2019-11-09 05:58 WA9PIE Additional Information Updated View Revisions
2019-11-09 05:59 WA9PIE Additional Information Updated View Revisions
2019-11-09 17:21 WA9PIE Status new => assigned
2019-11-09 17:21 WA9PIE Assigned To => K7ZCZ
2019-11-10 16:47 K7ZCZ Note Added: 0009231
2019-11-10 18:36 WA9PIE Note Added: 0009233
2019-11-10 18:58 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-11-10 18:58 K7ZCZ Note Added: 0009237
2019-11-10 18:58 K7ZCZ Relationship added related to 0003549
2019-11-10 19:03 WA9PIE Note Added: 0009238
2019-11-10 19:15 K7ZCZ Note Added: 0009239
2019-11-10 19:18 WA9PIE Assigned To WA9PIE => K7ZCZ
2019-11-10 19:18 WA9PIE Note Added: 0009240
2019-11-10 19:21 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-11-10 19:21 K7ZCZ Note Added: 0009241
2019-11-11 01:49 PD9FER Note Added: 0009249
2019-11-11 05:29 WA9PIE Note Added: 0009254
2019-11-11 05:48 WA9PIE Status assigned => closed
2019-11-11 05:48 WA9PIE Resolution open => unable to reproduce
2019-11-11 05:48 WA9PIE Fixed in Version => 6.7.0.245
2019-11-11 05:48 WA9PIE Testing Not Started => N/A
2019-11-11 05:48 WA9PIE Note Added: 0009255