View Issue Details

IDProjectCategoryView StatusLast Update
0003584Ham Radio DeluxeBugpublic2020-04-01 01:41
ReporterKB3NPHAssigned ToDOUG 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.7.0.269 
Summary0003584: FT4 Contacts not logged properly in Logbook to allow confirmations from LoTW
DescriptionFT4 has been designated as a submode of MFSK by the ADIF board. This puts the FT4 mode in the ADIF3 category which HRD Logbook does not currently support. Mike C and I have discussed this and here are Mike C's recommendations.

1 - create a new field in the database called COL_SUBMODE
2 - we add SUBMODE to the ALE under the existing "Mode" field
3 - correctly save data to Logbook coming from WSJT-X logging via the "QSO Forwarding" function.
4 - update the matching criteria for LOTW so that anything downloaded with MFSK as MODE and FT4 as SUBMODE will match

Additional InformationAfter we test the above, we can do this:
* - Modify the table that contains MODE to include SUBMODES as defined by the ADIF:
       http://www.adif.org/310/ADIF_310.htm#Mode_Enumeration

These values should be provided in a drop-down list for the Submode field as Modes are currently.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleData
Testing Beta Successful

Relationships

has duplicate 0003504 closedDOUG Using QSO Forwarding FT4 is put in the log as MFSK 
related to 0003655 closedDOUG Populate drop-down list for SubMode in Bulk Editor 

Activities

WA9PIE

2019-11-14 06:24

administrator   ~0009317

Last edited: 2019-11-14 06:31

View 4 revisions

Eliminating irrelevant QSO fields... I'm going to explain what needs to be done in order to fix this problem:

Here is the data that comes from WSJT-X to Logbook via "QSO Forwarding":
<mode:4>MFSK <submode:3>FT4

Here's what we need to do with that data:
We need to store MFSK into the COL_MODE field (this already happens)
We need to store FT4 into a new field called COL_SUBMODE (ADIF is <submode:x> where x is the number of characters of text in the field; in the case of FT4, it's <submode:3>FT4)

On LOTW upload, here what we need to do:
We need to include the ADIF field "<submode>" in the LOTW upload. The resulting uploaded data would be:
<mode:4>MFSK <submode:3>FT4

Once these fields are uploaded to LOTW, the QSO Mode appears as "FT4" in LOTW.

On LOTW download, here's what we need to do:
Here is the data that comes down from LOTW to Logbook during LOTW Download when both the MODE and SUBMODE were uploaded:
<mode:4>MFSK <submode:3>FT4

During the LOTW download process in HRD Logbook, we need to add an additional matching criteria for <submode> - only IF IT EXISTS in the downloaded data. (Generally, the data downloaded from LOTW will not include a field where there is no data. So - effectively - both sides are "NULL" in that case and - therefore - match.)

WA9PIE

2019-11-14 06:28

administrator   ~0009318

Doug... take this on after we get the upcoming 6.7 maintenance release out.

WA9PIE

2019-11-16 03:55

administrator   ~0009331

To fix this completely, we'll need a table of Submodes that map to Modes. I'm attaching that.

I'm also attaching a mock-up of a "Submodes Editor" (fashioned to be similar to the "Modes Editor").

The Submodes are enumerated here: http://www.adif.org/310/ADIF_310.htm#Submode_Enumeration

Submodes.xlsx (11,807 bytes)
Submodes.png (79,059 bytes)
Submodes.png (79,059 bytes)

WA9PIE

2020-02-12 05:27

administrator   ~0009588

Doug, I've created a document that describes (what I think are) the steps to fix this problem. Attached.

Let me know if you have any questions.

Fixing LOTW Matching for FT4 QSOs.docx (49,642 bytes)

DOUG

2020-03-03 23:42

developer   ~0009592

Ok, I have some of the basics in place. One thing of note, when I am using the sim radio, I am getting a message for something called "sub mode" into the ALE screen. In the example, Mode is USB, Sub mode is LSB, should I ignore that?

PD9FER

2020-03-17 07:22

viewer   ~0009595

As far I can see the mode is SSB and the Submode should be LSB or USB (depending on if working LSB or USB)

DOUG

2020-03-22 15:35

developer   ~0009597

I have the first pass of this done, I should get a test build of this out soon.

PD9FER

2020-03-26 02:45

viewer  

ALE.jpg (128,418 bytes)
ALE.jpg (128,418 bytes)
LoTW.jpg (35,885 bytes)
LoTW.jpg (35,885 bytes)
wsjtx to LB.txt (342 bytes)
<call:5>UY2LA <gridsquare:4>KN89 <mode:4>MFSK <submode:3>FT4 <rst_sent:3>-01 <rst_rcvd:3>-14 <qso_date:8>20200326 <time_on:6>071116 <qso_date_off:8>20200326 <time_off:6>071145 <band:3>20m <freq:9>14.080820 <station_callsign:6>PD9FER <my_gridsquare:6>JO22OQ <tx_pwr:2>15 <comment:33>Tnx for FT4 Contact, 73 de PD9FER <operator:6>PD9FER <eor>
wsjtx to LB.txt (342 bytes)
ADIF in LB.txt (1,714 bytes)
#++
#
#   HRD Logbook version 6.7.0.263, Copyright � 2003 - 2019 by HRD Software, LLC
#   https://www.HamRadioDeluxe.com/
#
#   Created:  20200326 081243
#
#--

<ADIF_VERS:3>2.2
<PROGRAMID:14>HamRadioDeluxe
<PROGRAMVERSION:17>Version 6.7.0.263
<CREATED_TIMESTAMP:15>20200326 081243
<EOH>

<address:80>Alexander Glamazda, UY2LA

Gagarina 6 Chkalovskoye

Kharkiv obl,  63544

Ukraine <a_index:3>0.0 
<ant_az:3>0.0 <ant_el:3>0.0 <band:3>20m <call:5>UY2LA <comment:33>Tnx for FT4 Contact, 73 de PD9FER <country:7>Ukraine 
<cqz:2>16 <distance:8>1873.600 <dxcc:3>288 <eqsl_qslsdate:8>20200326 <eqsl_qsl_rcvd:1>N <eqsl_qsl_sent:1>Y 
<app_hamradiodeluxe_eqsl_status:125>Result: 1 out of 1 records added, Information: From: PD9FER To: UY2LA Date: 20200326 Time: 0711 Band: 20M Mode: MFSK RST: -01 
<force_init:1>N <freq:9>14.080820 <gridsquare:6>KN59rb <app_hamradiodeluxe_heading:6>91.893 <ituz:2>29 
<k_index:3>0.0 <lat:11>N049 04.000 <lon:11>E031 25.254 <lotw_qsl_rcvd:1>N <lotw_qsl_sent:1>N <mode:4>MFSK 
<my_city:11>Grootebroek <my_country:11>Netherlands <my_cq_zone:2>14 <my_gridsquare:6>JO22oq <my_itu_zone:2>27 
<my_lat:11>N052 41.250 <my_lon:11>E005 12.500 <my_name:5>Ferry <my_postal_code:7>1613 CE <my_rig:12>Icom IC-9100 
<my_state:2>NH <my_street:13>Schouwwagen 1 <name:18>Alexander Glamazda <operator:6>PD9FER <owner_callsign:6>PD9FER 
<pfx:3>UY2 <qsl_rcvd:1>N <qsl_sent:1>N <qso_complete:1>Y <qso_random:1>N <qth:11>Kharkiv obl <rst_rcvd:3>-14 
<rst_sent:3>-01 <rx_pwr:3>0.0 <sfi:3>0.0 <station_callsign:6>PD9FER <swl:1>N <time_off:6>071145 <time_on:6>071116 
<tx_pwr:6>25.000 <app_hamradiodeluxe_my_antennas:13>Fritzel FB-34 <hrdcountryno:3>288 <qso_date:8>20200326 <EOR>

ADIF in LB.txt (1,714 bytes)

PD9FER

2020-03-26 02:45

viewer   ~0009600

Tested it, but No Sub Mode is assigned.
Attached are my ADIF files and some screenshots.

LOTWUpload 2020-03-26 081431.txt (1,496 bytes)
#++
#
#   HRD Logbook version 6.7.0.263, Copyright � 2003 - 2019 by HRD Software, LLC
#   https://www.HamRadioDeluxe.com/
#
#   Created:  26-Mar-2020 08:14:36
#
#--

<ADIF_VERS:3>2.2
<PROGRAMID:14>HamRadioDeluxe
<PROGRAMVERSION:17>Version 6.7.0.263
<EOH>

<address:80>Alexander Glamazda, UY2LA

Gagarina 6 Chkalovskoye

Kharkiv obl,  63544

Ukraine <a_index:3>0.0 
<ant_az:3>0.0 <ant_el:3>0.0 <band:3>20m <call:5>UY2LA <comment:33>Tnx for FT4 Contact, 73 de PD9FER <country:7>Ukraine 
<cqz:2>16 <distance:8>1873.600 <dxcc:3>288 <eqsl_qslsdate:8>20200326 <eqsl_qsl_rcvd:1>N <eqsl_qsl_sent:1>Y 
<force_init:1>0 <freq:9>14.080820 <freq_rx:1>0 <gridsquare:6>KN59rb <ituz:2>29 <k_index:3>0.0 <lat:11>N049 04.000 
<lon:11>E031 25.254 <lotw_qslsdate:8>20200326 <lotw_qsl_rcvd:1>N <lotw_qsl_sent:1>Y <mode:4>MFSK <my_city:11>Grootebroek 
<my_country:11>Netherlands <my_cq_zone:2>14 <my_gridsquare:6>JO22oq <my_itu_zone:2>27 <my_lat:11>N052 41.250 
<my_lon:11>E005 12.500 <my_name:5>Ferry <my_postal_code:7>1613 CE <my_rig:12>Icom IC-9100 <my_state:2>NH 
<my_street:13>Schouwwagen 1 <name:18>Alexander Glamazda <operator:6>PD9FER <owner_callsign:6>PD9FER <pfx:3>UY2 
<qsl_rcvd:1>N <qsl_sent:1>N <qso_complete:1>Y <qso_random:1>0 <qth:11>Kharkiv obl <rst_rcvd:3>-14 <rst_sent:3>-01 
<rx_pwr:3>0.0 <sfi:3>0.0 <station_callsign:6>PD9FER <swl:1>0 <time_off:6>071145 <time_on:6>071116 <qso_date:8>20200326 
<tx_pwr:6>25.000 <user_defined_9:8>20200326 <hrdcountryno:3>288 <EOR>

g3ucq

2020-03-26 04:46

viewer   ~0009601

Not sure if I am testing this correctly.
I created COL_SUBMODE in the ALE Custom fields
Made a FT4 QSO and the Mode populated the Logbook as MSFK.

WA9PIE

2020-03-26 06:14

administrator   ~0009602

Last edited: 2020-03-26 06:39

View 4 revisions

This is 95% done.

What happens is this.
> The submode isn't correctly going into Logbook and stored correctly. (Because of this, the submode isn't being included in the ADIF.)
> If you manually enter the submode, the exported ADIF field is incorrect as "sub_mode" (it should be, simply, "submode").

Further:
> Suspecting that the problem is related to the overall misnaming of the "submode" field, I manually edited Ferry's WSJT-X ADIF file to change the field from submode to sub_mode and it imported and exported in the ADIF (albeit, with the wrong field name).

ACTION/What needs to be fixed (very simple):
> Rename the ADIF value from "sub_mode" to "submode" and this should work properly.

G3UCQ - There is no need to create a (custom) field for this.

Mike, VK4EIE

(Ron - this is all going to work out. Relax.)

g3ucq

2020-03-26 11:56

viewer   ~0009604

QSOs forward as MFSK into Logbook.

WA9PIE

2020-03-26 19:30

administrator   ~0009605

Right. They do forward into Logbook as MFSK. This is correct, because the MODE for FT4 is MFSK.

The problem that Doug is working on is with regards to the SUBMODE. Once he corrects this in code...

The QSO will forward into Logbook as "<mode:4>MFSK <submode:3>FT4" (as mentioned in my original post here). This will finish this change and then Logbook will be compliant with ADIF and LOTW with regards to FT4.

DOUG

2020-03-26 21:42

developer   ~0009607

I made this change, new beta build is done.

WA9PIE

2020-03-26 23:32

administrator   ~0009608

In the 264 build, the file imported... but the field names (for column and ADIF) weren't correct.

in the 265 build, the file will no longer import (and this would affect a whole lot more than just this functionality).

I'm attaching the file here that I've been testing with. You can import it from Logbook > File > Import... and select this file.

wsjtx to LB.adi (342 bytes)

WA9PIE

2020-03-27 05:01

administrator   ~0009609

Doug,

I created videos showing the behavior of the 264 and 265 builds.

You can find them via GDFS\HRD Software\Doug\3584

g3ucq

2020-03-27 05:06

viewer   ~0009610

FT4 QSOs uploaded to LOTW shows as FT4.

WA9PIE

2020-03-27 08:47

administrator   ~0009611

John... when the QSO goes into LOTW with "<mode:4>MFSK <submode:3>FT4", then LOTW knows to display it as FT4.

But when it goes into LOTW with only "<mode:4>MFSK", then it displays it as DATA.

FT4 isn't a MODE. It's a SUBMODE of MFSK.

What we're doing here will work.

(Yes Ron, it will work... because that's the way the other systems were designed.)

WA9PIE

2020-03-27 08:50

administrator   ~0009612

Doug:

Here's a pictorial representation of what should happen.

submode.png (53,056 bytes)
submode.png (53,056 bytes)

g3ucq

2020-03-27 15:50

viewer   ~0009613

A FT4 QSO, logged as MFSK, uploaded to LOTW but the LOTW download did not Verify the QSO as a match.

WA9PIE

2020-03-28 07:25

administrator   ~0009614

John... up through beta build #265, the problem hasn't been fixed. I suspect Doug will get nail this very soon.

When it's done, it will behave as shown in the diagram that I posted above.

Let's watch for #266.

WA9PIE

2020-03-29 17:42

administrator   ~0009615

Last edited: 2020-03-29 19:10

View 2 revisions

I believe that the 266 build resolves this problem.

Testing:
> Using QSO Forwarding, allow an FT4 QSO to be created in Logbook from WSJT-X
> Check the QSO in the Logbook ALE. The MODE should be MFSK. The SUBMODE should be FT4.
> Upload it to LOTW; I believe it should show there as FT4 (but I'm not 100% certain).
> Get your buddy to upload his as well.
> Download the confirmation. See if it matches.

PD9FER

2020-03-30 04:09

viewer   ~0009616

Looks good so far.
Only need some confirmations, but it shows correct in LoTW.

g3ucq

2020-03-30 04:22

viewer   ~0009617

Same as Ferry.

g3ucq

2020-03-30 04:53

viewer   ~0009618

First FT4 downloads from LOTW did not verify a match but the data looks OK. DS5USH and YO4NF.

LOTW down.JPG (36,222 bytes)
LOTW down.JPG (36,222 bytes)

g3ucq

2020-03-30 05:07

viewer   ~0009619

Same again

LOTW-2.JPG (21,477 bytes)
LOTW-2.JPG (21,477 bytes)

WA9PIE

2020-03-30 05:22

administrator   ~0009621

Yeah, we're going to have to provide guidance for folks to help them use bulk editor to update previous QSOs.

For these previous QSOs, the SUBMODE field is blank (because the field didn't exist). So they'll have to find these old QSOs (either when the MODE=MFSK and SUBMODE is empty... or when the MODE=FT4... but in these cases, they'll have to modify them to be MODE=MFSK and SUBMODE=FT4... then upload them again... and they will match).

(See Ron, I told you this would work out.)

PD9FER

2020-03-30 05:26

viewer   ~0009622

I confirm Verification for LoTW, just got one in.

g3ucq

2020-03-30 06:16

viewer   ~0009624

"I confirm Verification for LoTW, just got one in."
Why are my FT4 QSOs not matching?

PD9FER

2020-03-30 06:49

viewer   ~0009625

John, has the other party uploaded theire Log to LoTW yet?

WA9PIE

2020-03-30 07:52

administrator   ~0009626

Both parties have to upload Mode=MFSK and SUBMODE=FT4... if that happens (and all the other things are correct), they'll match.

If you go back to previous QSOs, they may not match because SUBMODE didn't exist in Logbook then. There were times when we just sent the mode as FT4 and that was wrong.

So... if they were uploaded wrong in LOTW, then they'll have to be uploaded again... then they should match against QSOs that are uploaded with the correct data.

g3ucq

2020-03-30 08:18

viewer   ~0009627

These QSOs were made today using .266.

g3ucq

2020-03-30 09:16

viewer   ~0009628

In the LOTW download .adif file the Mode is MFSK and Submode FT4 but the QSOs still do not match for me.

WA9PIE

2020-03-30 17:45

administrator   ~0009629

While pondering this, I have found the following article:

https://groups.arrl.org/g/ARRL-LoTW/topic/my_ft_4_contacts_are_showing/64418516?p=,,,20,0,0,0::recentpostdate%2Fsticky,,,20,2,20,64418516

John - can you get me a copy of and ADIF for the QSOs in-question, as well as the ADIF you're downloading from LOTW so I can look at these?

g3ucq

2020-03-31 02:03

viewer   ~0009630

Mike. I attach the LOTW download, G3UCQ.adif export from Logbook and the LOTW report. HTH

LOTWDownload 2020-03-31 075839.ADI (6,878 bytes)
G3UCQ.ADI (21,400 bytes)
lotwreport(1).adi (3,899 bytes)

g3ucq

2020-03-31 02:08

viewer   ~0009631

In my Logbook adif export the Mode is listed as FT4 and Submode as FT4. The Logbook is showing MFSK and FT4?

WA9PIE

2020-03-31 03:13

administrator   ~0009632

Yeah, the data in the fields in these files match, John.

The G3UCQ.ADI is an export from your log (thanks). This shows me that <mode:3>FT4 and <submode:3>FT4. It should be <mode:4>MFSK and <submode:3>FT4.
Looking at the lotwreport(1).adi file, which is the file that has the conformations in it, I can see that it correctly shows <mode:4>MFSK and <submode:3>FT4.

But these won't match.

I'm going to record a video where I simulate this and I'll post it here shortly.

PD9FER

2020-03-31 03:21

viewer   ~0009633

John, in Tools > Configure > Modes, click Defaults and restart Logbook
Looks like You have MFSK > FT4 in there

g3ucq

2020-03-31 03:32

viewer   ~0009634

Looks like you have nailed it Ferry. Getting Verified matches now. Thank you

WA9PIE

2020-03-31 04:00

administrator   ~0009635

John,

I'm posting a link to the video in our beta forums. Thanks for providing this. It validated the change perfectly.

- The log entries have to be MODE = MFSK and SUBMODE = FT4
- They have to be uploaded to LOTW as such (even if they were previously uploaded, they have to go again so they're in there correctly)
- Then they download from LOTW to where the MODE and SUBMODE match (respectively) and we're good!

All we need now is to get the dropdown list to populate for Sub Mode and we're good-to-go!

(See Ron, I told you so.)

WA9PIE

2020-03-31 04:05

administrator   ~0009636

I verified this myself using files provided by G3UCQ

g3ucq

2020-03-31 04:09

viewer   ~0009637

Yes, I re-uploaded all my FT4 QSOs to LOTW and after doing Ferry's advice all working now.
Somehow I had the Modes wrong in the Modes file. Clicking Default fixed it so perhaps that advice should go to users once this is released.

WA9PIE

2020-03-31 05:48

administrator   ~0009638

Finally! (and I told you so, Ron) This is complete.

John, Ferry, and I have successfully validated this item.

I'll create a video to go along with this release that instructs the user to:
- set the Modes back to "Default"
- add Submode field into their layout
- change the setting in JTAlert, if they use it, to log it per the ADIF standard
- how to use Bulk Editor to update previous log entries and re-upload to LOTW where necessary
- go through the process of downloading from LOTW to match the QSOs

(John, I'll probably use your log, if that's okay.)

Issue History

Date Modified Username Field Change
2019-11-13 06:34 KB3NPH New Issue
2019-11-13 06:54 KB3NPH File Added: WY0V in HRD Logbook.jpg
2019-11-13 07:11 KB3NPH File Added: WY0V In LoTW Logbook.jpg
2019-11-14 01:52 KB3NPH Assigned To => DOUG
2019-11-14 01:52 KB3NPH Status new => assigned
2019-11-14 04:43 WA9PIE Additional Information Updated View Revisions
2019-11-14 06:22 WA9PIE File Deleted: WY0V In LoTW Logbook.jpg
2019-11-14 06:22 WA9PIE File Deleted: WY0V in HRD Logbook.jpg
2019-11-14 06:24 WA9PIE Note Added: 0009317
2019-11-14 06:26 WA9PIE Description Updated View Revisions
2019-11-14 06:28 WA9PIE Note Added: 0009318
2019-11-14 06:30 WA9PIE Note Edited: 0009317 View Revisions
2019-11-14 06:30 WA9PIE Note Edited: 0009317 View Revisions
2019-11-14 06:31 WA9PIE Note Edited: 0009317 View Revisions
2019-11-14 06:38 WA9PIE Description Updated View Revisions
2019-11-14 06:38 WA9PIE Additional Information Updated View Revisions
2019-11-14 20:14 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2019-11-16 03:55 WA9PIE File Added: Submodes.xlsx
2019-11-16 03:55 WA9PIE File Added: Submodes.png
2019-11-16 03:55 WA9PIE Note Added: 0009331
2019-11-20 18:29 WA9PIE Relationship added related to 0003504
2020-02-12 05:25 WA9PIE File Added: FT4 - ALE Field Addition.png
2020-02-12 05:25 WA9PIE File Deleted: FT4 - ALE Field Addition.png
2020-02-12 05:27 WA9PIE File Added: Fixing LOTW Matching for FT4 QSOs.docx
2020-02-12 05:27 WA9PIE Note Added: 0009588
2020-03-03 23:42 DOUG Note Added: 0009592
2020-03-17 07:22 PD9FER Note Added: 0009595
2020-03-22 15:35 DOUG Note Added: 0009597
2020-03-26 01:54 WA9PIE Status assigned => resolved
2020-03-26 01:54 WA9PIE Resolution open => fixed
2020-03-26 01:54 WA9PIE Fixed in Version => 6.7.0.263
2020-03-26 02:45 PD9FER File Added: ALE.jpg
2020-03-26 02:45 PD9FER File Added: LoTW.jpg
2020-03-26 02:45 PD9FER File Added: wsjtx to LB.txt
2020-03-26 02:45 PD9FER File Added: ADIF in LB.txt
2020-03-26 02:45 PD9FER File Added: LOTWUpload 2020-03-26 081431.txt
2020-03-26 02:45 PD9FER Note Added: 0009600
2020-03-26 04:46 g3ucq Note Added: 0009601
2020-03-26 06:14 WA9PIE Status resolved => assigned
2020-03-26 06:14 WA9PIE Resolution fixed => reopened
2020-03-26 06:14 WA9PIE Fixed in Version 6.7.0.263 =>
2020-03-26 06:14 WA9PIE Testing Not Started => Beta Failed
2020-03-26 06:14 WA9PIE Note Added: 0009602
2020-03-26 06:18 WA9PIE Note Edited: 0009602 View Revisions
2020-03-26 06:31 WA9PIE Note Edited: 0009602 View Revisions
2020-03-26 06:39 WA9PIE Note Edited: 0009602 View Revisions
2020-03-26 11:56 g3ucq Note Added: 0009604
2020-03-26 19:30 WA9PIE Note Added: 0009605
2020-03-26 21:42 DOUG Note Added: 0009607
2020-03-26 23:32 WA9PIE File Added: wsjtx to LB.adi
2020-03-26 23:32 WA9PIE Note Added: 0009608
2020-03-27 05:01 WA9PIE Note Added: 0009609
2020-03-27 05:06 g3ucq Note Added: 0009610
2020-03-27 08:47 WA9PIE Note Added: 0009611
2020-03-27 08:50 WA9PIE File Added: submode.png
2020-03-27 08:50 WA9PIE Note Added: 0009612
2020-03-27 15:50 g3ucq Note Added: 0009613
2020-03-28 07:25 WA9PIE Note Added: 0009614
2020-03-29 17:42 WA9PIE Status assigned => resolved
2020-03-29 17:42 WA9PIE Resolution reopened => fixed
2020-03-29 17:42 WA9PIE Fixed in Version => 6.7.0.266
2020-03-29 17:42 WA9PIE Testing Beta Failed => Not Started
2020-03-29 17:42 WA9PIE Note Added: 0009615
2020-03-29 19:10 WA9PIE Note Edited: 0009615 View Revisions
2020-03-30 04:09 PD9FER Note Added: 0009616
2020-03-30 04:22 g3ucq Note Added: 0009617
2020-03-30 04:53 g3ucq File Added: LOTW down.JPG
2020-03-30 04:53 g3ucq Note Added: 0009618
2020-03-30 05:07 g3ucq File Added: LOTW-2.JPG
2020-03-30 05:07 g3ucq Note Added: 0009619
2020-03-30 05:21 PD9FER Relationship replaced has duplicate 0003504
2020-03-30 05:22 WA9PIE Note Added: 0009621
2020-03-30 05:26 PD9FER Note Added: 0009622
2020-03-30 06:16 g3ucq Note Added: 0009624
2020-03-30 06:49 PD9FER Note Added: 0009625
2020-03-30 07:52 WA9PIE Note Added: 0009626
2020-03-30 08:18 g3ucq Note Added: 0009627
2020-03-30 09:16 g3ucq Note Added: 0009628
2020-03-30 09:17 WA9PIE Relationship added related to 0003655
2020-03-30 17:45 WA9PIE Note Added: 0009629
2020-03-31 02:03 g3ucq File Added: LOTWDownload 2020-03-31 075839.ADI
2020-03-31 02:03 g3ucq File Added: G3UCQ.ADI
2020-03-31 02:03 g3ucq File Added: lotwreport(1).adi
2020-03-31 02:03 g3ucq Note Added: 0009630
2020-03-31 02:08 g3ucq Note Added: 0009631
2020-03-31 03:13 WA9PIE Note Added: 0009632
2020-03-31 03:21 PD9FER Note Added: 0009633
2020-03-31 03:32 g3ucq Note Added: 0009634
2020-03-31 04:00 WA9PIE Note Added: 0009635
2020-03-31 04:05 WA9PIE Testing Not Started => Beta Successful
2020-03-31 04:05 WA9PIE Note Added: 0009636
2020-03-31 04:09 g3ucq Note Added: 0009637
2020-03-31 05:48 WA9PIE Status resolved => closed
2020-03-31 05:48 WA9PIE Note Added: 0009638
2020-04-01 01:32 WA9PIE Fixed in Version 6.7.0.266 => 6.7.0.269
2020-04-01 01:41 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe