View Issue Details

IDProjectCategoryView StatusLast Update
00035913 - Current Dev ListBugpublic2019-11-18 05:01
ReporterWA9PIEAssigned ToWA9PIE 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.7.0.249 
Summary0003591: Invoking a callsign lookup in the ALE forces a switch to the Logbook tab (should stay at current tab)
DescriptionAs of the 6.7.0.247 build...

When you invoke a callsign lookup action in the ALE (by tabbing out of the callsign field or clicking on the "Lookup" button), it forces a switch to the "Logbook" tab of the ALE. It should remain at whatever the current tab is.
Steps To Reproduce- launch Logbook
- I don't really think it matters what callsign lookup choice is enabled
- open an ALE
- put a callsign in the callsign field (WA9PIE is fine) then:
hit the "TAB" key, or...
click the "Lookup" button

BUG: The ALE will then change to the Logbook tab, rather than staying on the tab it was currently on.
Tags6.7 defects
ModuleLogbook
Sub-ModuleALE Window
Testing Beta Successful

Relationships

related to 0003568 closedWA9PIE The Logbook tab in the ALE no longer works 

Activities

DOUG

2019-11-17 17:42

developer   ~0009339

Tabbing out of call sign no longer does the find (and the related tab switch back to logbook).

Hitting "lookup" will trigger a find after it is done, and still forces the tab as it did before.

Changed a bit of the logic on the lookup to get it to work for me (it wasn't populating the name consistently).

Will be in the build later tonight.

DOUG

2019-11-17 22:13

developer   ~0009340

It now....

Does just the find (with no tab switch) ...
When you tabbed out of the field (and it has changed since last find)
every time you hit the lookup button.

Will do the find and switch the tab...
if you hit one of the 3 search buttons (icons with magnifying glass)

WA9PIE

2019-11-18 01:55

administrator   ~0009345

Validated in 6.7.0.249, however...

New bug - tabbing out of the callsign field after entering a call no longer causes the callsign lookup to happen.
New bug - the folder icon (Find) that is next to the Country field no longer is lit (grey'd out).

I can write these up separately.

PD9FER

2019-11-18 03:10

updater   ~0009349

Tested this:
I put WA9PIE in the Callsign box and press TAB
No lookup is happening, the cursor is moving to the 1st RST field

Also confirming the Folder icon issue

g3ucq

2019-11-18 04:59

updater   ~0009358

I confirm PD9FER's find. The TAB key does not work as it did.

WA9PIE

2019-11-18 05:01

administrator   ~0009359

This change validated.

Opened 0003594 for the "tabbing out" issue.

Issue History

Date Modified Username Field Change
2019-11-15 16:29 WA9PIE New Issue
2019-11-15 16:29 WA9PIE Assigned To => DOUG
2019-11-15 16:29 WA9PIE Status new => assigned
2019-11-15 16:31 WA9PIE Tag Attached: 6.7 defects
2019-11-16 16:51 WA9PIE Relationship added related to 0003568
2019-11-17 17:42 DOUG Note Added: 0009339
2019-11-17 22:13 DOUG Status assigned => resolved
2019-11-17 22:13 DOUG Resolution open => fixed
2019-11-17 22:13 DOUG Note Added: 0009340
2019-11-17 22:15 DOUG Assigned To DOUG => WA9PIE
2019-11-18 01:55 WA9PIE Fixed in Version => 6.7.0.249
2019-11-18 01:55 WA9PIE Testing Not Started => Alpha Successful
2019-11-18 01:55 WA9PIE Note Added: 0009345
2019-11-18 03:10 PD9FER Note Added: 0009349
2019-11-18 04:59 g3ucq Note Added: 0009358
2019-11-18 05:01 WA9PIE Status resolved => closed
2019-11-18 05:01 WA9PIE Testing Alpha Successful => Beta Successful
2019-11-18 05:01 WA9PIE Note Added: 0009359