View Issue Details

IDProjectCategoryView StatusLast Update
00035931 - BacklogBugpublic2019-11-18 11:02
Reportervk2byiAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindows 10OSWindows 10 ProOS Version1903
Summary0003593: QRZ.com Upload Fails with Date Range Error
DescriptionAll attempts to upload QSOs to QRZ.com result in an ‘add_qso: outside date range’ internal error when using either v6.7.0.244 or v6.7.0.245 beta.

After reverting to v6.6.0.237, all attempts at QRZ.com uploads work as expected.

I verified that my start and end QSO dates in my logbook properties in QRZ.com are current and valid (1978-11-27 through 2020-12-31).

It may be relevant that I am located in Australia and do not use US date format at the OS level. Instead, I use ISO date format (yyyy-mm-dd).
Steps To Reproduce    1. Install either v6.7.0.244 or v6.7.0.245 beta;
    2. Select a QSO in HRD Logbook and upload it to QRZ.com;
    3. It doesn't matter if a new contact, or an existing contact already in QRZ.com is selected for upload, all attempts fail with an ‘add_qso: outside date range’ internal error.
Additional InformationI have reproduced this in both my normal and testing (VM) environments.

After reverting to v6.6.237, uploading a new contact works, and uploading an existing contact results in a duplicate contact error as expected.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleImport Export
TestingNot Started

Relationships

duplicate of 0003565 closedWA9PIE 3 - Current Dev List Log data upload to QRZ.COM fails with error 

Activities

vk2byi

2019-11-17 20:35

reporter  

QRZ Upload.jpg (114,048 bytes)
QRZ Upload.jpg (114,048 bytes)
QRZ Logbook Properties.jpg (101,832 bytes)
QRZ Logbook Properties.jpg (101,832 bytes)

vk2byi

2019-11-18 04:45

reporter   ~0009352

I spent time making sure I wasn't creating a duplicate before I created this ticket and didn't find 0003565. But that was because I had a filter set with Hide Status set to Closed (and above), hence hiding it from me.

I see that 0003565 was closed with the issue being fixed in 6.7.0.247. I thought we were testing 6.7.0.245, and so I went looking for 6.7.0.247 only to find 6.7.0.249 is now available for test I presume. Maybe 0003565 (or 0003593) should remain open until beta testing off 6.7.0.249 is done. Just my 2c worth.

I will download 6.7.0.249 now and test.

w4elp

2019-11-18 11:02

reporter   ~0009371

6.7.0.249: Confirm QRZ.com Log upload working.

Issue History

Date Modified Username Field Change
2019-11-17 20:35 vk2byi New Issue
2019-11-17 20:35 vk2byi File Added: QRZ Upload.jpg
2019-11-17 20:35 vk2byi File Added: QRZ Logbook Properties.jpg
2019-11-18 03:55 PD9FER Relationship added duplicate of 0003565
2019-11-18 03:56 PD9FER Status new => resolved
2019-11-18 03:56 PD9FER Resolution open => fixed
2019-11-18 03:56 PD9FER Description Updated View Revisions
2019-11-18 03:56 PD9FER Steps to Reproduce Updated View Revisions
2019-11-18 03:56 PD9FER Additional Information Updated View Revisions
2019-11-18 03:56 PD9FER Testing => Not Started
2019-11-18 04:45 vk2byi Note Added: 0009352
2019-11-18 11:02 w4elp Note Added: 0009371