View Issue Details

IDProjectCategoryView StatusLast Update
00035943 - Current Dev ListBugpublic2019-11-20 04:56
ReporterWA9PIEAssigned ToWA9PIE 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.7.0.251 
Summary0003594: Tabbing out of the Callsign field after entering a callsign no longer invokes the Callsign Lookup
DescriptionAs of the 6.7.0.249 build...

Tabbing out of the Callsign field after entering a callsign no longer invokes the Callsign Lookup
Steps To Reproduce- launch Logbook
- probably should ensure that at least QRZ.com is an enabled method (so it will populated the ALE with useful data)
- open the ALE
- enter a callsign (WA9PIE is fine)
- press the TAB key

BUG: The Callsign Lookup is not performed to populate the log entry as it was previously.

(Meanwhile, the "Lookup" button still works. But the TAB key should have the same effect as the "Lookup" button.)
Tags6.7 defects
ModuleLogbook
Sub-ModuleCall lookup
Testing Beta Successful

Activities

DOUG

2019-11-18 17:30

developer   ~0009373

The previous bug I changed it to do the "find" if the call sign was changed.
I will now change it to do the "lookup" and "find"

WA9PIE

2019-11-18 20:00

administrator   ~0009374

Probably a minor clarification, but...

"lookup and find" without changing the current tab (to the Logbook tab)

DOUG

2019-11-19 00:19

developer   ~0009375

right.

It is in the build from tonight. slight change from last build. This search on tabbing out will only happen on "new" logs (not by opening existing ones). Existing ones require you to hit the button.

WA9PIE

2019-11-19 02:53

administrator   ~0009380

Submitted for testing.

g3ucq

2019-11-19 03:43

updater   ~0009381

The TAB key is working however -
Enter a call sign, press the TAB key and a Lookup is made.
With the ALE still open, press Reset and enter the same call sign again.
Press the TAB key and the Lookup does not work.
The TAB key moves to different data entries.
The Lookup button continues to work.
Closing the ALE, reopening and entering the same call sign again the TAB key does work.

PD9FER

2019-11-19 04:26

updater   ~0009384

Confirm the findings of G3UCQ in 250

WA9PIE

2019-11-19 05:04

administrator   ~0009387

I confirm the behavior that's been described regarding the Reset button.

Assigning it back to Doug.

DOUG

2019-11-19 22:28

developer   ~0009406

Ok, to prevent additional lookup/finds I only did it if you changed the call sign. I hadn't factored how this would have worked if you hit reset.

DOUG

2019-11-19 23:01

developer   ~0009407

Fixed. BTW, the reason I did the search only on a change of callsign is so it didn't clear the search users might do on the other 2 find buttons on screen. If we want it to ALWAYS do it (lookup AND find) when we tab out without changes let me know and I can change it.

DOUG

2019-11-19 23:01

developer   ~0009408

BTW, just kicked off build 6.7.0.251 with this fix.

vk2byi

2019-11-20 00:21

updater   ~0009410

I can confirm that pressing the TAB key, or the Call text box losing focus, works for both find and lookup with each change of call. It also works with each change of call after a reset.

However, entering a call, clicking reset and entering the same call again doesn't work. This sequence of events works in v6.6.0237, but most times I hit reset it is to enter a new record with a new call. So I am happy to call this as fixed.

Looking good Doug/Mike.

WA9PIE

2019-11-20 01:39

administrator   ~0009412

This looks good to me. Beta team comments.

PD9FER

2019-11-20 01:55

updater   ~0009417

Confirming Fixed
(also no problems with looking up same call after reset)

g3ypp

2019-11-20 03:24

updater   ~0009419

Fixed for me in .251

g3ucq

2019-11-20 03:50

updater   ~0009423

Fixed for me in .251

WA9PIE

2019-11-20 04:56

administrator   ~0009427

Validated

Issue History

Date Modified Username Field Change
2019-11-18 02:08 WA9PIE New Issue
2019-11-18 02:08 WA9PIE Status new => assigned
2019-11-18 02:08 WA9PIE Assigned To => DOUG
2019-11-18 02:08 WA9PIE Tag Attached: 6.7 defects
2019-11-18 17:30 DOUG Note Added: 0009373
2019-11-18 20:00 WA9PIE Note Added: 0009374
2019-11-19 00:19 DOUG Assigned To DOUG => WA9PIE
2019-11-19 00:19 DOUG Status assigned => resolved
2019-11-19 00:19 DOUG Resolution open => fixed
2019-11-19 00:19 DOUG Note Added: 0009375
2019-11-19 02:53 WA9PIE Fixed in Version => 6.7.0.250
2019-11-19 02:53 WA9PIE Note Added: 0009380
2019-11-19 03:43 g3ucq Note Added: 0009381
2019-11-19 04:26 PD9FER Note Added: 0009384
2019-11-19 05:04 WA9PIE Assigned To WA9PIE => DOUG
2019-11-19 05:04 WA9PIE Status resolved => assigned
2019-11-19 05:04 WA9PIE Note Added: 0009387
2019-11-19 22:28 DOUG Note Added: 0009406
2019-11-19 23:01 DOUG Assigned To DOUG => WA9PIE
2019-11-19 23:01 DOUG Status assigned => resolved
2019-11-19 23:01 DOUG Note Added: 0009407
2019-11-19 23:01 DOUG Note Added: 0009408
2019-11-20 00:21 vk2byi Note Added: 0009410
2019-11-20 01:39 WA9PIE Fixed in Version 6.7.0.250 => 6.7.0.251
2019-11-20 01:39 WA9PIE Note Added: 0009412
2019-11-20 01:55 PD9FER Note Added: 0009417
2019-11-20 03:24 g3ypp Note Added: 0009419
2019-11-20 03:50 g3ucq Note Added: 0009423
2019-11-20 04:56 WA9PIE Status resolved => closed
2019-11-20 04:56 WA9PIE Testing Not Started => Beta Successful
2019-11-20 04:56 WA9PIE Note Added: 0009427